<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<link rel="pingback" href="https://www.linuxnix.com/xmlrpc.php" />
<title>How to check a service is running or not in Linux? - The Linux Juggernaut</title>
<link rel="canonical" href="https://www.linuxnix.com/check-service-running-linux/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to check a service is running or not in Linux? - The Linux Juggernaut" />
<meta property="og:description" content="This is a small &quot;How to&quot; for checking a service is running in the server or not. Some times we need to check the status of a service if it is&nbsp;running or not to cross verify something on server. Suppose you have edited your httpd.conf file and when restarting the service it just show start &hellip;" />
<meta property="og:url" content="https://www.linuxnix.com/check-service-running-linux/" />
<meta property="og:site_name" content="The Linux Juggernaut" />
<meta property="article:author" content="https://www.facebook.com/Linux.Juggernaut/" />
<meta property="article:tag" content="linux-service-status" />
<meta property="article:tag" content="server status" />
<meta property="article:tag" content="service command" />
<meta property="article:section" content="Servers" />
<meta property="article:published_time" content="2011-05-17T01:05:58+00:00" />
<meta property="article:modified_time" content="2015-10-13T19:25:58+00:00" />
<meta property="og:updated_time" content="2015-10-13T19:25:58+00:00" />
<meta property="og:image" content="https://www.linuxnix.com/wp-content/uploads/2011/05/status.jpg" />
<meta property="og:image:secure_url" content="https://www.linuxnix.com/wp-content/uploads/2011/05/status.jpg" />
<meta property="og:image:width" content="642" />
<meta property="og:image:height" content="285" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="This is a small &quot;How to&quot; for checking a service is running in the server or not. Some times we need to check the status of a service if it is&nbsp;running or not to cross verify something on server. Suppose you have edited your httpd.conf file and when restarting the service it just show start [&hellip;]" />
<meta name="twitter:title" content="How to check a service is running or not in Linux? - The Linux Juggernaut" />
<meta name="twitter:image" content="https://www.linuxnix.com/wp-content/uploads/2011/05/status.jpg" />
<meta name="twitter:creator" content="@linuxnix" />
<link rel='dns-prefetch' href='//www.linuxnix.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Feed" href="https://www.linuxnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Comments Feed" href="https://www.linuxnix.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; How to check a service is running or not in Linux? Comments Feed" href="https://www.linuxnix.com/check-service-running-linux/feed/" />
<meta content="Extra v.1.2.4.4" name="generator" /><style>img.wp-smiley,
img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important;}</style>
<link rel="stylesheet" type="text/css" href="//www.linuxnix.com/wp-content/cache/wpfc-minified/3695ff51ac01953bbe380b694ecfec19/1508576908index.css" media="all" />
<link rel='https://api.w.org/' href='https://www.linuxnix.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxnix.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.1" />
<link rel='shortlink' href='https://www.linuxnix.com/?p=899' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxnix.com%2Fcheck-service-running-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxnix.com%2Fcheck-service-running-linux%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<style id="extra-dynamic-styles-primary_nav_text_color-color">#et-menu > li a,
#et-menu > li.menu-item-has-children > a:after,
#et-menu > li.mega-menu-featured > a:after,
#et-extra-mobile-menu > li.mega-menu-featured > a:after{color:rgba(0,0,0,0.6);}</style>
<style id="extra-dynamic-styles-primary_nav_active_link_color-color">#et-menu > li > a:hover,
#et-menu > li.menu-item-has-children > a:hover:after,
#et-menu > li.mega-menu-featured > a:hover:after,
#et-navigation > ul#et-menu > li.current-menu-item > a,
#et-navigation > ul#et-menu > li.current_page_item > a,
#et-extra-mobile-menu > li.mega-menu-featured > a:hover:after,
#et-extra-mobile-menu > li.current-menu-item > a,
#et-extra-mobile-menu > li.current_page_item > a,
#et-extra-mobile-menu > li > a:hover{color:#1e73be;}</style>
<style id="extra-dynamic-styles-primary_nav_active_link_color-background-color">#et-navigation > ul > li > a:before{background-color:#1e73be;}</style>
<style id="extra-dynamic-styles-primary_nav_background_color-background-color">#main-header{background-color:#ffffff;}</style>
<style id="extra-dynamic-styles-button_text_color-color">#page-container .button,
#page-container button,
#page-container button[type="submit"],
#page-container input[type="submit"],
#page-container input[type="reset"],
#page-container input[type="button"],
.read-more-button,
.comment-body .comment_area .comment-content .reply-container .comment-reply-link,
.widget_tag_cloud a,
.widget_tag_cloud a:visited,
.post-nav .nav-links .button,
a.read-more-button,
a.read-more-button:visited,
#footer .widget_tag_cloud a,
#footer .widget_tag_cloud a:visited,
#footer a.read-more-button,
#footer a.read-more-button:visited,
#footer .button,
#footer button,
#footer button[type="submit"],
#footer input[type="submit"],
#footer input[type="reset"],
#footer input[type="button"]{color:rgba(0,0,0,0.6);}</style>
<style id="extra-dynamic-styles-button_hover_text_color-color">#page-container .button:hover,
#page-container button:hover,
#page-container button[type="submit"]:hover,
#page-container input[type="submit"]:hover,
#page-container input[type="reset"]:hover,
#page-container input[type="button"]:hover,
.read-more-button:hover,
.comment-body .comment_area .comment-content .reply-container .comment-reply-link:hover,
.widget_tag_cloud a:hover,
.widget_tag_cloud a:visited:hover,
.post-nav .nav-links .button:hover,
a.read-more-button:hover,
a.read-more-button:visited:hover,
#footer .widget_tag_cloud a:hover,
#footer .widget_tag_cloud a:visited:hover,
#footer a.read-more-button:hover,
#footer a.read-more-button:visited:hover,
#footer .button:hover,
#footer button:hover,
#footer button[type="submit"]:hover,
#footer input[type="submit"]:hover,
#footer input[type="reset"]:hover,
#footer input[type="button"]:hover{color:rgba(0,0,0,0.6);}</style>
<style id="extra-dynamic-styles-extra_nav_height_value">@media only screen and (min-width: 768px) {
#main-header .logo{height:48.45px;margin:23.275px 0;}
.header.left-right #et-navigation > ul > li > a{padding-bottom:39.5px;}
}
@media only screen and (min-width: 768px) {
.et-fixed-header #main-header .logo{height:48.45px;margin:23.275px 0;}
.et-fixed-header .header.left-right #et-navigation > ul > li > a{padding-bottom:39.5px;}
}</style>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-752078-3', 'auto'); ga('send', 'pageview');</script><link rel="icon" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-270x270.png" />
<style id="et-custom-css">@media screen and (max-width: 900px)
{
#main-header .etad{display:none;}
}
#top-header{background-color:#B11B3D;}
.et_pb_extra_module .main-post article .header img, .et_extra_other_module .main-post article .header img{display:block;width:auto;
object-fit:cover;height:158px;width:100%;}
pre{border:1px solid #DDD;overflow:auto;background:#EEE;font-size:.857em;line-height:1.5em;margin-bottom:1.833em;padding:.667em .917em;clear:both;color:#000;}
.posts-blog-feed-module.masonry .post-content{padding:20px !important;}
.author-box{display:none;}
.post-thumbnail img{width:auto;margin:0 auto;}
#disqus_thread{background:#fff;padding:20px;border-radius:3px;box-shadow:0 1px 3px rgba(0,0,0,0.1);box-sizing:border-box;}</style></head>
<body class="post-template-default single single-post postid-899 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right chrome et_includes_sidebar">
<div id="page-container"> <header class="header left-right"> <div id="top-header"> <div class="container"> <div id="et-secondary-nav" class="et-trending"> <div id="et-trending"> <a id="et-trending-button" href="#" title=""> <span></span> <span></span> <span></span> </a> <h4 id="et-trending-label"> TRENDING: </h4> <div id='et-trending-container'> <div id="et-trending-post-1297" class="et-trending-post et-trending-latest"> <a href="https://www.linuxnix.com/sticky-bit-set-linux/">What is a sticky Bit and how to set it in Linux?</a></div><div id="et-trending-post-1264" class="et-trending-post"> <a href="https://www.linuxnix.com/suid-set-suid-linuxunix/">What is SUID and how to set SUID in Linux/Unix?</a></div><div id="et-trending-post-1093" class="et-trending-post"> <a href="https://www.linuxnix.com/linux-top-command-explained-2/">Linux TOP command explained</a></div></div></div></div><div id="et-info"> <ul class="et-extra-social-icons"> <li class="et-extra-social-icon facebook"> <a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a> </li> <li class="et-extra-social-icon twitter"> <a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a> </li> <li class="et-extra-social-icon instagram"> <a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a> </li> </ul> <div class="et-top-search"> <form role="search" class="et-search-form" method="get" action="https://www.linuxnix.com/"> <input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" /> <button class="et-search-submit"></button> </form></div></div></div></div><div id="main-header-wrapper">
<div id="main-header" data-fixed-height="95">
<div class="container">
<a class="logo" href="https://www.linuxnix.com/" data-fixed-height="51">
<img src="https://www.linuxnix.com/wp-content/uploads/2016/08/linux.png" alt="The Linux Juggernaut" id="logo" />
</a>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-7992389594799240" data-ad-slot="3872473351" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><div class="subHeader"> <div class="container"> <div id="et-navigation"> <ul id="et-menu" class="nav"><li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-5531"><a href="https://www.linuxnix.com/category/administration/">Administration</a> <ul class="sub-menu"> <li id="menu-item-5534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5534"><a href="https://www.linuxnix.com/category/administration/monitoring/">Monitoring</a></li> <li id="menu-item-5533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5533"><a href="https://www.linuxnix.com/category/administration/security/">Security</a></li> <li id="menu-item-5532" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5532"><a href="https://www.linuxnix.com/category/administration/servers/">Servers</a></li> </ul> </li> <li id="menu-item-5536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5536"><a href="https://www.linuxnix.com/category/basics/">Basics</a></li> <li id="menu-item-5544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5544"><a href="/category/cloudvirtulization/">Cloud</a> <ul class="sub-menu"> <li id="menu-item-5545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5545"><a href="/category/cloudvirtulization/aws/">AWS</a></li> <li id="menu-item-5540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5540"><a href="https://www.linuxnix.com/category/cloudvirtulization/kvm/">KVM</a></li> </ul> </li> <li id="menu-item-5546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5546"><a href="/category/Devops/">Devops</a> <ul class="sub-menu"> <li id="menu-item-5547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5547"><a href="/category/Devops/Ansible/">Ansible</a></li> <li id="menu-item-5548" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5548"><a href="/category/Devops/Docker/">Docker</a></li> <li id="menu-item-5549" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5549"><a href="/category/Devops/Packer/">Packer</a></li> <li id="menu-item-5550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5550"><a href="/category/Devops/Puppet/">Puppet</a></li> <li id="menu-item-5551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5551"><a href="/category/Devops/Vagrant/">Vagrant</a></li> </ul> </li> <li id="menu-item-5537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5537"><a href="https://www.linuxnix.com/category/interviews-2/">Interviews</a></li> <li id="menu-item-5535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5535"><a href="https://www.linuxnix.com/category/news/">News</a></li> <li id="menu-item-5552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5552"><a href="/category/offers/">Offers</a></li> <li id="menu-item-5553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5553"><a href="/category/Programming/">Programming</a> <ul class="sub-menu"> <li id="menu-item-5554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5554"><a href="/category/Programming/awk/">Awk</a></li> <li id="menu-item-5538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5538"><a href="https://www.linuxnix.com/category/programming/bash/">Bash</a></li> <li id="menu-item-5555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5555"><a href="/category/Programming/Batch/">Batch</a></li> <li id="menu-item-5556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5556"><a href="/category/Programming/git/">Git</a></li> <li id="menu-item-5557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5557"><a href="/category/Programming/Perl/">Perl</a></li> <li id="menu-item-5558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5558"><a href="/category/Programming/PowerShell/">PowerShell</a></li> <li id="menu-item-5539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5539"><a href="https://www.linuxnix.com/category/programming/python/">python</a></li> <li id="menu-item-5559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5559"><a href="/category/Programming/Ruby/">Ruby</a></li> <li id="menu-item-5560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5560"><a href="/category/Programming/Sed/">Sed</a></li> <li id="menu-item-5561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5561"><a href="/category/Programming/SQL/">SQL</a></li> </ul> </li> <li id="menu-item-5562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5562"><a href="/category/Reviews/">Reviews</a> <ul class="sub-menu"> <li id="menu-item-5563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5563"><a href="/category/Reviews/Books/">Books</a></li> <li id="menu-item-5564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5564"><a href="/category/Reviews/Linuxunix/">Linux/Unix</a></li> <li id="menu-item-5565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5565"><a href="/category/reviews/open-source/">Open source</a></li> </ul> </li> <li id="menu-item-5896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5896"><a href="http://corp.linuxnix.com">Mounix Systems</a></li> </ul> <div id="et-mobile-navigation"> <span class="show-menu"> <div class="show-menu-button"> <span></span> <span></span> <span></span></div><p>Select Page</p>
</span>
<nav>
</nav></div></div></div></div></div></div></header>
<div id="main-content"> <div class="container"> <div id="content-area" class="clearfix"> <div class="et_pb_extra_column_main"> <article id="post-899" class="module single-post-module post-899 post type-post status-publish format-standard has-post-thumbnail hentry category-servers tag-linux-service-status tag-server-status tag-service-command et-has-post-format-content et_post_format-et-post-format-standard"> <div class="post-header"> <h1 class="entry-title">How to check a service is running or not in Linux?</h1> <div class="post-meta"> <p>Posted by <a href="https://www.linuxnix.com/author/surendra/" class="url fn" title="Posts by Surendra Anne" rel="author">Surendra Anne</a> | <span class="updated">May 17, 2011</span> | <a href="https://www.linuxnix.com/category/administration/servers/" rel="tag">Servers</a> | <a class="comments-link" href="https://www.linuxnix.com/check-service-running-linux/#comments">12 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 3.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span> <span class="post-meta-icon rating-star rating-star-on rating-star-2"></span> <span class="post-meta-icon rating-star rating-star-on rating-star-3"></span> <span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span> <span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span> </span></p></div></div><div class="post-thumbnail header"> <a href="https://www.linuxnix.com/check-service-running-linux/" title="How to check a service is running or not in Linux?" class="featured-image"> <img src="https://www.linuxnix.com/wp-content/uploads/2011/05/status.jpg" alt="How to check a service is running or not in Linux?" /> </a></div><div class="post-wrap">
<div class="post-content entry-content">
<p>
This is a small "How to" for checking a service is running in the server or not.
</p><div class="advads-middel-of-post" style="text-align: center; margin-top: 18px; margin-bottom: 20px;" id="advads-409408163"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7992389594799240" data-ad-slot="3872473351" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><p>
Some times we need to check the status of a service if it is running or not to cross verify something on server. Suppose you have edited your httpd.conf file and when restarting the service it just show start service is on. But when you try to get access to the web site the site is down. At that time we can use below command to check if Apache service is running or not..
</p>
<p>
<strong>Syntax:</strong>
</p>
<p>
<strong>Method 1: Using service command</strong>
</p>
<pre><strong>#service servicename status</strong>
</pre>
<p>
<strong>Example:</strong>
</p><div class="advads-second Second middle of post" id="secondmiddleofpost"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-7992389594799240" data-ad-slot="1617608518" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><pre><strong>#service httpd status</strong>
</pre>
<p>
clipped output of the above command
</p>
<pre><strong>httpd (pid 7474) is running...</strong>
</pre>
<p>
<strong>Method 2:</strong> Using init.d scripts which are located in /etc/init.d folder
</p>
<p>
<strong>Example:</strong>
</p><div class="advads-content" style="text-align: center; margin-top: 50px; margin-bottom: 50px;" id="advads-1594665958"><a href="https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut" target="_blank"> <img style="max-width:550px;" class="aligncenter" alt="Linuxnix-free-e-book" src="https://i2.wp.com/www.linuxnix.com/wp-content/uploads/2013/01/Linuxnix-free-e-book.png"></a></div><pre><strong>/etc/init.d/cron status</strong>
</pre>
<p>
Clipped output of init.d script:
</p>
<pre><strong>cron start/running, process 1253</strong>
</pre>
<p>
<strong>Method3:</strong> Using status command to check if the service is running or not
</p>
<p>
Example:
</p>
<pre><strong>status atd</strong>
</pre>
<p>
<strong>Output:</strong>
</p>
<pre><strong>atd start/running, process 1245</strong>
</pre>
<p>
<strong>To check all the services state at a time use below command</strong>
</p>
<pre><strong>#service --status-all</strong>
</pre>
<p>
<strong>Note</strong>: Please make a note that due to formating –status-all is shown as -status-all
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.linuxnix.com/dns-troubleshooting-in-linux/" target="_blank" rel="nofollow" class="u9fa89ca1f583df521261c111ddf3280d"><style>.u9fa89ca1f583df521261c111ddf3280d{padding:0px;margin:0;padding-top:1em!important;padding-bottom:1em!important;width:100%;display:block;font-weight:bold;background-color:inherit;border:0!important;border-left:4px solid inherit!important;box-shadow:0 1px 2px rgba(0, 0, 0, 0.17);-moz-box-shadow:0 1px 2px rgba(0, 0, 0, 0.17);-o-box-shadow:0 1px 2px rgba(0, 0, 0, 0.17);-webkit-box-shadow:0 1px 2px rgba(0, 0, 0, 0.17);text-decoration:none;}
.u9fa89ca1f583df521261c111ddf3280d:active, .u9fa89ca1f583df521261c111ddf3280d:hover{opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;text-decoration:none;}
.u9fa89ca1f583df521261c111ddf3280d{transition:background-color 250ms;webkit-transition:background-color 250ms;opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;}
.u9fa89ca1f583df521261c111ddf3280d .ctaText{font-weight:bold;color:inherit;text-decoration:none;font-size:16px;}
.u9fa89ca1f583df521261c111ddf3280d .postTitle{color:inherit;text-decoration:underline!important;font-size:16px;}
.u9fa89ca1f583df521261c111ddf3280d:hover .postTitle{text-decoration:underline!important;}</style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">Related concept: </span>&nbsp; <span class="postTitle">DNS Troubleshooting in Linux</span></div></a></div></p>
<p>
Please comment on this if you have any other way to check the status of a service.</p></div></div><div class="post-footer"> <div class="social-icons ed-social-share-icons"> <p class="share-title">Share:</p> <a href="https://www.facebook.com/sharer.php?u=https://www.linuxnix.com/check-service-running-linux/&#038;t=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Facebook" data-network-name="facebook" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span> </a><a href="https://twitter.com/home?status=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F%20https://www.linuxnix.com/check-service-running-linux/" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Twitter" data-network-name="twitter" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span> </a><a href="https://plus.google.com/share?url=https://www.linuxnix.com/check-service-running-linux/&#038;t=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Google +" data-network-name="googleplus" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span> </a><a href="https://www.tumblr.com/share?v=3&#038;u=https://www.linuxnix.com/check-service-running-linux/&#038;t=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Tumblr" data-network-name="tumblr" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover"></span> </a><a href="https://www.pinterest.com/pin/create/button/?url=https://www.linuxnix.com/check-service-running-linux/&#038;description=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Pinterest" data-network-name="pinterest" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span> </a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.linuxnix.com/check-service-running-linux/&#038;title=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via LinkedIn" data-network-name="linkedin" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span> </a><a href="https://bufferapp.com/add?url=https://www.linuxnix.com/check-service-running-linux/&#038;title=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Buffer" data-network-name="buffer" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover"></span> </a><a href="http://www.stumbleupon.com/badge?url=https://www.linuxnix.com/check-service-running-linux/&#038;title=How%20to%20check%20a%20service%20is%20running%20or%20not%20in%20Linux%3F" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Email" data-network-name="basic_email" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span> </a><a href="#" class="social-share-link" title="Share &quot;How to check a service is running or not in Linux?&quot; via Print" data-network-name="basic_print" data-share-title="How to check a service is running or not in Linux?" data-share-url="https://www.linuxnix.com/check-service-running-linux/"> <span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span> </a></div><div class="rating-stars"> <p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="899" /></div><style id="rating-stars">.post-footer .rating-stars #rated-stars img.star-on,
.post-footer .rating-stars #rating-stars img.star-on{background-color:#8bd623;}</style></div></article>
<nav class="post-nav">
<div class="nav-links clearfix"> <div class="nav-link nav-link-prev"> <a href="https://www.linuxnix.com/yum-rpm/" rel="prev"><span class="button">Previous</span><span class="title">YUM vs RPM in Linux</span></a></div><div class="nav-link nav-link-next"> <a href="https://www.linuxnix.com/find-ram-utilization-user-linux/" rel="next"><span class="button">Next</span><span class="title">How to find RAM utilization by user in Linux</span></a></div></div></nav>
<div class="et_extra_other_module author-box vcard"> <div class="author-box-header"> <h3>About The Author</h3></div><div class="author-box-content clearfix"> <div class="author-box-avatar photo"> <img alt='' src='https://secure.gravatar.com/avatar/8f71515aab81c5a2f6b9a2f414e347eb?s=170&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8f71515aab81c5a2f6b9a2f414e347eb?s=340&#038;d=mm&#038;r=g 2x' class='avatar avatar-170 photo' height='170' width='170' /></div><div class="author-box-description"> <h4><a class="author-link url fn" href="https://www.linuxnix.com/author/surendra/" rel="author" title="">Surendra Anne</a></h4> <p class="note"><p>Mr Surendra Anne is from Vijayawada, Andhra Pradesh, India. He is a Linux/Open source supporter who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. He works as Devops Engineer with Taggle systems, an IOT automatic water metering company, Sydney . You can contact him at surendra (@) linuxnix dot com.</p> </p> <ul class="social-icons"> <li><a href="https://www.facebook.com/Linux.Juggernaut/" target="_blank"><span class="et-extra-icon et-extra-icon-facebook et-extra-icon-color-hover"></span></a></li> <li><a href="http://linuxnix" target="_blank"><span class="et-extra-icon et-extra-icon-twitter et-extra-icon-color-hover"></span></a></li> <li><a href="https://www.facebook.com/Linux.Juggernaut/" target="_blank"><span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-color-hover"></span></a></li> </ul></div></div></div><div class="et_extra_other_module related-posts"> <div class="related-posts-header"> <h3>Related Posts</h3></div><div class="related-posts-content clearfix"> <div class="related-post"> <div class="featured-image"><a href="https://www.linuxnix.com/webmin-installation-in-linuxunix/" title="How to install Webmin and configure it in Linux" class="post-thumbnail"> <img src="https://www.linuxnix.com/wp-content/uploads/2010/01/webmin-logo.png" alt="How to install Webmin and configure it in Linux" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.linuxnix.com/webmin-installation-in-linuxunix/">How to install Webmin and configure it in Linux</a></h4>
<p class="date"><span class="updated">January 23, 2010</span></p></div><div class="related-post"> <div class="featured-image"><a href="https://www.linuxnix.com/check-status-services-linux-shell-script/" title="Check Status Of All Services In Linux" class="post-thumbnail"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Check Status Of All Services In Linux" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.linuxnix.com/check-status-services-linux-shell-script/">Check Status Of All Services In Linux</a></h4>
<p class="date"><span class="updated">February 3, 2011</span></p></div><div class="related-post"> <div class="featured-image"><a href="https://www.linuxnix.com/mail-system-explained/" title="Mail system explained" class="post-thumbnail"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Mail system explained" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.linuxnix.com/mail-system-explained/">Mail system explained</a></h4>
<p class="date"><span class="updated">June 10, 2009</span></p></div><div class="related-post"> <div class="featured-image"><a href="https://www.linuxnix.com/dns-troubleshooting-in-linux/" title="DNS Troubleshooting in Linux" class="post-thumbnail"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="DNS Troubleshooting in Linux" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.linuxnix.com/dns-troubleshooting-in-linux/">DNS Troubleshooting in Linux</a></h4>
<p class="date"><span class="updated">May 29, 2009</span></p></div></div></div><div id="disqus_thread"> <div id="dsq-content"> <ul id="dsq-comments"> <li class="comment even thread-even depth-1" id="dsq-comment-575"> <div id="dsq-comment-header-575" class="dsq-comment-header"> <cite id="dsq-cite-575"> <span id="dsq-author-user-575">Kuldeep Sharma</span> </cite></div><div id="dsq-comment-body-575" class="dsq-comment-body"> <div id="dsq-comment-message-575" class="dsq-comment-message"><p>There is another way.<br /> You can check by issuing following command.<br /> /etc/init.d/servicename status<br /> Some times you don&#8217;t know the exact name of service, It those situations, I think this&#8217;ll be helpfull. </p></div></div><ul class="children"> <li class="comment odd alt depth-2" id="dsq-comment-576"> <div id="dsq-comment-header-576" class="dsq-comment-header"> <cite id="dsq-cite-576"> <a id="dsq-author-user-576" href="https://www.linuxnix.com" target="_blank" rel="nofollow">Surendra</a> </cite></div><div id="dsq-comment-body-576" class="dsq-comment-body"> <div id="dsq-comment-message-576" class="dsq-comment-message"><p>Ya thats true.. thanks for making a point Kuldeep</p></div></div></li>
</ul>
</li>
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-577"> <div id="dsq-comment-header-577" class="dsq-comment-header"> <cite id="dsq-cite-577"> <span id="dsq-author-user-577">Guest</span> </cite></div><div id="dsq-comment-body-577" class="dsq-comment-body"> <div id="dsq-comment-message-577" class="dsq-comment-message"><p>its very help ful ..keep on updating <br /> thanks </p></div></div></li>
<li class="comment odd alt thread-even depth-1" id="dsq-comment-578"> <div id="dsq-comment-header-578" class="dsq-comment-header"> <cite id="dsq-cite-578"> <a id="dsq-author-user-578" href="https://kamalkakkar.wordpress.com" target="_blank" rel="nofollow">kamal kakkar</a> </cite></div><div id="dsq-comment-body-578" class="dsq-comment-body"> <div id="dsq-comment-message-578" class="dsq-comment-message"><p>Lovely command&#8230;..</p></div></div></li>
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-579"> <div id="dsq-comment-header-579" class="dsq-comment-header"> <cite id="dsq-cite-579"> <span id="dsq-author-user-579">Quoc-Son</span> </cite></div><div id="dsq-comment-body-579" class="dsq-comment-body"> <div id="dsq-comment-message-579" class="dsq-comment-message"><p>To add to your article, you need to specify which Linux distribution and/or version that you are using to run the service command or you can use the general command as suggested by Kulpdeep. </p> <p>I have chance to use 3 distribution: Ubuntu, Centos/Redhat, and SUSE, I can tell that some of the files or commands are not common for all of Linux distribution, especially for network interface configuration.</p> <p>Anyway, nice work.</p></div></div><ul class="children"> <li class="comment byuser comment-author-surendra bypostauthor odd alt depth-2" id="dsq-comment-580"> <div id="dsq-comment-header-580" class="dsq-comment-header"> <cite id="dsq-cite-580"> <a id="dsq-author-user-580" href="https://www.linuxnix.com" target="_blank" rel="nofollow">Surendra Anne</a> </cite></div><div id="dsq-comment-body-580" class="dsq-comment-body"> <div id="dsq-comment-message-580" class="dsq-comment-message"><p>Quoc,</p> <p> Updated the post with other commands as well suggested by you and Kuldeep. </p> <p>Thanks.</p></div></div><ul class="children"> <li class="comment even depth-3" id="dsq-comment-585"> <div id="dsq-comment-header-585" class="dsq-comment-header"> <cite id="dsq-cite-585"> <a id="dsq-author-user-585" href="http://dtecter.co.za" target="_blank" rel="nofollow">lebogang</a> </cite></div><div id="dsq-comment-body-585" class="dsq-comment-body"> <div id="dsq-comment-message-585" class="dsq-comment-message"><p>good day i am having this problem when i try to logg in mysql: ERROR 2002 (HY000): Can&#8217;t connect to local MySQL server through socket &#8216;/var/lib/mysql/mysql.sock&#8217; (111)<br /> please send me an emial <a href="/cdn-cgi/l/email-protection#0c616d6063657f6d626960696e636b6d626b4c756d646363226f6361"><span class="__cf_email__" data-cfemail="99f4f8f5f6f0eaf8f7fcf5fcfbf6fef8f7fed9e0f8f1f6f6b7faf6f4">[email&#160;protected]</span></a> please please help</p></div></div></li>
</ul>
</li>
</ul>
</li>
<li class="comment odd alt thread-even depth-1" id="dsq-comment-581"> <div id="dsq-comment-header-581" class="dsq-comment-header"> <cite id="dsq-cite-581"> <span id="dsq-author-user-581">Farhaaz</span> </cite></div><div id="dsq-comment-body-581" class="dsq-comment-body"> <div id="dsq-comment-message-581" class="dsq-comment-message"><p>very good commands helpful for beginners&#8230;</p> <p>Thanks very much.</p></div></div></li>
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-582"> <div id="dsq-comment-header-582" class="dsq-comment-header"> <cite id="dsq-cite-582"> <span id="dsq-author-user-582">UMER AZEEM</span> </cite></div><div id="dsq-comment-body-582" class="dsq-comment-body"> <div id="dsq-comment-message-582" class="dsq-comment-message"><p>Nice Sharing For Bignners Like me&#8230;..Thanks</p></div></div></li>
<li class="comment odd alt thread-even depth-1" id="dsq-comment-583"> <div id="dsq-comment-header-583" class="dsq-comment-header"> <cite id="dsq-cite-583"> <span id="dsq-author-user-583">Satya</span> </cite></div><div id="dsq-comment-body-583" class="dsq-comment-body"> <div id="dsq-comment-message-583" class="dsq-comment-message"><p>To check all the services state at a time use below command</p> <p>#service &#8211;status-all</p></div></div><ul class="children"> <li class="comment even depth-2" id="dsq-comment-584"> <div id="dsq-comment-header-584" class="dsq-comment-header"> <cite id="dsq-cite-584"> <span id="dsq-author-user-584">Satya</span> </cite></div><div id="dsq-comment-body-584" class="dsq-comment-body"> <div id="dsq-comment-message-584" class="dsq-comment-message"><p>#service &#8211;status-all</p></div></div></li>
</ul>
</li>
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-586"> <div id="dsq-comment-header-586" class="dsq-comment-header"> <cite id="dsq-cite-586"> <span id="dsq-author-user-586">Steve</span> </cite></div><div id="dsq-comment-body-586" class="dsq-comment-body"> <div id="dsq-comment-message-586" class="dsq-comment-message"><p> Is there a way to test a service that was modified in the vi editor before restarting that service?&nbsp; I needed to modify a service by adding some information , but when I try to restart that service for the changes to take effect it failed to start.&nbsp; Thanks for help.&nbsp;</p></div></div></li>
</li>
</li>
</li>
</li>
</ul></div></div></div><div class="et_pb_extra_column_sidebar"> <div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Our supporters</h4><div class="textwidget custom-html-widget"></div></div><div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://www.linuxnix.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /> </form></div><div id="wp_subscribe-2" class="et_pb_widget wp_subscribe"> <div id="wp-subscribe" class="wp-subscribe-wrap wp-subscribe wp-subscribe-1" data-thanks_page="0" data-thanks_page_url="" data-thanks_page_new_window="0"> <h4 class="title">Get more stuff like this<br /> <span>in your inbox</span></h4> <p class="text">Subscribe to our mailing list and get interesting stuff and updates to your email inbox.</p> <form action="https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut" method="post" class="wp-subscribe-form wp-subscribe-feedburner" id="wp-subscribe-form-1" target="popupwindow"> <input class="regular-text email-field" type="text" name="email" placeholder="Enter your email here"> <input type="hidden" name="uri" value="TheLinuxJuggernaut"> <input type="hidden" name="loc" value="en_US"> <input type="hidden" name="form_type" value="widget"> <input type="hidden" name="service" value="feedburner"> <input type="hidden" name="widget" value="wp_subscribe-2"> <input class="submit" type="submit" name="submit" value="Sign Up Now"> </form> <div class="wp-subscribe-loader"> <svg version="1.1" id="loader-1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0" y="0" width="40px" height="40px" viewBox="0 0 50 50" style="enable-background:new 0 0 50 50;" xml:space="preserve"> <path fill="" d="M43.935,25.145c0-10.318-8.364-18.683-18.683-18.683c-10.318,0-18.683,8.365-18.683,18.683h4.068c0-8.071,6.543-14.615,14.615-14.615c8.072,0,14.615,6.543,14.615,14.615H43.935z"> <animateTransform attributeType="xml" attributeName="transform" type="rotate" from="0 25 25" to="360 25 25" dur="0.6s" repeatCount="indefinite" /> </path> </svg></div><p class="thanks">Thank you for subscribing.</p>
<p class="error">Something went wrong.</p>
<div class="clear"></div><p class="footer-text">we respect your privacy and take protecting it seriously</p></div></div><div id="et_social_followers-3" class="et_pb_widget widget_et_social_followers"><h4 class="widgettitle">Follow Us</h4> <div class="widget_content"> <ul class="widget_list"> <li> <a class="et-extra-icon et-extra-icon-facebook et-extra-icon-background social-icon" href="https://www.facebook.com/Linux.Juggernaut/"></a> <a href="https://www.facebook.com/Linux.Juggernaut/" class="widget_list_social"> <h3 class="title">Facebook</h3> </a> </li> <li> <a class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background social-icon" href="https://plus.google.com/+Linuxnix"></a> <a href="https://plus.google.com/+Linuxnix" class="widget_list_social"> <h3 class="title">Google+</h3> </a> </li> <li> <a class="et-extra-icon et-extra-icon-twitter et-extra-icon-background social-icon" href="https://twitter.com/LINUXNIX"></a> <a href="https://twitter.com/LINUXNIX" class="widget_list_social"> <h3 class="title">Twitter</h3> <span class="post-meta">704 followers</span> </a> </li> </ul></div></div><div id="et-recent-posts-3" class="et_pb_widget widget_et_recent_entries"> <h4 class="widgettitle">Recent Posts</h4> <ul class="widget_list"> <li> <a href="https://www.linuxnix.com/10-file-globbing-examples-linux-unix/" title="10 File Globbing examples in Linux/Unix" class="widget_list_thumbnail" style="background-color:#8bd623"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="10 File Globbing examples in Linux/Unix" style="background-color:#8bd623" /> </a> <div class="post_info"> <a href="https://www.linuxnix.com/10-file-globbing-examples-linux-unix/" class="title">10 File Globbing examples in Linux/Unix</a> <div class="post-meta"> <span class="updated">Dec 1, 2017</span> | <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a></div></div></li>
<li> <a href="https://www.linuxnix.com/16-tr-command-examples-in-linux-unix/" title="18 tr command examples in linux/Unix" class="widget_list_thumbnail" style="background-color:#8bd623"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="18 tr command examples in linux/Unix" style="background-color:#8bd623" /> </a> <div class="post_info"> <a href="https://www.linuxnix.com/16-tr-command-examples-in-linux-unix/" class="title">18 tr command examples in linux/Unix</a> <div class="post-meta"> <span class="updated">Nov 30, 2017</span> | <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a></div></div></li>
<li> <a href="https://www.linuxnix.com/installing-configuring-firewalld-linux/" title="How to Installing and Configuring Firewalld on Linux" class="widget_list_thumbnail" style="background-color:#8bd623"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="How to Installing and Configuring Firewalld on Linux" style="background-color:#8bd623" /> </a> <div class="post_info"> <a href="https://www.linuxnix.com/installing-configuring-firewalld-linux/" class="title">How to Installing and Configuring Firewalld on Linux</a> <div class="post-meta"> <span class="updated">Nov 29, 2017</span> | <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a></div></div></li>
<li> <a href="https://www.linuxnix.com/12-wget-command-examples/" title="12 wget command examples in Linux/Unix" class="widget_list_thumbnail" style="background-color:#7ac8cc"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="12 wget command examples in Linux/Unix" style="background-color:#7ac8cc" /> </a> <div class="post_info"> <a href="https://www.linuxnix.com/12-wget-command-examples/" class="title">12 wget command examples in Linux/Unix</a> <div class="post-meta"> <span class="updated">Nov 28, 2017</span> | <a href="https://www.linuxnix.com/category/administration/" rel="tag">Administration</a>, <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a></div></div></li>
<li> <a href="https://www.linuxnix.com/18-curl-command-examples/" title="18 curl command examples in Linux/Unix" class="widget_list_thumbnail" style="background-color:#7ac8cc"> <img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="18 curl command examples in Linux/Unix" style="background-color:#7ac8cc" /> </a> <div class="post_info"> <a href="https://www.linuxnix.com/18-curl-command-examples/" class="title">18 curl command examples in Linux/Unix</a> <div class="post-meta"> <span class="updated">Nov 27, 2017</span> | <a href="https://www.linuxnix.com/category/administration/" rel="tag">Administration</a>, <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a></div></div></li>
</ul></div><div id="et-recent-comments-3" class="et_pb_widget widget_et_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments" class="widget_list"><li class="recentcomments"><span class="author"><a href="https://www.linuxnix.com" rel='external nofollow' class='url'>Surendra</a></span> <div class="post-title">on <a href="https://www.linuxnix.com/understanding-awsamazon-web-services-cloud-part/#comment-2531">Understanding AWS(Amazon Web services) &#8220;The Cloud&#8221; Part &#8211; I</a></div></li><li class="recentcomments"><span class="author">Max Ntshinga</span> <div class="post-title">on <a href="https://www.linuxnix.com/understanding-awsamazon-web-services-cloud-part/#comment-2530">Understanding AWS(Amazon Web services) &#8220;The Cloud&#8221; Part &#8211; I</a></div></li><li class="recentcomments"><span class="author">Otto Adelfang</span> <div class="post-title">on <a href="https://www.linuxnix.com/docker-container-mind-map-you-should-have/#comment-2529">Docker mind map for easy understanding</a></div></li><li class="recentcomments"><span class="author"><a href="https://www.linuxnix.com" rel='external nofollow' class='url'>Surendra</a></span> <div class="post-title">on <a href="https://www.linuxnix.com/important-port-numbers-linux-system-administrator/#comment-2435">Important Port numbers for the Linux system administrator</a></div></li><li class="recentcomments"><span class="author">Uchechukwu Okeke</span> <div class="post-title">on <a href="https://www.linuxnix.com/linux-directory-structure-explained-boot-folder/#comment-2434">Linux Directory Structure explained: /boot folder</a></div></li></ul></div><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">ABOUT ME..!</h4> <div class="textwidget"><p><a href="/wp-content/uploads/2010/05/My-photo.jpg"><img class="alignnone size-full wp-image-2382" src="/wp-content/uploads/2010/05/My-photo.jpg" alt="My photo"></a><br /> My name is Surendra Kumar Anne. I hail from Vijayawada which is cultural capital of south Indian state of Andhra Pradesh. I am a Linux evangelist who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. At present I work at Bank of America as Sr. Analyst Systems and Administration. You can contact me at surendra (@) linuxnix dot com.</p></div></div><div id="insticator-embed-3" class="et_pb_widget insticator-embed-class"><div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div></div></div></div></div></div></div><footer id="footer" class="footer_columns_2">
<div id="footer-bottom"> <div class="container"> <div id="footer-nav"> <ul id="footer-menu" class="bottom-nav"><li id="menu-item-5405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="https://www.linuxnix.com/contact-us/">Contact Us</a></li> <li id="menu-item-3350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="https://www.linuxnix.com/testimonials/">Testimonials</a></li> <li id="menu-item-6050" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6050"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li> <li id="menu-item-3347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="https://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li> <li id="menu-item-3349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="https://www.linuxnix.com/contribute/">Contribute</a></li> <li id="menu-item-5341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="https://www.linuxnix.com/editorial-board/">Editorial team</a></li> <li id="menu-item-5342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="https://www.linuxnix.com/support-us/">Support us</a></li> <li id="menu-item-5382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li> </ul> <ul class="et-extra-social-icons"> <li class="et-extra-social-icon facebook"> <a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a> </li> <li class="et-extra-social-icon twitter"> <a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a> </li> <li class="et-extra-social-icon instagram"> <a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a> </li> </ul></div></div></div></footer></div><script data-cfasync="false" src="/cdn-cgi/scripts/ddc5a536/cloudflare-static/email-decode.min.js"></script><script>var advanced_ads_adsense_UID=false;
;advanced_ads_check_adblocker=(function(callback){
var pending_callbacks=[];
var is_enabled=null;
function RAF(RAF_callback){
var fn=window.requestAnimationFrame
|| window.mozRequestAnimationFrame
|| window.webkitRequestAnimationFrame
|| function(RAF_callback){ return setTimeout(RAF_callback, 16); };
fn.call(window, RAF_callback);
}
RAF(function(){
var ad=document.createElement('div');
ad.innerHTML='&nbsp;';
ad.setAttribute('class', 'ad_unit ad-unit text-ad text_ad pub_300x250');
ad.setAttribute('style', 'width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;');
document.body.appendChild(ad);
RAF(function(){
var styles=window.getComputedStyle&&window.getComputedStyle(ad);
var moz_binding=styles&&styles.getPropertyValue('-moz-binding');
is_enabled=(styles&&styles.getPropertyValue('display')==='none')
||(typeof moz_binding==='string'&&moz_binding.indexOf('about:')!==-1);
for(var i=0; i < pending_callbacks.length; i++){
pending_callbacks[ i ](is_enabled);
}
pending_callbacks=[];
});
});
return function(callback){
if(is_enabled===null){
pending_callbacks.push(callback);
return;
}
callback(is_enabled);
}}());
(function(){
var advadsTracker=function(name, UID){
this.name=name;
this.UID=UID;
this.analyticsObject=null;
var that=this;
var data={
hitType: 'event',
eventCategory: 'Advanced Ads',
eventAction: 'AdBlock',
eventLabel: 'Yes',
nonInteraction: true,
transport: 'beacon'
};
this.analyticsObject=('string'==typeof(GoogleAnalyticsObject)&&'function'==typeof(window[GoogleAnalyticsObject]))? window[GoogleAnalyticsObject]:false;
if(false===this.analyticsObject){
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','_advads_ga');
_advads_ga('create', that.UID, 'auto', this.name);
_advads_ga(that.name + '.send', data);
}else{
window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `" + GoogleAnalyticsObject + "`");
window[GoogleAnalyticsObject]('create', that.UID, 'auto', this.name);
window[GoogleAnalyticsObject](that.name + '.send', data);
}}
advanced_ads_check_adblocker(function(is_enabled){
if(is_enabled&&'string'===typeof advanced_ads_adsense_UID&&advanced_ads_adsense_UID){
new advadsTracker('advadsTracker', advanced_ads_adsense_UID);
}});
}());</script> <style id="inc-opt-styles">.inc_optin_1 .wpoi-hustle .wpoi-optin{background:#38454E;}
.inc_optin_1 .wpoi-hustle h2.wpoi-title{color:#FDFDFD;}
.inc_optin_1 .wpoi-hustle .wpoi-message p a{color:#38C5B5;}
.inc_optin_1 .wpoi-hustle .wpoi-message, .inc_optin_1.wpoi-hustle .wpoi-message p{color:#ADB5B7;}
.inc_optin_1 .wpoi-hustle .wpoi-message p a:hover{color:#49E2D1;}
.inc_optin_1 .wpoi-hustle .wpoi-form{background:#5D7380;}
.inc_optin_1 .wpoi-hustle form .wpoi-element{background:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form .wpoi-element:hover{background:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form .wpoi-element:active, .inc_optin_1.wpoi-hustle form .wpoi-element:focus{background:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form .wpoi-element label, .inc_optin_1.wpoi-hustle form .wpoi-element label span, .inc_optin_1.wpoi-hustle form .wpoi-element label span, .inc_optin_1.wpoi-hustle form .wphi-font{color:#ADB5B7;}
.inc_optin_1 .wpoi-hustle form button{background:#38C5B5;}
.inc_optin_1 .wpoi-hustle form button{color:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form > .wpoi-element input{color:#363B3F;}
.inc_optin_1 .wpoi-hustle form > .wpoi-element input:hover{color:#363B3F;}
.inc_optin_1 .wpoi-hustle form > .wpoi-element input:active, .inc_optin_1.wpoi-hustle form > .wpoi-element input:focus{color:#363B3F;}
.inc_optin_1 .wpoi-hustle form .i-error, .inc_optin_1.wpoi-hustle form .i-error + span{color:#C63D2B;}
.inc_optin_1 .wpoi-hustle form button:hover{background:#49E2D1;}
.inc_optin_1 .wpoi-hustle form button:active, .inc_optin_1.wpoi-hustle form button:focus{background:#49E2D1;}
.inc_optin_1 .wpoi-hustle form button:hover{color:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form button:active, .inc_optin_1.wpoi-hustle form button:focus{color:#FDFDFD;}
.inc_optin_1 .wpoi-hustle .wpoi-success-message .wphi-font{color:#38C5B5;}
.inc_optin_1 .wpoi-hustle .wpoi-success-message .wpoi-content, .inc_optin_1.wpoi-hustle .wpoi-success-message .wpoi-content p{color:#FDFDFD;}
.inc_optin_1 a.inc-opt-close-btn, .inc_optin_1a.inc-opt-close-btn:visited{color:#38C5B5;}
.inc_optin_1 .wpoi-nsa > a, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again{color:#38C5B5;}
.inc_optin_1 .wpoi-popup-overlay{background:rgba(54,59,63,0.8);}
.inc_optin_1 a.inc-opt-close-btn:hover{color:#38C5B5;}
.inc_optin_1 a.inc-opt-close-btn:active, .inc_optin_1a.inc-opt-close-btn:focus{color:#38C5B5;}
.inc_optin_1 .wpoi-nsa > a:hover, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again:hover{color:#38C5B5;}
.inc_optin_1 .wpoi-nsa > a:active, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again:active, .inc_optin_1.wpoi-nsa > a:focus, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again:focus{color:#38C5B5;}
.inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="radio"] + label:before{background:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="radio"] + label:after{background:#38C5B5;}
.inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="checkbox"] + label:before{background:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="checkbox"]:checked + label:before{color:#38C5B5;}
.inc_optin_1 .wpoi-hustle form .wpoi-mcg-list-name, .inc_optin_1.wpoi-hustle .wpoi-submit-failure{color:#FDFDFD;}
.inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="checkbox"] + label, .inc_optin_1.wpoi-hustle form .wpoi-mcg-option input[type="radio"] + label{color:#ADB5B7;}
.inc_optin_1 .wpoi-success-icon path{fill:#1FC5B6}
.inc_optin_1 .wpoi-hustle .wpoi-optin{box-shadow:0px 0px 0px #000000}
.inc_optin_1 .wpoi-hustle .wpoi-optin{border-radius:0px;}
.inc_optin_1 .wpoi-hustle form button{border-radius:0px !important;}
.inc_optin_1 .wpoi-hustle form .wpoi-element{border-radius:0px;}
.wpmui-popup.inc_optin_1{border-radius:0px;}</style>
<style id="hustle-cc-styles"></style>
<link rel="stylesheet" type="text/css" href="//www.linuxnix.com/wp-content/cache/wpfc-minified/991a1ee5318ae3445b053af804fe457a/1508576831index.css" media="all" />
<link rel='stylesheet' id='extra-fonts-css' wpfc-href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<script>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</script>
<script>var viewsCacheL10n={"admin_ajax_url":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","post_id":"899"};</script>
<script>var EXTRA={"images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","rating_nonce":"cac881fa8a","timeline_nonce":"5a7bf7a3c6","blog_feed_nonce":"b88bc05530","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address."};</script>
<script>var et_pb_custom={"ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"8130b8bc1b","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","is_divi_theme_used":"","widget_search_selector":".widget_search"};</script>
<script>var embedVars={"disqusConfig":{"platform":"wordpress@4.9.1","language":""},"disqusIdentifier":"899 http:\/\/www.linuxnix.com\/?p=899","disqusShortname":"linuxnix","disqusTitle":"How to check a service is running or not in Linux?","disqusUrl":"https:\/\/www.linuxnix.com\/check-service-running-linux\/","options":{"manualSync":false},"postId":"899"};</script>
<script>var wp_subscribe={"ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php"};</script>
<script>var countVars={"disqusShortname":"linuxnix"};</script>
<!--[if lt IE 9]><script src="//www.linuxnix.com/wp-content/cache/wpfc-minified/8aaba934e9b3cb4b799fb476d4cae8e4/1507860977index.js" type="text/javascript"></script><![endif]-->
<script>document.documentElement.className='js';</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.linuxnix.com\/","name":"The Linux Juggernaut","alternateName":"roles on..!","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.linuxnix.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Person","url":"https:\/\/www.linuxnix.com\/check-service-running-linux\/","sameAs":[],"@id":"#person","name":"Surendra Anne"}</script>
<script src='//www.linuxnix.com/wp-content/cache/wpfc-minified/38a19a21d2f92b48e5b73f50eacd3483/1507916241index.js' type="text/javascript"></script>
<!--[if IE]><script type='text/javascript' src='//www.linuxnix.com/wp-content/cache/wpfc-minified/a96470169428ea13176e5f1254665546/1507860977index.js'></script><![endif]-->
<script data-cfasync='false'>(function (a, c, s, u){'Insticator'in a||(a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "5.5", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}});var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/a30dc085-55ae-4bb0-9e46-774d36a290eb.js');</script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
<script>window.OneSignal=window.OneSignal||[];
OneSignal.push(function(){
OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";
OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";
OneSignal.SERVICE_WORKER_PARAM={ scope: '/' };
OneSignal.setDefaultNotificationUrl("https://www.linuxnix.com");
var oneSignal_options={};
window._oneSignalInitOptions=oneSignal_options;
oneSignal_options['wordpress']=true;
oneSignal_options['appId']='348fde8d-723d-4dd8-b8ac-2d123ca69f0a';
oneSignal_options['autoRegister']=true;
oneSignal_options['welcomeNotification']={ };
oneSignal_options['welcomeNotification']['title']="";
oneSignal_options['welcomeNotification']['message']="";
oneSignal_options['subdomainName']="linuxnix";
oneSignal_options['promptOptions']={ };
oneSignal_options['notifyButton']={ };
oneSignal_options['notifyButton']['enable']=true;
oneSignal_options['notifyButton']['position']='bottom-right';
oneSignal_options['notifyButton']['theme']='default';
oneSignal_options['notifyButton']['size']='medium';
oneSignal_options['notifyButton']['prenotify']=true;
oneSignal_options['notifyButton']['showCredit']=false;
oneSignal_options['notifyButton']['text']={};
oneSignal_options['notifyButton']['text']['message.prenotify']='Get free Linux/Devops updates to you directly';
OneSignal.init(window._oneSignalInitOptions);
});
function documentInitOneSignal(){
var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");
var oneSignalLinkClickHandler=function(event){ OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i=0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
}
if(document.readyState==='complete'){
documentInitOneSignal();
}else{
window.addEventListener("load", function(event){
documentInitOneSignal();
});
}</script>
<script>(function(){
var lkqdSettings={
pid: 124,
sid: 567585,
playerContainerId: 'ad' + Math.round(Math.random()*1000000000).toString(),
playerId: '',
playerWidth: 300,
playerHeight: 250,
execution: 'inbanner',
placement: '',
passbackFirst: false,
playInitiation: 'auto',
volume: 0,
pageUrl: '',
trackImp: '',
trackClick: '',
custom1: '',
custom2: '',
custom3: '',
pubMacros: '',
dfp: false,
lkqdId: new Date().getTime().toString() + Math.round(Math.random()*1000000000).toString(),
supplyContentVideo: {
url: '', clickurl: '', play: 'pre'
}};
var lkqdVPAID;
var creativeData='';
if(!document.getElementById(lkqdSettings.playerContainerId)){ try { if(document.readyState&&document.readyState!='complete'&&document.readyState!='interactive'){ document.write('<div id=' + lkqdSettings.playerContainerId + '></div>'); }} catch (e){}}
var environmentVars={ slot: document.getElementById(lkqdSettings.playerContainerId), videoSlot: document.getElementById(lkqdSettings.playerId), videoSlotCanAutoPlay: true, lkqdSettings: lkqdSettings };
function onVPAIDLoad(){
lkqdVPAID.subscribe(function(){ lkqdVPAID.startAd(); }, 'AdLoaded');
}
var vpaidFrame=document.createElement('iframe');
vpaidFrame.id=lkqdSettings.lkqdId;
vpaidFrame.name=lkqdSettings.lkqdId;
vpaidFrame.style.display='none';
var vpaidFrameLoaded=function(){
vpaidFrame.contentWindow.addEventListener('lkqdFormatsLoad', function(){
lkqdVPAID=vpaidFrame.contentWindow.getVPAIDAd();
onVPAIDLoad();
lkqdVPAID.handshakeVersion('2.0');
lkqdVPAID.initAd(lkqdSettings.playerWidth, lkqdSettings.playerHeight, 'normal', 600, creativeData, environmentVars);
});
vpaidLoader=vpaidFrame.contentWindow.document.createElement('script');
vpaidLoader.setAttribute('async','async');
vpaidLoader.src='https://ad.lkqd.net/vpaid/formats.js?pid=124&sid=567585';
vpaidFrame.contentWindow.document.body.appendChild(vpaidLoader);
};
vpaidFrame.onload=vpaidFrameLoaded;
vpaidFrame.onerror=vpaidFrameLoaded;
document.documentElement.appendChild(vpaidFrame);
})();</script>
<script data-cfasync='false'>Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id:"68177583-1994-412a-be0d-ee99e36ca658"})</script>
<script src="//tags.us.onscroll.com/abb02468-6e24-445f-8578-cb3cee3d87ca/tag.min.js" async defer></script>
<script id="optin-layout-two" type="text/template">
<div class="wpoi-hustle wpoi-layout-two"> <div class="wpoi-success-message"> <div class="wpoi-optin wpoi-align"> <div class="wpoi-container wpoi-col wpoi-align-element"> <div class="wpoi-element"> <i class="wphi-font wphi-check"></i></div><div class="wpoi-element"> <div class="wpoi-content">{{{ success_message.replace("{name}", optin_name) }}}</div></div></div></div></div><div class="wpoi-optin"> <div class="wpoi-container wpoi-image-{{image_location}}<# if(!optin_title && !optin_message){ #> nocontent<# } #><# if(!image_src){ #> noimage<# } #>"> <# if(elements.indexOf("image") !== -1){ #> <div class="wpoi-element wpoi-aside wpoi-image wpoi-image-fill" style="background-image: url('{{image_src}}'); background-size:{{image_style}};"></div><# } #>
<div class="wpoi-element"> <div class="wpoi-container wpoi-col"> <# if(optin_title || optin_message){ #> <div class="wpoi-element"> <div class="wpoi-content"> <# if(optin_title){ #> <h2 class="wpoi-title">{{optin_title}}</h2> <# } #> <# if(optin_message){ #> <div class="wpoi-message">{{{optin_message}}}</div><# } #></div></div><# } #>
<div class="wpoi-element wpoi-form"> <form class="wpoi-container<# if( has_args ){ #> wpoi-col<# } #> wpoi-fields-{{fields_style}} wpoi-{{input_icons}}<# if( has_args ){ #> hasmcg<# } #>" method="post"> <# if( has_args ){ #> <div class="wpoi-element wpoi-mcg-common-fields"> <div class="wpoi-container"> <# _.each(module_fields, function(field, key){ #> <div class="wpoi-element"> <input type="{{field.type}}" name="inc_optin_{{field.name}}" data-error="Please, provide {{field.label}}" class="wpoi-subscribe-{{field.name}} {{_.class(_.isTrue(field.required), 'required' )}}"> <label> <i class="wphi-font <# if ( field.type == 'email' ) { #>wphi-email<# } else if ( field.type == 'text' ) { if ( field.name == 'fname' || field.name == 'lname' || field.name == 'first_name' || field.name == 'last_name' || field.name == 'FNAME' || field.name == 'LNAME' ) { #>wphi-user<# } else if ( field.name == 'address' || field.name == 'ADDRESS' ) { #>wphi-address<# } else { #>wphi-typo<# } } else if ( field.type == 'number' ) { #>wphi-number<# } else if ( field.type == 'url' ) { #>wphi-url<# } #>"></i> <span>{{field.placeholder}}</span> </label></div><# }); #></div></div><div class="wpoi-element wpoi-provider-args" style="margin-bottom: 0;"></div><# } else { #>
<# _.each(module_fields, function(field, key){ #>
<div class="wpoi-element"> <input type="{{field.type}}" name="inc_optin_{{field.name}}" data-error="Please, provide {{field.label}}" class="wpoi-subscribe-{{field.name}} {{_.class(_.isTrue(field.required), 'required' )}}"> <label> <i class="wphi-font <# if ( field.type == 'email' ) { #>wphi-email<# } else if ( field.type == 'text' ) { if ( field.name == 'fname' || field.name == 'lname' || field.name == 'first_name' || field.name == 'last_name' || field.name == 'FNAME' || field.name == 'LNAME' ) { #>wphi-user<# } else if ( field.name == 'address' || field.name == 'ADDRESS' ) { #>wphi-address<# } else { #>wphi-typo<# } } else if ( field.type == 'number' ) { #>wphi-number<# } else if ( field.type == 'url' ) { #>wphi-url<# } #>"></i> <span>{{field.placeholder}}</span> </label></div><# }); #>
<div class="wpoi-button"> <button type="submit" class="wpoi-subscribe-send">{{cta_button}}</button></div><# } #>
</form></div></div></div></div></div></div></script>
<script defer src='//www.linuxnix.com/wp-content/cache/wpfc-minified/50925e482e8dd76bf57d546d76cabae6/1508577042index.js' type="text/javascript"></script>
<script>if(window.attachEvent){window.attachEvent('onload',wpfdr_google);}else if(window.addEventListener){window.addEventListener('load', wpfdr_google,false);}function wpfdr_google(){jQuery("link[wpfc-href]").each(function(i,e){jQuery(e).attr("href", jQuery(e).attr("wpfc-href"));});}</script>
<script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script>
</body>
</html>