<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8"/>
<link rel="pingback" href="http://www.linuxnix.com/xmlrpc.php"/>
<!--[if lt IE 9]>
	<script src="http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<title>What is SUID and how to set SUID in Linux/Unix? - The Linux Juggernaut</title>
 
<link rel="canonical" href="http://www.linuxnix.com/suid-set-suid-linuxunix/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="What is SUID and how to set SUID in Linux/Unix? - The Linux Juggernaut"/>
<meta property="og:description" content="There are some other special permission apart from the normal file permissions read, write and execute which we set with chmod and chown commands. They are SUID, SGID, Sticky Bit, ACL&#8217;s, SUDO, SELinux for granular file/folder management by Linux administrator. Today we will see 1) What is SUID? 2) How to set SUID? 3) Where to use &hellip;"/>
<meta property="og:url" content="http://www.linuxnix.com/suid-set-suid-linuxunix/"/>
<meta property="og:site_name" content="The Linux Juggernaut"/>
<meta property="article:author" content="https://www.facebook.com/Linux.Juggernaut/"/>
<meta property="article:tag" content="chmod"/>
<meta property="article:tag" content="Enter your zip code here"/>
<meta property="article:tag" content="permissions"/>
<meta property="article:tag" content="SUID"/>
<meta property="article:section" content="Administration"/>
<meta property="article:published_time" content="2011-12-29T00:04:19+00:00"/>
<meta property="article:modified_time" content="2015-10-13T19:44:57+00:00"/>
<meta property="og:updated_time" content="2015-10-13T19:44:57+00:00"/>
<meta property="og:image" content="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-1.jpg"/>
<meta property="og:image:width" content="464"/>
<meta property="og:image:height" content="302"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="There are some other special permission apart from the normal file permissions read, write and execute which we set with chmod and chown commands. They are SUID, SGID, Sticky Bit, ACL&#8217;s, SUDO, SELinux for granular file/folder management by Linux administrator. Today we will see 1) What is SUID? 2) How to set SUID? 3) Where to use [&hellip;]"/>
<meta name="twitter:title" content="What is SUID and how to set SUID in Linux/Unix? - The Linux Juggernaut"/>
<meta name="twitter:image" content="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-1.jpg"/>
<meta name="twitter:creator" content="@linuxnix"/>
 
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Feed" href="http://www.linuxnix.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Comments Feed" href="http://www.linuxnix.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; What is SUID and how to set SUID in Linux/Unix? Comments Feed" href="http://www.linuxnix.com/suid-set-suid-linuxunix/feed/"/>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("http://www.linuxnix.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '348fde8d-723d-4dd8-b8ac-2d123ca69f0a';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['subdomainName'] = "linuxnix";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['showCredit'] = false;
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Get free Linux/Devops updates to you directly';
            OneSignal.init(window._oneSignalInitOptions);
                });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.linuxnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.6"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Extra v.1.2.4.4" name="generator"/><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='et-gf-open-sans-css' href="https://fonts.googleapis.com/css?family=Open+Sans:400,700" type='text/css' media='all'/>
<link rel='stylesheet' id='et_monarch-css-css' href='http://www.linuxnix.com/wp-content/plugins/Monarch/css/style.css?ver=1.2.7.2' type='text/css' media='all'/>
<link rel='stylesheet' id='cupStyle-css' href='http://www.linuxnix.com/wp-content/plugins/contact-us-page/css/cupStyle.css?ver=4.5.6' type='text/css' media='all'/>
<link rel='stylesheet' id='extra-fonts-css' href="https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext" type='text/css' media='all'/>
<link rel='stylesheet' id='extra-style-css' href='http://www.linuxnix.com/wp-content/themes/Extra/style.css?ver=1.2.4.4' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://www.linuxnix.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all'/>
<link rel='stylesheet' id='magnific-popup-css' href='http://www.linuxnix.com/wp-content/themes/Extra/includes/builder/styles/magnific_popup.css?ver=1.2.4.4' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.linuxnix.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.linuxnix.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.linuxnix.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.linuxnix.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.5.6"/>
<link rel='shortlink' href='http://www.linuxnix.com/?p=1264'/>
<link rel="alternate" type="application/json+oembed" href="http://www.linuxnix.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.linuxnix.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;format=xml"/>
<style type="text/css" id="et-social-custom-css"></style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1"/>
<style type="text/css" id="extra-dynamic-styles-primary_nav_text_color-color">#et-menu>li a,#et-menu>li.menu-item-has-children>a:after,#et-menu>li.mega-menu-featured>a:after,#et-extra-mobile-menu>li.mega-menu-featured>a:after{color:rgba(0,0,0,0.6);}</style>
<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-color">#et-menu>li>a:hover,#et-menu>li.menu-item-has-children>a:hover:after,#et-menu>li.mega-menu-featured>a:hover:after,#et-navigation>ul#et-menu>li.current-menu-item>a,#et-navigation>ul#et-menu>li.current_page_item>a,#et-extra-mobile-menu>li.mega-menu-featured>a:hover:after,#et-extra-mobile-menu>li.current-menu-item>a,#et-extra-mobile-menu>li.current_page_item>a,#et-extra-mobile-menu>li>a:hover{color:#1e73be;}</style>
<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-background-color">#et-navigation>ul>li>a:before{background-color:#1e73be;}</style>
<style type="text/css" id="extra-dynamic-styles-primary_nav_background_color-background-color">#main-header{background-color:#ffffff;}</style>
<style type="text/css" id="extra-dynamic-styles-button_text_color-color">#page-container .button,#page-container button,#page-container button[type="submit"],#page-container input[type="submit"],#page-container input[type="reset"],#page-container input[type="button"],.read-more-button,.comment-body .comment_area .comment-content .reply-container .comment-reply-link,.widget_tag_cloud a,.widget_tag_cloud a:visited,.post-nav .nav-links .button,a.read-more-button,a.read-more-button:visited,#footer .widget_tag_cloud a,#footer .widget_tag_cloud a:visited,#footer a.read-more-button,#footer a.read-more-button:visited,#footer .button,#footer button,#footer button[type="submit"],#footer input[type="submit"],#footer input[type="reset"],#footer input[type="button"]{color:rgba(0,0,0,0.6);}</style>
<style type="text/css" id="extra-dynamic-styles-button_hover_text_color-color">#page-container .button:hover,#page-container button:hover,#page-container button[type="submit"]:hover,#page-container input[type="submit"]:hover,#page-container input[type="reset"]:hover,#page-container input[type="button"]:hover,.read-more-button:hover,.comment-body .comment_area .comment-content .reply-container .comment-reply-link:hover,.widget_tag_cloud a:hover,.widget_tag_cloud a:visited:hover,.post-nav .nav-links .button:hover,a.read-more-button:hover,a.read-more-button:visited:hover,#footer .widget_tag_cloud a:hover,#footer .widget_tag_cloud a:visited:hover,#footer a.read-more-button:hover,#footer a.read-more-button:visited:hover,#footer .button:hover,#footer button:hover,#footer button[type="submit"]:hover,#footer input[type="submit"]:hover,#footer input[type="reset"]:hover,#footer input[type="button"]:hover{color:rgba(0,0,0,0.6);}</style>
<style type="text/css" id="extra-dynamic-styles-extra_nav_height_value">@media only screen and (min-width: 768px) {#main-header .logo{height:48.45px;margin:23.275px 0;}.header.left-right #et-navigation>ul>li>a{padding-bottom:39.5px;}}@media only screen and (min-width: 768px) {.et-fixed-header #main-header .logo{height:48.45px;margin:23.275px 0;}.et-fixed-header .header.left-right #et-navigation>ul>li>a{padding-bottom:39.5px;}}</style>
 <script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "5.5", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/a30dc085-55ae-4bb0-9e46-774d36a290eb.js');/*]]>*/</script> <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-752078-3', 'auto');
  ga('send', 'pageview');

</script><link rel="icon" href="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-32x32.png" sizes="32x32"/>
<link rel="icon" href="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-180x180.png"/>
<meta name="msapplication-TileImage" content="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-270x270.png"/>
<style type="text/css" id="et-custom-css">@media screen and (max-width: 900px)
{#main-header .etad{display:none;}}#top-header{background-color:#B11B3D;}.et_pb_extra_module .main-post article .header img,.et_extra_other_module .main-post article .header img{display:block;width:auto;object-fit:cover;height:158px;width:100%;}pre{border:1px solid #DDD;overflow:auto;background:#EEE;font-size:.857em;line-height:1.5em;margin-bottom:1.833em;padding:.667em .917em;clear:both;color:#000;}.posts-blog-feed-module.masonry .post-content{padding:20px!important;}.author-box{display:none;}.post-thumbnail img{width:auto;margin:0 auto;}#disqus_thread{background:#fff;padding:20px;border-radius:3px;box-shadow:0 1px 3px rgba(0,0,0,0.1);box-sizing:border-box;}</style></head>
<body class="single single-post postid-1264 single-format-standard et_monarch et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right unknown et_includes_sidebar">
<div id="page-container">
 
<header class="header left-right">
 
<div id="top-header" style="">
<div class="container">
 
<div id="et-secondary-nav" class="et-trending">
 
<div id="et-trending">
 
<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>
 
<h4 id="et-trending-label">
TRENDING: </h4>
 
<div id='et-trending-container'>
<div id="et-trending-post-1297" class="et-trending-post et-trending-latest">
<a href="http://www.linuxnix.com/sticky-bit-set-linux/">What is a sticky Bit and how to set it in Linux?</a>
</div>
<div id="et-trending-post-1264" class="et-trending-post">
<a href="http://www.linuxnix.com/suid-set-suid-linuxunix/">What is SUID and how to set SUID in Linux/Unix?</a>
</div>
<div id="et-trending-post-1093" class="et-trending-post">
<a href="http://www.linuxnix.com/linux-top-command-explained-2/">Linux TOP command explained</a>
</div>
</div>
</div>
</div>
 
<div id="et-info">
 
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>
 
<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="http://www.linuxnix.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:"/>
<button class="et-search-submit"></button>
</form> </div>
 
</div>
</div> 
</div> 
 
<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="95">
<div class="container">
 
 
<a class="logo" href="http://www.linuxnix.com/" data-fixed-height="51">
<img src="http://www.linuxnix.com/wp-content/uploads/2016/08/linux.png" alt="The Linux Juggernaut" id="logo"/>
</a>
<div style="margin:auto;padding-top: 5px;" class="js-gads">
<script type="text/javascript"><!--
						    google_ad_client = "ca-pub-7992389594799240";
						    if (window.innerWidth <= 350) {
						      // Small ad
						      google_ad_slot = "1617608518";
						      google_ad_width = 320;
						      google_ad_height = 50;
						    } else if (window.innerWidth >= 750) {
						      google_ad_slot = "1617608518";
						      google_ad_width = 728;
						      google_ad_height = 90;

						    } else {
						      // Medium (fallback) ad
						      google_ad_slot = "1617608518";
						      google_ad_width = 320;
						      google_ad_height = 50;
						    }
						  //--></script>
<script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
</div>
</div>
 
<div class="subHeader">
<div class="container">
 
<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5531"><a href="http://www.linuxnix.com/category/administration/">Administration</a>
<ul class="sub-menu">
<li id="menu-item-5534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5534"><a href="http://www.linuxnix.com/category/administration/monitoring/">Monitoring</a></li>
<li id="menu-item-5533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5533"><a href="http://www.linuxnix.com/category/administration/security/">Security</a></li>
<li id="menu-item-5532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5532"><a href="http://www.linuxnix.com/category/administration/servers/">Servers</a></li>
</ul>
</li>
<li id="menu-item-5536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5536"><a href="http://www.linuxnix.com/category/basics/">Basics</a></li>
<li id="menu-item-5544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5544"><a href="/category/cloudvirtulization/">Cloud</a>
<ul class="sub-menu">
<li id="menu-item-5545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5545"><a href="/category/cloudvirtulization/aws/">AWS</a></li>
<li id="menu-item-5540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5540"><a href="http://www.linuxnix.com/category/cloudvirtulization/kvm/">KVM</a></li>
</ul>
</li>
<li id="menu-item-5546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5546"><a href="/category/Devops/">Devops</a>
<ul class="sub-menu">
<li id="menu-item-5547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5547"><a href="/category/Devops/Ansible/">Ansible</a></li>
<li id="menu-item-5548" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5548"><a href="/category/Devops/Docker/">Docker</a></li>
<li id="menu-item-5549" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5549"><a href="/category/Devops/Packer/">Packer</a></li>
<li id="menu-item-5550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5550"><a href="/category/Devops/Puppet/">Puppet</a></li>
<li id="menu-item-5551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5551"><a href="/category/Devops/Vagrant/">Vagrant</a></li>
</ul>
</li>
<li id="menu-item-5537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5537"><a href="http://www.linuxnix.com/category/interviews-2/">Interviews</a></li>
<li id="menu-item-5535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5535"><a href="http://www.linuxnix.com/category/news/">News</a></li>
<li id="menu-item-5552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5552"><a href="/category/offers/">Offers</a></li>
<li id="menu-item-5553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5553"><a href="/category/Programming/">Programming</a>
<ul class="sub-menu">
<li id="menu-item-5554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5554"><a href="/category/Programming/awk/">Awk</a></li>
<li id="menu-item-5538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5538"><a href="http://www.linuxnix.com/category/programming/bash/">Bash</a></li>
<li id="menu-item-5555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5555"><a href="/category/Programming/Batch/">Batch</a></li>
<li id="menu-item-5556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5556"><a href="/category/Programming/git/">Git</a></li>
<li id="menu-item-5557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5557"><a href="/category/Programming/Perl/">Perl</a></li>
<li id="menu-item-5558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5558"><a href="/category/Programming/PowerShell/">PowerShell</a></li>
<li id="menu-item-5539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5539"><a href="http://www.linuxnix.com/category/programming/python/">python</a></li>
<li id="menu-item-5559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5559"><a href="/category/Programming/Ruby/">Ruby</a></li>
<li id="menu-item-5560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5560"><a href="/category/Programming/Sed/">Sed</a></li>
<li id="menu-item-5561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5561"><a href="/category/Programming/SQL/">SQL</a></li>
</ul>
</li>
<li id="menu-item-5562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5562"><a href="/category/Reviews/">Reviews</a>
<ul class="sub-menu">
<li id="menu-item-5563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5563"><a href="/category/Reviews/Books/">Books</a></li>
<li id="menu-item-5564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5564"><a href="/category/Reviews/Linuxunix/">Linux/Unix</a></li>
<li id="menu-item-5565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5565"><a href="/category/reviews/open-source/">Open source</a></li>
</ul>
</li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>   </div> 
</div>
</div>
</div> 
</div> 
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-1264" class="module single-post-module post-1264 post type-post status-publish format-standard has-post-thumbnail hentry category-administration tag-chmod tag-enter-your-zip-code-here tag-permissions tag-suid et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">What is SUID and how to set SUID in Linux/Unix?</h1>
<div class="post-meta">
<p>Posted by <a href="http://www.linuxnix.com/author/surendra/" class="url fn" title="Posts by Surendra Anne" rel="author">Surendra Anne</a> | <span class="updated">Dec 29, 2011</span> | <a href="http://www.linuxnix.com/category/administration/" rel="tag">Administration</a> | <a class="comments-link" href="http://www.linuxnix.com/suid-set-suid-linuxunix/#comments">29 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 2.50"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-half rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
</div>
</div>
<div class="post-thumbnail header">
<a href="http://www.linuxnix.com/suid-set-suid-linuxunix/" title="What is SUID and how to set SUID in Linux/Unix?" class="featured-image">
<img src="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-1.jpg" alt="What is SUID and how to set SUID in Linux/Unix?"/>
</a> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p style="text-align: left;">There are some other special permission apart from the normal file permissions read, write and execute which we set with <a title="chmod command explained for Linux/Unix" href="http://www.linuxnix.com/2011/10/chmod-command-explained-linuxunix.html" target="_blank">chmod</a> and <a title="CHOWN command in Linux/Unix explained with examples" href="http://www.linuxnix.com/2011/12/chown-command-linuxunix-explained-examples.html" target="_blank">chown</a> commands. They are <strong>SUID, <a title="What is SGID and how to set SGID in Linux?" href="http://www.linuxnix.com/2011/12/sgid-set-sgid-linuxunix.html" target="_blank">SGID</a>, <a title="What is a sticky Bit and how to set it in Linux?" href="http://www.linuxnix.com/2012/01/sticky-bit-set-linux.html" target="_blank">Sticky Bit</a>, ACL&#8217;s, SUDO, <a title="Basics of SELinux in Linux" href="http://www.linuxnix.com/2012/09/basics-of-selinux-in-linux.html" target="_blank">SELinux</a></strong> for granular file/folder management by Linux administrator. Today we will see</p>
<pre><strong>1) What is SUID?</strong>
<strong>2) How to set SUID?</strong>
<strong>3) Where to use SUID?</strong></pre>
<h1><strong>What is SUID and how to set it in Linux?</strong></h1>
<p><strong>SUID</strong> (<strong>S</strong>et owner <strong>U</strong>ser <strong>ID</strong> up on execution) is a special type of file permissions given to a file. Normally in Linux/Unix when a program runs, it inherit&#8217;s access permissions from the logged in user. SUID is defined as giving temporary permissions to a user to run a program/file with the permissions of the file owner rather that the user who runs it<strong>. In simple words users will get file owner’s permissions as well as owner UID and GID when executing a file/program/command.</strong></p>
<p>The above sentence is a tricky one and should be explained in-depth with examples.</p>
<h2><strong>Learn SUID with examples:</strong></h2>
<h3><strong>Example1: </strong> <strong>passwd command</strong></h3>
<p>When we try to change our password we will use <strong>passwd command,</strong> which is owned by root. This <strong>passwd command</strong> file will try to edit some system config files such as /etc/passwd, /etc/shadow etc when we try to change our password. Some of these files cannot be opened or viewed by normal user only root user will have permissions. So if we try to remove SUID and give full permissions to this passwd command file it cannot open other files such as /etc/shadow file to update the changes and we will get permission denied error or some other error when tried to execute passwd command. So passwd command is set with SUID to give root user permissions to normal user so that it can update /etc/shadow and other files.</p>
<h3><strong>Example2: ping command</strong></h3>
<p>Similarly if we take ping command, when we have to execute this command internally it should open socket files and open ports in order to send IP packets and receive IP packets to remote server. Normal users don’t have permissions to open socket files and open ports. So SUID bit is set on this file/command so that whoever executes this will get owner (Root user’s) permissions to them when executing this command. So when this command start executing it will inherit root user permissions to this normal user and opens require socket files and ports.</p>
<h3><strong>Example3: crontab and at command</strong></h3>
<p>When scheduling the jobs by using crontab or at command it is obvious to edit some of the crontab related configuration files located in /etc which are not writable for normal users. So crontab/at commands are set with SUID in-order to write some data.</p>
<h1><strong>How can I setup SUID for a file?</strong></h1>
<p>SUID can be set in two ways</p>
<pre><strong>1) Symbolic way (s, Stands for Set) </strong>
<strong>2) Numerical/octal way (4)</strong>
</pre>
<p>Use chmod command to set SUID on file: file1.txt</p>
<p><strong>Symbolic way:</strong></p>
<pre><strong style="line-height: 18px; font-family: Consolas, Monaco, monospace; white-space: pre; font-size: 12px;"><a title="chmod command explained for Linux/Unix" href="http://www.linuxnix.com/2011/10/chmod-command-explained-linuxunix.html" target="_blank">chmod</a> u+s file1.txt</strong>
</pre>
<p>Here owner permission execute bit is set to SUID with +s</p>
<p><strong>Numerical way:</strong></p>
<pre><strong style="line-height: 18px; font-family: Consolas, Monaco, monospace; white-space: pre; font-size: 12px;">chmod 4750 file1.txt</strong>
</pre>
<p>Here in 4750, four indicates SUID bit set, seven for full permissions for owner, five for read and execute permissions for group, and no permissions for others.</p>
<p><strong>How can I check if a file is set with SUID bit or not?</strong></p>
<p>Use ls –l to check if the x in owner permissions field is replaced by s or S</p>
<p>For example: Listing file1.txt before and after SUID set</p>
<p><strong>Before setting SUID bit:</strong></p>
<pre><strong style="line-height: 18px; font-family: Consolas, Monaco, monospace; white-space: pre; font-size: 12px;">ls -l</strong>
<strong>total 8</strong>
<strong>-rwxr--r-- 1 xyz xyzgroup 148 Dec 22 03:46 file1.txt</strong>
</pre>
<p><strong>After setting SUID bit:</strong></p>
<pre><strong style="line-height: 18px; font-family: Consolas, Monaco, monospace; white-space: pre; font-size: 12px;">ls -l</strong>
<strong>total 8</strong>
<strong>-rw</strong><span style="color: #ff0000;"><strong>s</strong></span><strong>r--r-- 1 xyz xyzgroup 148 Dec 22 03:46 file1.txt</strong>
</pre>
<h1><strong>Some FAQ’s related to SUID:</strong></h1>
<h2><strong>A) Where is SUID used?</strong></h2>
<p>1) Where root login is required to execute some commands/programs/scripts.</p>
<p>2) Where you don&#8217;t want to give credentials of a particular user, but want to run some programs as the owner.</p>
<p>3) Where you don&#8217;t want to use SUDO command, but want to give execute permission for a file/script etc.</p>
<h2><strong>B) I am seeing &#8216;S&#8217; I.e. Capital &#8216;s&#8217; in the file permissions, what is that?</strong></h2>
<p>After setting SUID to a file/folder if you see ‘S’ in the file permission area that indicates that the file/folder does not have executable permissions for that user on that particular file/folder.</p>
<p>For example see below example</p>
<pre><strong style="line-height: 18px; font-family: Consolas, Monaco, monospace; white-space: pre; font-size: 12px;">chmod u+s file1.txt</strong>
<strong>ls -l</strong>
<strong>-rwSrwxr-x 1 surendra surendra 0 Dec 27 11:24 file1.txt</strong>
</pre>
<p>If you want to convert this S to s then add executable permissions to this file as show below</p>
<pre><strong>chmod u+x file1.txt</strong>
<strong>ls -l</strong>
<strong>-rwsrwxr-x 1 surendra surendra 0 Dec 5 11:24 file1.txt</strong>
</pre>
<p>you should see a smaller &#8216;s&#8217; in the executable permission position now.</p>
<h2><strong>SUID with execute permissions:</strong></h2>
<h1><a href="http://www.linuxnix.com/2011/12/suid-set-suid-linuxunix.html/untitleddrawing-1" rel="attachment wp-att-1278"><img class="alignnone size-full wp-image-1278" src="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-1.jpg" alt="SUID_Linux" width="464" height="302" srcset="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-1.jpg 464w, http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-1-300x195.jpg 300w" sizes="(max-width: 464px) 100vw, 464px"/></a></h1>
<h2><strong>SUID without execute permissions:</strong></h2>
<p><a href="http://www.linuxnix.com/2011/12/suid-set-suid-linuxunix.html/untitleddrawing-2-2" rel="attachment wp-att-1280"><img class="alignnone size-full wp-image-1280" src="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-2.jpg" alt="SUID_Linux_without_execute_permissions" width="501" height="310" srcset="http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-2.jpg 501w, http://www.linuxnix.com/wp-content/uploads/2011/12/Untitleddrawing-2-300x186.jpg 300w" sizes="(max-width: 501px) 100vw, 501px"/></a></p>
<h2><strong>C) How can I find all the SUID set files in Linux/Unix.</strong></h2>
<pre><strong style="line-height: 18px; font-family: Consolas, Monaco, monospace; white-space: pre; font-size: 12px;"><a title="Learn Linux/Unix Find command with 60+ Practical examples Part-I" href="http://www.linuxnix.com/2012/04/learn-linuxunix-find-command-50-practical-examples-part-i.html" target="_blank">find</a> / -perm +4000</strong>
</pre>
<p>The above find command will check all the files which are set with SUID bit (4000).</p>
<h2><strong>D) Can I set SUID for folders?</strong></h2>
<p>Yes, you can if it&#8217;s required (you should remember one thing that Linux treats everything as a file)</p>
<h2><strong>E) What is SUID numerical value?</strong></h2>
<p>It has the value 4.</p>
<p>Please comment your thoughts about SUID usage in your company.</p>
<script type="text/javascript">
jQuery(document).ready(function($) {
	$.post('http://www.linuxnix.com/wp-admin/admin-ajax.php', {action: 'wpt_view_count', id: '1264'});
});
</script><span class="et_social_bottom_trigger"></span> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Facebook" data-network-name="facebook" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/home?status=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F%20http://www.linuxnix.com/suid-set-suid-linuxunix/" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Twitter" data-network-name="twitter" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Google +" data-network-name="googleplus" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.tumblr.com/share?v=3&#038;u=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Tumblr" data-network-name="tumblr" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;description=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Pinterest" data-network-name="pinterest" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via LinkedIn" data-network-name="linkedin" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="https://bufferapp.com/add?url=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Buffer" data-network-name="buffer" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover"></span>
</a><a href="http://www.stumbleupon.com/badge?url=http://www.linuxnix.com/suid-set-suid-linuxunix/&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Email" data-network-name="basic_email" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;What is SUID and how to set SUID in Linux/Unix?&quot; via Print" data-network-name="basic_print" data-share-title="What is SUID and how to set SUID in Linux/Unix?" data-share-url="http://www.linuxnix.com/suid-set-suid-linuxunix/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<div class="rating-stars">
<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="1264"/> </div>
<style type="text/css" id="rating-stars">.post-footer .rating-stars #rated-stars img.star-on,.post-footer .rating-stars #rating-stars img.star-on{background-color:#7ac8cc;}</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="http://www.linuxnix.com/umask-define-linuxunix/" rel="prev"><span class="button">Previous</span><span class="title">What is UMASK and how to set UMASK in Linux/Unix?</span></a> </div>
<div class="nav-link nav-link-next">
<a href="http://www.linuxnix.com/sgid-set-sgid-linuxunix/" rel="next"><span class="button">Next</span><span class="title">What is SGID and how to set SGID in Linux?</span></a> </div>
</div>
</nav>
<div class="et_extra_other_module author-box vcard">
<div class="author-box-header">
<h3>About The Author</h3>
</div>
<div class="author-box-content clearfix">
<div class="author-box-avatar photo">
<img alt src="https://2.gravatar.com/avatar/8f71515aab81c5a2f6b9a2f414e347eb?s=170&#038;d=mm&#038;r=g" srcset="http://2.gravatar.com/avatar/8f71515aab81c5a2f6b9a2f414e347eb?s=340&amp;d=mm&amp;r=g 2x" class='avatar avatar-170 photo' height='170' width='170'/> </div>
<div class="author-box-description">
<h4><a class="author-link url fn" href="http://www.linuxnix.com/author/surendra/" rel="author" title="">Surendra Anne</a></h4>
<p class="note">Mr Surendra Anne is from Vijayawada, Andhra Pradesh, India. He is a Linux/Open source supporter who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. He works as Devops Engineer with Taggle systems, an IOT automatic water metering company, Sydney . You can contact him at surendra (@) linuxnix dot com.</p>
<ul class="social-icons">
<li><a href="https://www.facebook.com/Linux.Juggernaut/" target="_blank"><span class="et-extra-icon et-extra-icon-facebook et-extra-icon-color-hover"></span></a></li>
<li><a href="http://linuxnix" target="_blank"><span class="et-extra-icon et-extra-icon-twitter et-extra-icon-color-hover"></span></a></li>
<li><a href="https://www.facebook.com/Linux.Juggernaut/" target="_blank"><span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-color-hover"></span></a></li>
</ul>
</div>
</div>
</div>
<div class="et_extra_other_module related-posts">
<div class="related-posts-header">
<h3>Related Posts</h3>
</div>
<div class="related-posts-content clearfix">
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/mounting-of-nfsnetwork-file-system-on-a-local-ubuntu/" title="Mounting Of NFS(Network File System) On A Local Ubuntu" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Mounting Of NFS(Network File System) On A Local Ubuntu"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/mounting-of-nfsnetwork-file-system-on-a-local-ubuntu/">Mounting Of NFS(Network File System) On A Local Ubuntu</a></h4>
<p class="date"><span class="updated">January 23, 2010</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/find-determine-if-a-machine-runs-64-bit-linux-os-or-not/" title="Check if a machine runs on 64 bit or 32 bit Processor/Linux OS?" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Check if a machine runs on 64 bit or 32 bit Processor/Linux OS?"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/find-determine-if-a-machine-runs-64-bit-linux-os-or-not/">Check if a machine runs on 64 bit or 32 bit Processor/Linux OS?</a></h4>
<p class="date"><span class="updated">February 5, 2013</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/how-to-mount-dvd-or-cdrom-in-linux/" title="How to mount DVD or CDROM in Linux" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="How to mount DVD or CDROM in Linux"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/how-to-mount-dvd-or-cdrom-in-linux/">How to mount DVD or CDROM in Linux</a></h4>
<p class="date"><span class="updated">September 10, 2012</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/find-large-files-linux/" title="How To Find Large Files In Linux" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/uploads/2011/02/linux-find-command.png" alt="How To Find Large Files In Linux"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/find-large-files-linux/">How To Find Large Files In Linux</a></h4>
<p class="date"><span class="updated">February 18, 2011</span></p>
</div>
</div>
</div>
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-844">
<div id="dsq-comment-header-844" class="dsq-comment-header">
<cite id="dsq-cite-844">
<a id="dsq-author-user-844" href="http://zenettii.myopenid.com/" target="_blank" rel="nofollow">Zenettii</a>
</cite>
</div>
<div id="dsq-comment-body-844" class="dsq-comment-body">
<div id="dsq-comment-message-844" class="dsq-comment-message"><p>On majority of distro&#8217;s the ability to suid on scripts (bash, perl etc) is not allowed due to security.<br/>
Where experimenting and testing this for experience, it should be done against a small program that you&#8217;re familiar with.</p>
<p>A great way to test this is to suid on &#8220;whoami&#8221; command. Try this:</p>
<p>$ whoami<br/>
zenettii<br/>
$ sudo chmod u+s /usr/bin/whoami<br/>
$ whoami<br/>
root<br/>
$ sudo chmod u-s /usr/bin/whoami</p>
<p>Regards.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-845">
<div id="dsq-comment-header-845" class="dsq-comment-header">
<cite id="dsq-cite-845">
<span id="dsq-author-user-845">Coder</span>
</cite>
</div>
<div id="dsq-comment-body-845" class="dsq-comment-body">
<div id="dsq-comment-message-845" class="dsq-comment-message"><p>Your graphical explanation of the difference between capital S and small s was really helpful! Thanks!!!</p>
</div>
</div>
</li> 
<li class="post pingback">
<p>Pingback: <a href='http://www.linuxnix.com/2012/01/sticky-bit-set-linux.html' rel='external nofollow' class='url'>What is Sticky bit and how to implement Sticky bit in Linux</a>()</p>
</li>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-853">
<div id="dsq-comment-header-853" class="dsq-comment-header">
<cite id="dsq-cite-853">
<span id="dsq-author-user-853">Yash</span>
</cite>
</div>
<div id="dsq-comment-body-853" class="dsq-comment-body">
<div id="dsq-comment-message-853" class="dsq-comment-message"><p>sticky bit is used in linux for prevent damage by using sticky bit we not able to delete the file for example if a file shared in linux and many users have write and modification permissions then any one can delete the file and the data of other users also deleted in this case we use sticky bit </p>
<p>for setting sticky bit for a file </p>
<p>chmod +t &#8220;directory path on which u want to apply&#8221;</p>
<p>in numeric</p>
<p>chmod +1 /tmp</p>
</div>
</div>
<ul class="children">
<li class="comment byuser comment-author-surendra bypostauthor odd alt depth-3" id="dsq-comment-854">
<div id="dsq-comment-header-854" class="dsq-comment-header">
<cite id="dsq-cite-854">
<a id="dsq-author-user-854" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra Anne</a>
</cite>
</div>
<div id="dsq-comment-body-854" class="dsq-comment-body">
<div id="dsq-comment-message-854" class="dsq-comment-message"><p>I dont think chmod +1 /path/to/folder will work</p>
<p>chmod +1 /opt/Data/sticky/<br/>
chmod: invalid mode: `+1&#8242;<br/>
Try `chmod &#8211;help&#8217; for more information.</p>
<p>Did you tried this of your own before posting a comment?</p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="post pingback">
<p>Pingback: <a href='http://www.linuxnix.com/2011/12/sgid-set-sgid-linuxunix.html' rel='external nofollow' class='url'>What is SGID and how to set SGID in Linux? | The Linux Juggernaut</a>()</p>
</li>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-848">
<div id="dsq-comment-header-848" class="dsq-comment-header">
<cite id="dsq-cite-848">
<span id="dsq-author-user-848">aselvan</span>
</cite>
</div>
<div id="dsq-comment-body-848" class="dsq-comment-body">
<div id="dsq-comment-message-848" class="dsq-comment-message"><p>Good explanation. Just a minor correction: your before graphic for &#8220;SUID with out execute permissions:&#8221; is incorrect. It should be &#8220;rw-rwxrwx&#8221; so it can become &#8220;rwSrwxrwx&#8221; after suid added to permission.</p>
</div>
</div>
<ul class="children">
<li class="comment byuser comment-author-surendra bypostauthor odd alt depth-2" id="dsq-comment-849">
<div id="dsq-comment-header-849" class="dsq-comment-header">
<cite id="dsq-cite-849">
<a id="dsq-author-user-849" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra Anne</a>
</cite>
</div>
<div id="dsq-comment-body-849" class="dsq-comment-body">
<div id="dsq-comment-message-849" class="dsq-comment-message"><p>Hi Aselvan,</p>
<p> The example shows already SUID bit set so its small &#8220;s&#8221;, I dont think its a wrong GUI. Thanks for taking time and posting your comment.<br/>
Suri</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-865">
<div id="dsq-comment-header-865" class="dsq-comment-header">
<cite id="dsq-cite-865">
<span id="dsq-author-user-865">Rama</span>
</cite>
</div>
<div id="dsq-comment-body-865" class="dsq-comment-body">
<div id="dsq-comment-message-865" class="dsq-comment-message"><p> Hi good job,its crisp and clear.But i request you to verify a small thing.Mr Selvan is correct.In FAQ &quot;B)&quot; &nbsp;the second part for &quot;S&quot; occurs for rw-.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-3" id="dsq-comment-870">
<div id="dsq-comment-header-870" class="dsq-comment-header">
<cite id="dsq-cite-870">
<span id="dsq-author-user-870">Dags</span>
</cite>
</div>
<div id="dsq-comment-body-870" class="dsq-comment-body">
<div id="dsq-comment-message-870" class="dsq-comment-message"><p> @Surendra, what the other two posters are trying to say is that the second graphic &#8211; SUID with out execute permissions &#8211; doesn&#039;t make much sense.</p>
<p> It looks like: rwxrwxrwx -&gt; set SUID bit -&gt; rwSrwxrwx.</p>
<p> This is wrong. To get from rwxrwxrwx to rwSrwxrwx, you&#039;d have to set the SUID bit *and* remove the executable permission from user (the second command is not indicated anywhere). It would make much more sense if the graphic was:</p>
<p> rw-rwxrwx &gt; SUID -&gt; rwSrwxrwx</p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="post pingback">
<p>Pingback: <a href="https://www.linuxquestions.org/questions/linux-newbie-8/what-is-suid-sgid-sticky-and-why-we-use-it-4175457692/#post4929173" rel='external nofollow' class='url'>what is suid, sgid, sticky and why we use it ...?</a>()</p>
</li>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-851">
<div id="dsq-comment-header-851" class="dsq-comment-header">
<cite id="dsq-cite-851">
<span id="dsq-author-user-851">xavi</span>
</cite>
</div>
<div id="dsq-comment-body-851" class="dsq-comment-body">
<div id="dsq-comment-message-851" class="dsq-comment-message"><p>I don&#8217;t think this is accurate:</p>
<p>&#8220;Normal users don’t have permissions to open socket files and open ports.&#8221;</p>
<p>A regular user can&#8217;t open ports under 1024, but they can certainly open ports without being root.</p>
</div>
</div>
<ul class="children">
<li class="comment byuser comment-author-surendra bypostauthor odd alt depth-2" id="dsq-comment-852">
<div id="dsq-comment-header-852" class="dsq-comment-header">
<cite id="dsq-cite-852">
<a id="dsq-author-user-852" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra Anne</a>
</cite>
</div>
<div id="dsq-comment-body-852" class="dsq-comment-body">
<div id="dsq-comment-message-852" class="dsq-comment-message"><p>I agree, but in the post Its not mention any where. It mention as root user permissions are used to open a socket file. do let us know if any sentence is misleading.</p>
<p>Thanks,<br/>
Surendra.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-855">
<div id="dsq-comment-header-855" class="dsq-comment-header">
<cite id="dsq-cite-855">
<a id="dsq-author-user-855" href="http://www.redpinesignals.com" target="_blank" rel="nofollow">bharath</a>
</cite>
</div>
<div id="dsq-comment-body-855" class="dsq-comment-body">
<div id="dsq-comment-message-855" class="dsq-comment-message"><p>Absolutely fantastic info&#8230;. Thanks Suri&#8230;</p>
</div>
</div>
</li> 
<li class="post pingback">
<p>Pingback: <a href="https://fuenteziimufrad.wordpress.com/2013/07/13/kismet/" rel='external nofollow' class='url'>Kismet | Serba Serbi</a>()</p>
</li>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-857">
<div id="dsq-comment-header-857" class="dsq-comment-header">
<cite id="dsq-cite-857">
<a id="dsq-author-user-857" href="https://gravatar.com/klooride" target="_blank" rel="nofollow">klooride</a>
</cite>
</div>
<div id="dsq-comment-body-857" class="dsq-comment-body">
<div id="dsq-comment-message-857" class="dsq-comment-message"><p>Thanks! really helpful!</p>
<p>Just a little comment, at line where you write:<br/>
Here in 4750, 4 indicates SUID bit set, 7 for full permissions for owner, 5 for //write// and execute permissions for group, and no permissions for others.<br/>
Isn&#8217;t 5 for read-execute??</p>
</div>
</div>
<ul class="children">
<li class="comment byuser comment-author-surendra bypostauthor even depth-2" id="dsq-comment-858">
<div id="dsq-comment-header-858" class="dsq-comment-header">
<cite id="dsq-cite-858">
<a id="dsq-author-user-858" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra Anne</a>
</cite>
</div>
<div id="dsq-comment-body-858" class="dsq-comment-body">
<div id="dsq-comment-message-858" class="dsq-comment-message"><p>
yes.. thanks klooride for heads up. Updated the post.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-859">
<div id="dsq-comment-header-859" class="dsq-comment-header">
<cite id="dsq-cite-859">
<a id="dsq-author-user-859" href="http://cloudwalks.com/" target="_blank" rel="nofollow">QuickBooks</a>
</cite>
</div>
<div id="dsq-comment-body-859" class="dsq-comment-body">
<div id="dsq-comment-message-859" class="dsq-comment-message"><p>Great explanation, it saved me to solving the SUID puzzle.</p>
<p>Thank you very much.</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-860">
<div id="dsq-comment-header-860" class="dsq-comment-header">
<cite id="dsq-cite-860">
<a id="dsq-author-user-860" href="https://gravatar.com/rajshekar007" target="_blank" rel="nofollow">rajshekar007</a>
</cite>
</div>
<div id="dsq-comment-body-860" class="dsq-comment-body">
<div id="dsq-comment-message-860" class="dsq-comment-message"><p>I got your point. But I have a doubt. I hope you clarify it.<br/>
If we want others to execute our file as owner of that file then why not set &#8216;x&#8217; bit in others permission(&#8211;x) of the file instead of setting suid. If there is any advantage in doing so. What is that can you explain.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-861">
<div id="dsq-comment-header-861" class="dsq-comment-header">
<cite id="dsq-cite-861">
<span id="dsq-author-user-861">gavin</span>
</cite>
</div>
<div id="dsq-comment-body-861" class="dsq-comment-body">
<div id="dsq-comment-message-861" class="dsq-comment-message"><p>find / -xdev ( -perm -4000 ) -type f -print0 | xargs -0 ls -l</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-862">
<div id="dsq-comment-header-862" class="dsq-comment-header">
<cite id="dsq-cite-862">
<a id="dsq-author-user-862" href="http://N/A" target="_blank" rel="nofollow">Joel Winkler</a>
</cite>
</div>
<div id="dsq-comment-body-862" class="dsq-comment-body">
<div id="dsq-comment-message-862" class="dsq-comment-message"><p> &nbsp; My name is Joel and&nbsp; I am running a Macintosh&nbsp; system 10.6.8&nbsp; and when I tried to repair permissions there are several SUID files that will not be altered ( repaired).&nbsp;&nbsp; I&#039;m not sure if this is harmful or not I.&nbsp; I&nbsp; would appreciate a response in terms of this problem.&nbsp; Thank you&nbsp; in advance&nbsp; for your assistance.</p>
<p> &nbsp;Joel<br/>
&nbsp;</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-863">
<div id="dsq-comment-header-863" class="dsq-comment-header">
<cite id="dsq-cite-863">
<span id="dsq-author-user-863">Tharindu Edirisinghe</span>
</cite>
</div>
<div id="dsq-comment-body-863" class="dsq-comment-body">
<div id="dsq-comment-message-863" class="dsq-comment-message"><p> This post is really informative. Got clear understanding of the suid in linux. Thank you !</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-864">
<div id="dsq-comment-header-864" class="dsq-comment-header">
<cite id="dsq-cite-864">
<span id="dsq-author-user-864">Ngowda</span>
</cite>
</div>
<div id="dsq-comment-body-864" class="dsq-comment-body">
<div id="dsq-comment-message-864" class="dsq-comment-message"><p> Good info to understand setuid.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-866">
<div id="dsq-comment-header-866" class="dsq-comment-header">
<cite id="dsq-cite-866">
<span id="dsq-author-user-866">duniaaneh</span>
</cite>
</div>
<div id="dsq-comment-body-866" class="dsq-comment-body">
<div id="dsq-comment-message-866" class="dsq-comment-message"><p>Hi Dear, are you genuinely visiting this site on a regular basis, if so after that you will definitely obtain good knowledge.</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-867">
<div id="dsq-comment-header-867" class="dsq-comment-header">
<cite id="dsq-cite-867">
<span id="dsq-author-user-867">praveen</span>
</cite>
</div>
<div id="dsq-comment-body-867" class="dsq-comment-body">
<div id="dsq-comment-message-867" class="dsq-comment-message"><p> thanks much</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-868">
<div id="dsq-comment-header-868" class="dsq-comment-header">
<cite id="dsq-cite-868">
<a id="dsq-author-user-868" href="https://www.linkedin.com/pub/dir/Courtney/Jones/us-52-Greater-Atlanta-Area" target="_blank" rel="nofollow">courtney jones atlanta</a>
</cite>
</div>
<div id="dsq-comment-body-868" class="dsq-comment-body">
<div id="dsq-comment-message-868" class="dsq-comment-message"><p> visiting this site on a regular basis, if so after that you will definitely obtain good knowledge</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-869">
<div id="dsq-comment-header-869" class="dsq-comment-header">
<cite id="dsq-cite-869">
<span id="dsq-author-user-869">madhan kumar</span>
</cite>
</div>
<div id="dsq-comment-body-869" class="dsq-comment-body">
<div id="dsq-comment-message-869" class="dsq-comment-message"><p> hi sir</p>
<p> this is madhan kumar &nbsp;i am trying job on linux admin. i seen your web site,i have one question?</p>
<p> &nbsp;</p>
<p> with out ACL permissino</p>
<p> &nbsp;</p>
<p> how to assign the permssions of users.</p>
<p> &nbsp;</p>
<p> Ex. user A &nbsp;should contain readly only permission to Dir.</p>
<p> &nbsp; &nbsp; &nbsp; user B &nbsp; should contain modify permission to Dir.</p>
<p> &nbsp; &nbsp; &nbsp; but Other users do not have any access to Dir.</p>
<p> &nbsp;</p>
<p> Dir: /optfile/</p>
<p> &nbsp; &nbsp; &nbsp;</p>
<p> i hope you will give answer to question?.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-871">
<div id="dsq-comment-header-871" class="dsq-comment-header">
<cite id="dsq-cite-871">
<span id="dsq-author-user-871">Łukasz Przeniosło</span>
</cite>
</div>
<div id="dsq-comment-body-871" class="dsq-comment-body">
<div id="dsq-comment-message-871" class="dsq-comment-message"><p> Hello there,</p>
<p> I have a problem with a Qt program and keyboard device (event1). My problem is that keyboard only works in my Qt embedded application if i run it with sudo on the device itself, not through ssh or startup script in rc.local. I cannot fix this problem for a long time. I though maybe your tutorial could fix the problem. I have set the &quot;s&quot; bit to my application using chmod 4777 app (security is not an issue at the moment) and chmod 4777 /dev/input/event1. Even though the program cant use keyboard. I have set a rule in /etc/udev/rules.d that says: KERNEL==&quot;event1&quot;, MODE=&quot;4777&quot; but the &quot;s&quot; bit is lost after reboot and if I do it manualy with chmod the keyboard still doesnt work&#8230; Do you know maybe what could be the case in here? It is my nightmare.</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-872">
<div id="dsq-comment-header-872" class="dsq-comment-header">
<cite id="dsq-cite-872">
<span id="dsq-author-user-872">Dhananjay</span>
</cite>
</div>
<div id="dsq-comment-body-872" class="dsq-comment-body">
<div id="dsq-comment-message-872" class="dsq-comment-message"><p> This is very help full. I&nbsp;Got clear understanding of the suid in linux. Thank you !</p>
<p> &nbsp;</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-1557">
<div id="dsq-comment-header-1557" class="dsq-comment-header">
<cite id="dsq-cite-1557">
<span id="dsq-author-user-1557">AndrewC</span>
</cite>
</div>
<div id="dsq-comment-body-1557" class="dsq-comment-body">
<div id="dsq-comment-message-1557" class="dsq-comment-message"><p>Great article! Thanks!!</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-1560">
<div id="dsq-comment-header-1560" class="dsq-comment-header">
<cite id="dsq-cite-1560">
<a id="dsq-author-user-1560" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra</a>
</cite>
</div>
<div id="dsq-comment-body-1560" class="dsq-comment-body">
<div id="dsq-comment-message-1560" class="dsq-comment-message"><p>Thanks for complements Andrew</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1707">
<div id="dsq-comment-header-1707" class="dsq-comment-header">
<cite id="dsq-cite-1707">
<a id="dsq-author-user-1707" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra</a>
</cite>
</div>
<div id="dsq-comment-body-1707" class="dsq-comment-body">
<div id="dsq-comment-message-1707" class="dsq-comment-message"><p>No worries..!</p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1817">
<div id="dsq-comment-header-1817" class="dsq-comment-header">
<cite id="dsq-cite-1817">
<span id="dsq-author-user-1817">arpan</span>
</cite>
</div>
<div id="dsq-comment-body-1817" class="dsq-comment-body">
<div id="dsq-comment-message-1817" class="dsq-comment-message"><p>there is a bit confusion i have.<br/>
I have created a script which just create directory in /root(home directory of root user). I did setuid permission.<br/>
now when i run the script with other user it gives me error</p>
<p>mkdir: cannot create directory `/root/dir1&#8242;: Permission denied</p>
<p>why so?<br/>
it should allow it as root user. As the script owned by root user</p>
</div>
</div>
</li> 
</li> 
</li> 
</li> 
</li> 
</li> 
</li> 
</ul>
</div>
</div>
</div> 
<div class="et_pb_extra_column_sidebar">
<div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="http://www.linuxnix.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s"/>
</label>
<input type="submit" class="search-submit" value="Search"/>
</form></div>  <div id="wp_subscribe-2" class="et_pb_widget wp_subscribe">
<div class="wp-subscribe no-name-field" id="wp-subscribe">
<h4 class="title">Get more stuff like this<br/> <span>in your inbox</span></h4>
<p class="text">Subscribe to our mailing list and get interesting stuff and updates to your email inbox.</p>
<form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" _lpchecked="1">
                        <input class="email-field" type="text" value="" placeholder="Enter your email here" name="email">
                        <input type="hidden" value="TheLinuxJuggernaut" name="uri"><input type="hidden" name="loc" value="en_US">
                        <input class="submit" name="submit" type="submit" value="Sign Up Now">
                    </form>
                
                                <div class="clear"></div>
                
                <p class="footer-text">we respect your privacy and take protecting it seriously</p>
                
            </div><!--subscribe_widget-->
        
        </div> <!-- end .et_pb_widget --><div id="et_social_followers-3" class="et_pb_widget widget_et_social_followers"><h4 class="widgettitle">Follow Us</h4>
		<div class="widget_content">
			<ul class="widget_list">
								<li>
						<a class="et-extra-icon et-extra-icon-facebook et-extra-icon-background social-icon" href="https://www.facebook.com/Linux.Juggernaut/"></a>
						<a href="https://www.facebook.com/Linux.Juggernaut/" class="widget_list_social">
							<h3 class="title">Facebook</h3>
													</a>
					</li>
										<li>
						<a class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background social-icon" href="https://plus.google.com/+Linuxnix"></a>
						<a href="https://plus.google.com/+Linuxnix" class="widget_list_social">
							<h3 class="title">Google+</h3>
													</a>
					</li>
										<li>
						<a class="et-extra-icon et-extra-icon-twitter et-extra-icon-background social-icon" href="https://twitter.com/LINUXNIX"></a>
						<a href="https://twitter.com/LINUXNIX" class="widget_list_social">
							<h3 class="title">Twitter</h3>
														<span class="post-meta">697 followers</span>
													</a>
					</li>
								</ul>
		</div>
		</div> <!-- end .et_pb_widget -->		<div id="et-recent-posts-3" class="et_pb_widget widget_et_recent_entries">		<h4 class="widgettitle">Recent Posts</h4>		<ul class="widget_list">
					<li>
									<a href="http://www.linuxnix.com/mysql-find-table-database-size/" title="Mysql: How to find table and database size?" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="Mysql: How to find table and database size?"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/mysql-find-table-database-size/" class="title">Mysql: How to find table and database size?</a>
										<div class="post-meta">
						<span class="updated">Jan 9, 2017</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>, <a href="http://www.linuxnix.com/category/programming/sql/" rel="tag">SQL</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/ping-utility/" title="PING Utility" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="PING Utility"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/ping-utility/" class="title">PING Utility</a>
										<div class="post-meta">
						<span class="updated">Dec 26, 2016</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/bash-replace-occurrences-last-command/" title="Linux Bash History: Replace occurrences in last command" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="Linux Bash History: Replace occurrences in last command"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/bash-replace-occurrences-last-command/" class="title">Linux Bash History: Replace occurrences in last command</a>
										<div class="post-meta">
						<span class="updated">Nov 20, 2016</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/optimize-use-ram/" title="How to optimize the use of RAM ?" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="How to optimize the use of RAM ?"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/optimize-use-ram/" class="title">How to optimize the use of RAM ?</a>
										<div class="post-meta">
						<span class="updated">Nov 20, 2016</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/list-running-vhosts-apache/" title="How to list running vhosts on Apache" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="How to list running vhosts on Apache"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/list-running-vhosts-apache/" class="title">How to list running vhosts on Apache</a>
										<div class="post-meta">
						<span class="updated">Nov 19, 2016</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>					</div>
				</div>
			</li>
						</ul>
		</div> <!-- end .et_pb_widget --><div id="et-recent-comments-3" class="et_pb_widget widget_et_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments" class="widget_list"><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/puppet-congiuration-managment-terminology/#comment-1885">Puppet terminology for newbe Linux users</a></div></li><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/linuxunix-zip-and-unzip-command-examples/#comment-1884">13 Zip and Unzip command examples in Linux/Unix</a></div></li><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/7-linux-read-command-examples-shell-scripting/#comment-1883">7 Linux read command examples for Shell scripting</a></div></li><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/regular-expressions-linux-i/#comment-1882">Regular Expressions in Linux Explained with Examples</a></div></li><li class="recentcomments"><span class="author">Babab Dayryam</span>  <div class="post-title">on <a href="http://www.linuxnix.com/regular-expressions-linux-i/#comment-1881">Regular Expressions in Linux Explained with Examples</a></div></li></ul></div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">ABOUT ME..!</h4>			<div class="textwidget"><p><a href="/wp-content/uploads/2010/05/My-photo.jpg"><img class="alignnone size-full wp-image-2382" src="/wp-content/uploads/2010/05/My-photo.jpg" alt="My photo"></a><br />
My name is Surendra Kumar Anne. I hail from Vijayawada which is cultural capital of south Indian state of Andhra Pradesh. I am a Linux evangelist who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. At present I work at Bank of America as Sr. Analyst Systems and Administration. You can contact me at surendra (@) linuxnix dot com.</p>
</div>
		</div> <!-- end .et_pb_widget --><div id="insticator-embed-3" class="et_pb_widget insticator-embed-class"><!-- Insticator API Fire Widget --><div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div><script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "68177583-1994-412a-be0d-ee99e36ca658"})/*]]>*/</script></div><!-- End Insticator API Fire Widget --></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_2">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<!--<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>-->

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-3347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="http://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li>
<li id="menu-item-3349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="http://www.linuxnix.com/contribute/">Contribute</a></li>
<li id="menu-item-5341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="http://www.linuxnix.com/editorial-board/">Editorial team</a></li>
<li id="menu-item-5342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="http://www.linuxnix.com/support-us/">Support us</a></li>
<li id="menu-item-5382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="http://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
<li id="menu-item-5405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="http://www.linuxnix.com/contact-us/">Contact Us</a></li>
<li id="menu-item-3350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="http://www.linuxnix.com/testimonials/">Testimonials</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	
	<div class="et_social_pin_images_outer">
					<div class="et_social_pinterest_window">
						<div class="et_social_modal_header"><h3>Pin It on Pinterest</h3><span class="et_social_close"></span></div>
						<div class="et_social_pin_images" data-permalink="http://www.linuxnix.com/suid-set-suid-linuxunix/" data-title="What is SUID and how to set SUID in Linux/Unix?" data-post_id="1264"></div>
					</div>
				</div><div class="et_social_sidebar_networks et_social_visible_sidebar et_social_slideright et_social_animated et_social_rectangle et_social_sidebar_flip et_social_withtotalcount et_social_mobile_on et_social_sidebar_networks_right">
					<div class="et_social_totalcount et_social_dark">
							<span class="et_social_totalcount_count et_social_total_share" data-post_id="1264"></span>
							<span class="et_social_totalcount_label">Shares</span>
						</div>
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="https://twitter.com/share?text=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F&#038;url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;via=" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										<div class="et_social_count">
						<span>3</span>
					</div>
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_googleplus">
									<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_googleplus"></i>
										
										<div class="et_social_count">
						<span>40</span>
					</div>
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_buffer">
									<a href="https://bufferapp.com/add?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="buffer" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_buffer"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_digg">
									<a href="https://digg.com/submit?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="digg" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_digg"></i>
										
										<div class="et_social_count">
						<span>3</span>
					</div>
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_evernote">
									<a href="https://www.evernote.com/clip.action?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="evernote" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_evernote"></i>
										
										<div class="et_social_count">
						<span>6</span>
					</div>
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_all_button">
								<a href="#" rel="nofollow" data-location="sidebar" data-page_id="1264" data-permalink="http://www.linuxnix.com/suid-set-suid-linuxunix/" data-title="What is SUID and how to set SUID in Linux/Unix?" class="et_social_open_all">
									<i class="et_social_icon et_social_icon_all_button"></i>
									<span class="et_social_overlay"></span>
								</a>
							</li></ul>
					<span class="et_social_hide_sidebar et_social_icon"></span>
				</div><div class="et_social_mobile_button"></div>
					<div class="et_social_mobile et_social_fadein">
						<div class="et_social_heading">Share This</div>
						<span class="et_social_close"></span>
						<div class="et_social_networks et_social_simple et_social_rounded et_social_left">
							<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_facebook"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Facebook</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="https://twitter.com/share?text=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F&#038;url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;via=" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_twitter"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Twitter</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_googleplus">
									<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;t=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_googleplus"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Google+</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_buffer">
									<a href="https://bufferapp.com/add?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="buffer" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_buffer"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Buffer</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_digg">
									<a href="https://digg.com/submit?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="digg" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_digg"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Digg</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_evernote">
									<a href="https://www.evernote.com/clip.action?url=http%3A%2F%2Fwww.linuxnix.com%2Fsuid-set-suid-linuxunix%2F&#038;title=What%20is%20SUID%20and%20how%20to%20set%20SUID%20in%20Linux%2FUnix%3F" class="et_social_share" rel="nofollow" data-social_name="evernote" data-post_id="1264" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_evernote"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Evernote</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_all_button">
								<a href="#" rel="nofollow" data-location="sidebar" data-page_id="1264" data-permalink="http://www.linuxnix.com/suid-set-suid-linuxunix/" data-title="What is SUID and how to set SUID in Linux/Unix?" class="et_social_open_all">
									<i class="et_social_icon et_social_icon_all_button"></i>
									<span class="et_social_overlay"></span>
								</a>
							</li></ul>
						</div>
					</div>
					<div class="et_social_mobile_overlay"></div><link rel='stylesheet' id='wp-subscribe-css'  href='http://www.linuxnix.com/wp-content/plugins/wp-subscribe/css/wp-subscribe.css?ver=4.5.6' type='text/css' media='all' />
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/includes/builder/scripts/frontend-builder-global-functions.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/plugins/Monarch/js/idle-timer.min.js?ver=1.2.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","pageurl":"http:\/\/www.linuxnix.com\/suid-set-suid-linuxunix\/","stats_nonce":"e9452ab023","share_counts":"64ad2cf912","follow_counts":"4940ad2ce6","total_counts":"d1e0dc4997","media_single":"4a303f3f41","media_total":"4f70cccbb3","generate_all_window_nonce":"663791d33c","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/plugins/Monarch/js/custom.js?ver=1.2.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var viewsCacheL10n = {"admin_ajax_url":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","post_id":"1264"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/plugins/wp-postviews/postviews-cache.js?ver=1.68'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/imagesloaded.min.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/jquery.waypoints.min.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/jquery.fitvids.min.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/smoothscroll.min.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-includes/js/masonry.min.js?ver=3.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"http:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","rating_nonce":"3b3aa8000c","timeline_nonce":"0074ec5a4d","blog_feed_nonce":"11fae56440","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/jquery.raty.min.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-includes/js/comment-reply.min.js?ver=4.5.6'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/includes/builder/scripts/jquery.fitvids.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/includes/builder/scripts/jquery.magnific-popup.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/includes/builder/scripts/jquery.mobile.custom.min.js?ver=1.2.4.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"http:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"20f8a12fb1","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","is_divi_theme_used":"","widget_search_selector":".widget_search"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/themes/Extra/includes/builder/scripts/frontend-builder-scripts.js?ver=1.2.4.4'></script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-includes/js/wp-embed.min.js?ver=4.5.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.5.6","language":""},"disqusIdentifier":"1264 http:\/\/www.linuxnix.com\/?p=1264","disqusShortname":"linuxnix","disqusTitle":"What is SUID and how to set SUID in Linux\/Unix?","disqusUrl":"http:\/\/www.linuxnix.com\/suid-set-suid-linuxunix\/","options":{"manualSync":false},"postId":"1264"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.5.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"linuxnix"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.linuxnix.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.5.6'></script>
</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 3131/3411 objects using apc
Content Delivery Network via N/A
Database Caching 19/54 queries in 0.082 seconds using apc

 Served from: www.linuxnix.com @ 2017-01-27 20:18:37 by W3 Total Cache -->