<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	
	<link rel="pingback" href="https://www.linuxnix.com/xmlrpc.php" />
    <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" />
<style>
 .ABT_float_ads_main_Wrap { width: 100%; max-width: 550px; max-height: 400px; position: fixed; z-index: 98765; background: rgb(59, 89, 152); left: 50%; top: 50%; transform: translate(-50%, -100%); box-sizing: border-box; box-shadow: 0 0 3px rgba(0, 0, 0, 0.2); border-radius: 10px; text-align: center; box-shadow: 0px 0px 3px 1px black; display: none; } .ABT_float_ads_close { margin: 0 auto; text-align: center; padding: 30px 20px 30px; position: absolute; top: -45px; right: -30px; z-index: 9999999; } .ABT_float_ads_close #ABT_close_button { font-size: 25px; color: #fff; display: inline-block; box-shadow: 0 0 3px rgba(0, 0, 0, 1); background: rgb(59, 89, 152); padding: 5px; border-radius: 5px; } #ABT_close_button { cursor: pointer; } #ABT_credits { font-size: 25px; color: #fff; position: absolute; bottom: 2px; right: 5px; display: inline-block; text-shadow: 0 0 3px rgba(0, 0, 0, 0.2); text-decoration: none!important; } .ABT_formWrap { background: rgb(250, 155, 57); padding: 10px; margin: 0px; width: 100%; min-width: 350px; overflow: hidden; box-sizing: border-box; border-radius: 10px; } .ABT_Heading, .ABT_Heading2 { color: #fff; font-size: 28px; font-weight: bold; text-shadow: 0px 0px 3px black; font-family: 'oswald', sans-serif; text-align: center; display: block; padding: 5px 0px; margin: 10px 0px 0px 0px; } .ABT_Heading2 { color: #fff; font-size: 18px; margin-bottom: 20px; font-style: italic; font-weight: 400; margin-top: 5px; } .ABT_Heading2 .fa-rss { color: rgb(250, 155, 57); } .ABT_Heading .fa-heart { color: rgb(227, 27, 35); } .ABT_float_ads_main_Wrap .fa-long-arrow-down { font-size: 40px; z-index: 98567; position: absolute; display: inline-block; padding: 10px; top: 80px; left: 45%; color: white; text-shadow: 0px 0px 5px black; } .ABT_formWrap .ABT_input_group { width: 100%; box-sizing: border-box; position: relative; margin: 0 auto; margin-top: 20px; border: 1px solid rgb(59, 89, 152); border-radius: 4px; } .ABT_input_group:before { color: #fff; content: "\f003"; font-family: FontAwesome; position: absolute; text-align: center; padding: 10px 12px; width: 50px; height: 100%; box-sizing: border-box; background: rgb(59, 89, 152); border: 1px solid rgb(59, 89, 152); text-shadow: 0px 0px 3px black; } .ABT_formWrap .ABT_Email { box-sizing: border-box; width: 100%; padding: 10px 0px 10px 60px; height: 100%; margin: 0px; border: none; border-radius: 4px; border: 1px solid rgb(59, 89, 152); } .ABT_formWrap .button { width: 100%; display: block; padding: 10px; box-sizing: border-box; position: relative; margin: 10px auto; margin-bottom: 20px; border-radius: 4px; background: rgb(59, 89, 152); font-size: 18px; border: none!important; cursor: pointer; text-shadow: 0px 0px 3px black; color: #fff; } .ABT_formWrap, .ABT_innerForm, .ABT_Widget_Container { width: 100%; } .pulse { -webkit-animation: pulse .8s linear infinite; -moz-animation: pulse .8s linear infinite; -ms-animation: pulse .8s linear infinite; animation: pulse .8s linear infinite } @keyframes pulse { 0% { -webkit-transform: scale(1); -moz-transform: scale(1); -o-transform: scale(1); -ms-transform: scale(1); transform: scale(1) } 50% { -webkit-transform: scale(0.8); -moz-transform: scale(0.8); -o-transform: scale(0.8); -ms-transform: scale(0.8); transform: scale(0.8) } 100% { -webkit-transform: scale(1); -moz-transform: scale(1); -o-transform: scale(1); -ms-transform: scale(1); transform: scale(1) } } @-moz-keyframes pulse { 0% { -moz-transform: scale(1); transform: scale(1) } 50% { -moz-transform: scale(0.8); transform: scale(0.8) } 100% { -moz-transform: scale(1); transform: scale(1) } } @-webkit-keyframes &quot; pulse&quot; { 0% { -webkit-transform: scale(1); transform: scale(1) } 50% { -webkit-transform: scale(0.8); transform: scale(0.8) } 100% { -webkit-transform: scale(1); transform: scale(1) } } @-ms-keyframes &quot; pulse&quot; { 0% { -ms-transform: scale(1); transform: scale(1) } 50% { -ms-transform: scale(0.8); transform: scale(0.8) } 100% { -ms-transform: scale(1); transform: scale(1) }
    </style>
   

<script type="text/javascript">
    window.onload = function() {
        var ABT_closeButton = document.getElementById('ABT_close_button');
        var ABT_float_ads_main_Wrap = document.getElementById("ABT_float_ads_main_Wrap");
        myVar = setTimeout(function() {
            ABT_float_ads_main_Wrap.style.display = 'block'
        }, 3000);
        ABT_closeButton.onclick = function() {
            document.getElementById("ABT_float_ads_main_Wrap").style.display = 'none';
        }
    }
</script>

		<!--[if lt IE 9]>
	<script src="https://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
	<!-- Header Tag Code -->
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/a30dc085-55ae-4bb0-9e46-774d36a290eb.js');/*]]>*/</script>
<!-- End Header Tag Code -->

	<title>How does /tmp directory get emptied automatically over time ? - The Linux Juggernaut</title>
<script type="text/javascript">//<![CDATA[
            function BaGetCookie(c_name) { var i,x,y,ARRcookies=document.cookie.split(";"); for (i=0;i<ARRcookies.length;i++) { x=ARRcookies[i].substr(0,ARRcookies[i].indexOf("=")); y=ARRcookies[i].substr(ARRcookies[i].indexOf("=")+1); x=x.replace(/^\s+|\s+$/g,""); if (x==c_name) { return unescape(y); } } }
            function BaSetCookie( name, value, exdays, path, domain, secure) { var exdate=new Date(); exdate.setDate(exdate.getDate() + exdays); document.cookie = name + "=" + escape(value) + ((exdate == null) ? "" : "; expires=" + exdate.toUTCString()) + ((path == null) ? "; path=/" : "; path=" + path) + ((domain == null) ? "" : "; domain=" + domain) +((secure == null) ? "" : "; secure");}
            //]]></script>
<!-- This site is optimized with the Yoast SEO plugin v8.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How does /tmp directory get emptied automatically over time ? - The Linux Juggernaut" />
<meta property="og:description" content="Introduction In order to maintain overall operating system stability it is important to check that directories/file systems being used as temporary storage space by applications should get full. This is because a temporary file system out of space could cause a server to go into hung state and under extreme circumstances even a kernel panic &hellip;" />
<meta property="og:url" content="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/" />
<meta property="og:site_name" content="The Linux Juggernaut" />
<meta property="article:section" content="Basics" />
<meta property="article:published_time" content="2019-01-22T04:35:36+00:00" />
<meta property="og:image" content="https://www.linuxnix.com/wp-content/uploads/2018/09/How-does-tmp-directory-get-emptied-automatically-over-time-title.jpg" />
<meta property="og:image:secure_url" content="https://www.linuxnix.com/wp-content/uploads/2018/09/How-does-tmp-directory-get-emptied-automatically-over-time-title.jpg" />
<meta property="og:image:width" content="586" />
<meta property="og:image:height" content="282" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Introduction In order to maintain overall operating system stability it is important to check that directories/file systems being used as temporary storage space by applications should get full. This is because a temporary file system out of space could cause a server to go into hung state and under extreme circumstances even a kernel panic [&hellip;]" />
<meta name="twitter:title" content="How does /tmp directory get emptied automatically over time ? - The Linux Juggernaut" />
<meta name="twitter:image" content="https://www.linuxnix.com/wp-content/uploads/2018/09/How-does-tmp-directory-get-emptied-automatically-over-time-title.jpg" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Person","url":"https:\/\/www.linuxnix.com\/","sameAs":[],"@id":"#person","name":"Surendra Anne"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//static.mailerlite.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Feed" href="https://www.linuxnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Comments Feed" href="https://www.linuxnix.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; How does /tmp directory get emptied automatically over time ? Comments Feed" href="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.4.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.4.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-752078-3';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-752078-3', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><!--noptimize--><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><!--/noptimize--><meta content="Extra v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='cupStyle-css'  href='https://www.linuxnix.com/wp-content/plugins/contact-us-page/css/cupStyle.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='email-subscribers-advanced-form-css'  href='https://www.linuxnix.com/wp-content/plugins/email-subscribers-advanced-form/assets/css/styles.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='es-widget-css-css'  href='https://www.linuxnix.com/wp-content/plugins/email-subscribers/widget/es-widget.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='ts_fab_css-css'  href='https://www.linuxnix.com/wp-content/plugins/fancier-author-box/css/ts-fab.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='magic-liquidizer-table-style-css'  href='https://www.linuxnix.com/wp-content/plugins/magic-liquidizer-responsive-table/idcss/ml-responsive-table.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mailerlite_forms.css-css'  href='https://www.linuxnix.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.linuxnix.com/wp-includes/css/dashicons.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css'  href='https://www.linuxnix.com/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.2.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-sub-style-css'  href='https://www.linuxnix.com/wp-content/plugins/wp-feedburner-email-subscriber/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='extra-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://www.linuxnix.com/wp-content/themes/Extra/style.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.linuxnix.com/wp-content/themes/Extra/includes/builder/styles/magnific_popup.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://www.linuxnix.com/?sccss=1&#038;ver=4.9.9' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var BaAjax = {"ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxnix.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>

<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.linuxnix.com","hash_tracking":"false"};
/* ]]> */
</script>




<script type='text/javascript' src='https://static.mailerlite.com/js/jquery.validate.min.js?ver=4.9.9'></script>
<link rel='https://api.w.org/' href='https://www.linuxnix.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxnix.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.9" />
<link rel='shortlink' href='https://www.linuxnix.com/?p=7876' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxnix.com%2Fhow-does-tmp-directory-get-emptied-automatically-over-time%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxnix.com%2Fhow-does-tmp-directory-get-emptied-automatically-over-time%2F&#038;format=xml" />
    <!-- MailerLite Universal -->
    <script>
        (function(m,a,i,l,e,r){m['MailerLiteObject']=e;function f(){
        var c={a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
        f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
        var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?'+(~~(new Date().getTime()/10000000));
        _.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '1233092', 'h2f1i6t6q7', 'load');
    </script>
    <!-- End MailerLite Universal -->
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<style type="text/css" id="extra-dynamic-styles-primary_nav_text_color-color">
#et-menu > li a,
#et-menu > li.menu-item-has-children > a:after,
#et-menu > li.mega-menu-featured > a:after,
#et-extra-mobile-menu > li.mega-menu-featured > a:after {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-color">
#et-menu > li > a:hover,
#et-menu > li.menu-item-has-children > a:hover:after,
#et-menu > li.mega-menu-featured > a:hover:after,
#et-navigation > ul#et-menu > li.current-menu-item > a,
#et-navigation > ul#et-menu > li.current_page_item > a,
#et-extra-mobile-menu > li.mega-menu-featured > a:hover:after,
#et-extra-mobile-menu > li.current-menu-item > a,
#et-extra-mobile-menu > li.current_page_item > a,
#et-extra-mobile-menu > li > a:hover {
	color: #1e73be;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-background-color">
#et-navigation > ul > li > a:before {
	background-color: #1e73be;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_background_color-background-color">
#main-header {
	background-color: #ffffff;
}

</style>

<style type="text/css" id="extra-dynamic-styles-button_text_color-color">
#page-container .button,
#page-container button,
#page-container button[type="submit"],
#page-container input[type="submit"],
#page-container input[type="reset"],
#page-container input[type="button"],
.read-more-button,
.comment-body .comment_area .comment-content .reply-container .comment-reply-link,
.widget_tag_cloud a,
.widget_tag_cloud a:visited,
.post-nav .nav-links .button,
a.read-more-button,
a.read-more-button:visited,
#footer .widget_tag_cloud a,
#footer .widget_tag_cloud a:visited,
#footer a.read-more-button,
#footer a.read-more-button:visited,
#footer .button,
#footer button,
#footer button[type="submit"],
#footer input[type="submit"],
#footer input[type="reset"],
#footer input[type="button"] {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-button_hover_text_color-color">
#page-container .button:hover,
#page-container button:hover,
#page-container button[type="submit"]:hover,
#page-container input[type="submit"]:hover,
#page-container input[type="reset"]:hover,
#page-container input[type="button"]:hover,
.read-more-button:hover,
.comment-body .comment_area .comment-content .reply-container .comment-reply-link:hover,
.widget_tag_cloud a:hover,
.widget_tag_cloud a:visited:hover,
.post-nav .nav-links .button:hover,
a.read-more-button:hover,
a.read-more-button:visited:hover,
#footer .widget_tag_cloud a:hover,
#footer .widget_tag_cloud a:visited:hover,
#footer a.read-more-button:hover,
#footer a.read-more-button:visited:hover,
#footer .button:hover,
#footer button:hover,
#footer button[type="submit"]:hover,
#footer input[type="submit"]:hover,
#footer input[type="reset"]:hover,
#footer input[type="button"]:hover {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-extra_nav_height_value">

			@media only screen and (min-width: 768px) {
				#main-header .logo {
					height: 48.45px;
					margin: 23.275px 0;
				}
				.header.left-right #et-navigation > ul > li > a {
					padding-bottom: 39.5px;
				}
			}
			@media only screen and (min-width: 768px) {
				.et-fixed-header #main-header .logo {
					height: 48.45px;
					margin: 23.275px 0;
				}
				.et-fixed-header .header.left-right #et-navigation > ul > li > a {
					padding-bottom: 39.5px;
				}
			}</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-752078-3', 'auto');
  ga('send', 'pageview');

</script><link rel="icon" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-270x270.png" />
<style type="text/css" id="et-custom-css">
@media screen and (max-width: 900px)
{
#main-header .etad {
display: none;
}
}

#top-header {
    background-color: #B11B3D;
}

.et_pb_extra_module .main-post article .header img, .et_extra_other_module .main-post article .header img {
    display: block;
    width: auto;
    /* max-width: 100%; */
    object-fit: cover;
    height: 158px;
    width: 100%;
}
pre {
    border: 1px solid #DDD;
    overflow: auto;
    background: #EEE;
    font-size: .857em;
    line-height: 1.5em;
    margin-bottom: 1.833em;
    padding: .667em .917em;
    clear: both;
    color: #000;
}
.posts-blog-feed-module.masonry .post-content {
padding: 20px !important;
}

.author-box {
  display: none;
}

.post-thumbnail img {
  width: auto;
  margin: 0 auto;
}

#disqus_thread {
    background: #fff;
    padding: 20px;
    border-radius: 3px;
    box-shadow: 0 1px 3px rgba(0,0,0,0.1);
    box-sizing: border-box;
}
</style></head>
<body data-ocssl='1' class="post-template-default single single-post postid-7876 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right unknown et_includes_sidebar">

	<div id="page-container">
				<!-- Header -->
		<header class="header left-right">
						<!-- #top-header -->
			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="et-trending">
						
							<!-- ET Trending -->
							<div id="et-trending">

								<!-- ET Trending Button -->
								<a id="et-trending-button" href="#" title="">
									<span></span>
									<span></span>
									<span></span>
								</a>

								<!-- ET Trending Label -->
								<h4 id="et-trending-label">
									TRENDING:								</h4>

								<!-- ET Trending Post Loop -->
								<div id='et-trending-container'>
																											<div id="et-trending-post-1264" class="et-trending-post et-trending-latest">
											<a href="https://www.linuxnix.com/suid-set-suid-linuxunix/">What is SUID and how to set SUID in Linux/Unix?</a>
										</div>
																			<div id="et-trending-post-1297" class="et-trending-post">
											<a href="https://www.linuxnix.com/sticky-bit-set-linux/">What is a sticky Bit and how to set it in Linux?</a>
										</div>
																			<div id="et-trending-post-1093" class="et-trending-post">
											<a href="https://www.linuxnix.com/linux-top-command-explained-2/">Linux TOP command explained</a>
										</div>
																									</div>
							</div>
							<ul id="et-secondary-menu" class="nav"><li id="menu-item-5405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="https://www.linuxnix.com/contact-us/">Contact Us</a></li>
<li id="menu-item-3350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="https://www.linuxnix.com/testimonials/">Testimonials</a></li>
<li id="menu-item-6050" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6050"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
<li id="menu-item-3347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="https://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li>
<li id="menu-item-3349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="https://www.linuxnix.com/contribute/">Contribute</a></li>
<li id="menu-item-5341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="https://www.linuxnix.com/editorial-board/">Editorial team</a></li>
<li id="menu-item-5342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="https://www.linuxnix.com/support-us/">Support us</a></li>
<li id="menu-item-5382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
</ul>
												</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-extra-social-icons -->
						<ul class="et-extra-social-icons" style="">
																																														<li class="et-extra-social-icon facebook">
									<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
								</li>
																																															<li class="et-extra-social-icon twitter">
									<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
								</li>
																																																																																																																																																																																																										<li class="et-extra-social-icon instagram">
									<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
								</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																								</ul>
						
						<!-- .et-top-search -->
												<div class="et-top-search" style="">
							<form role="search" class="et-search-form" method="get" action="https://www.linuxnix.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form>						</div>
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			
        

        
				<div id="main-header" data-fixed-height="95">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://www.linuxnix.com/" data-fixed-height="51">
							<img src="https://www.linuxnix.com/wp-content/uploads/2016/08/linux.png" alt="The Linux Juggernaut" id="logo" />
						</a>
<!-- Insticator API Fire Widget Ads Code -->
<div id="div-insticator-ad-3"></div>
<script data-cfasync='false' type="text/javascript">
/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-3");/*]]>*/
</script>
<!-- End Insticator API Fire Widget Ads Code -->
												  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- new_responsvie -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7992389594799240"
     data-ad-slot="3872473351"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>

					</div>
					<!-- /.container -->
						<div class="subHeader">
						<div class="container">
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5531"><a href="https://www.linuxnix.com/category/administration/">Administration</a>
<ul class="sub-menu">
	<li id="menu-item-5534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5534"><a href="https://www.linuxnix.com/category/administration/monitoring/">Monitoring</a></li>
	<li id="menu-item-5533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5533"><a href="https://www.linuxnix.com/category/administration/security/">Security</a></li>
	<li id="menu-item-5532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5532"><a href="https://www.linuxnix.com/category/administration/servers/">Servers</a></li>
</ul>
</li>
<li id="menu-item-5536" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5536"><a href="https://www.linuxnix.com/category/basics/">Basics</a></li>
<li id="menu-item-5544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5544"><a href="/category/cloudvirtulization/">Cloud</a>
<ul class="sub-menu">
	<li id="menu-item-5545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5545"><a href="/category/cloudvirtulization/aws/">AWS</a></li>
	<li id="menu-item-5540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5540"><a href="https://www.linuxnix.com/category/cloudvirtulization/kvm/">KVM</a></li>
</ul>
</li>
<li id="menu-item-5546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5546"><a href="/category/Devops/">Devops</a>
<ul class="sub-menu">
	<li id="menu-item-5547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5547"><a href="/category/Devops/Ansible/">Ansible</a></li>
	<li id="menu-item-5548" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5548"><a href="/category/Devops/Docker/">Docker</a></li>
	<li id="menu-item-5549" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5549"><a href="/category/Devops/Packer/">Packer</a></li>
	<li id="menu-item-5550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5550"><a href="/category/Devops/Puppet/">Puppet</a></li>
	<li id="menu-item-5551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5551"><a href="/category/Devops/Vagrant/">Vagrant</a></li>
</ul>
</li>
<li id="menu-item-5537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5537"><a href="https://www.linuxnix.com/category/interviews-2/">Interviews</a></li>
<li id="menu-item-5535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5535"><a href="https://www.linuxnix.com/category/news/">News</a></li>
<li id="menu-item-5552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5552"><a href="/category/offers/">Offers</a></li>
<li id="menu-item-5553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5553"><a href="/category/Programming/">Programming</a>
<ul class="sub-menu">
	<li id="menu-item-5554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5554"><a href="/category/Programming/awk/">Awk</a></li>
	<li id="menu-item-5538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5538"><a href="https://www.linuxnix.com/category/programming/bash/">Bash</a></li>
	<li id="menu-item-5555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5555"><a href="/category/Programming/Batch/">Batch</a></li>
	<li id="menu-item-5556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5556"><a href="/category/Programming/git/">Git</a></li>
	<li id="menu-item-5557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5557"><a href="/category/Programming/Perl/">Perl</a></li>
	<li id="menu-item-5558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5558"><a href="/category/Programming/PowerShell/">PowerShell</a></li>
	<li id="menu-item-5539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5539"><a href="https://www.linuxnix.com/category/programming/python/">python</a></li>
	<li id="menu-item-5559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5559"><a href="/category/Programming/Ruby/">Ruby</a></li>
	<li id="menu-item-5560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5560"><a href="/category/Programming/Sed/">Sed</a></li>
	<li id="menu-item-5561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5561"><a href="/category/Programming/SQL/">SQL</a></li>
</ul>
</li>
<li id="menu-item-5562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5562"><a href="/category/Reviews/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-5563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5563"><a href="/category/Reviews/Books/">Books</a></li>
	<li id="menu-item-5564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5564"><a href="/category/Reviews/Linuxunix/">Linux/Unix</a></li>
	<li id="menu-item-5565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5565"><a href="/category/reviews/open-source/">Open source</a></li>
</ul>
</li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
						</div>
						</div>
				</div><!-- /#main-header -->
			<!-- /#main-header-wrapper -->

		</header>
				<div id="main-content">
	<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-7876" class="module single-post-module post-7876 post type-post status-publish format-standard hentry category-basics et-doesnt-have-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">How does /tmp directory get emptied automatically over time ?</h1>
								<div class="post-meta">
									<p>Posted by <a href="https://www.linuxnix.com/author/sohil_suri/" class="url fn" title="Posts by Sahil Suri" rel="author">Sahil Suri</a> | <span class="updated">Jan 22, 2019</span> | <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a> | <a class="comments-link" href="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
								</div>
							</div>
							
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p><img class="size-full wp-image-7877 aligncenter" src="https://www.linuxnix.com/wp-content/uploads/2018/09/How-does-tmp-directory-get-emptied-automatically-over-time-title.jpg" alt="" width="586" height="282" /></p>
<h4>Introduction</h4>
<p>In order to maintain overall operating system stability it is important to check that directories/file systems being used as temporary storage space by applications should get full. This is because a temporary file system out of space could cause a server to go into hung state and under extreme circumstances even a kernel panic might occur.  Have you ever wondered why most files inside the /tmp directory get deleted over some time if they are left unused? If you have then this article is for you. In this article we will explain how and why the /tmp directory gets emptied over a period of time on Linux systems.</p>
<p>We will explaining the concept on Centos 6/RHEL 6 systems. The mechanism is different in case of Centos 7/RHEL 7 systems.</p>
<p>A program named tmpwatch is responsible for periodically cleaning up the /tmp and /var/tmp directories on Centos 6/RHEL 6 systems. tmpwatch recursively removes files which haven&#8217;t been accessed for a given time. Normally, it&#8217;s used to clean up directories which are used for temporary holding space such as /tmp. It does not follow symbolic links in the directories when it&#8217;s cleaning up the directory, will not switch file systems, skips lost+found and directories owned by the root user. The tmpwatch program should be installed on the system by default and you confirm the same by performing a query on it using the rpm command as shown below:</p>
<pre><strong>[sahil@linuxnix:~] $ rpm -qa | grep -i tmpwatch</strong>
<strong>tmpwatch-2.9.16-6.el6.x86_64</strong></pre>
<p>This utility provides a couple of files which includes the tmpwatch binary itself along with other files the most important one being /etc/cron.daily/tmpwatch.</p>
<pre><strong>[sahil@linuxnix:~] $ rpm -ql tmpwatch</strong>
<strong>/etc/cron.daily/tmpwatch</strong>
<strong>/usr/bin/tmpwatch</strong>
<strong>/usr/sbin/tmpwatch</strong>
<strong>/usr/share/doc/tmpwatch-2.9.16</strong>
<strong>/usr/share/doc/tmpwatch-2.9.16/COPYING</strong>
<strong>/usr/share/doc/tmpwatch-2.9.16/ChangeLog</strong>
<strong>/usr/share/doc/tmpwatch-2.9.16/NEWS</strong>
<strong>/usr/share/doc/tmpwatch-2.9.16/README</strong>
<strong>/usr/share/man/man8/tmpwatch.8.gz</strong></pre>
<p>The cronjob or script defined in /etc/cron.daily/tmpwatch executes once every day at 3:05 a.m. The time of execution of the script is defined by the values mentioned in the /etc/anacrontab file. Given below is the content of the file on a Centos 6 system:</p>
<pre><strong>[root@linuxnix ~]# cat /etc/anacrontab</strong>
<strong># /etc/anacrontab: configuration file for anacron</strong>

<strong># See anacron(8) and anacrontab(5) for details.</strong>

<strong>SHELL=/bin/sh</strong>
<strong>PATH=/sbin:/bin:/usr/sbin:/usr/bin</strong>
<strong>MAILTO=root</strong>
<strong># the maximal random delay added to the base delay of the jobs</strong>
<strong>RANDOM_DELAY=45</strong>
<strong># the jobs will be started during the following hours only</strong>
<strong>START_HOURS_RANGE=3-22</strong>

<strong>#period in days delay in minutes job-identifier command</strong>
<strong>1 5 cron.daily nice run-parts /etc/cron.daily</strong>
<strong>7 25 cron.weekly nice run-parts /etc/cron.weekly</strong>
<strong>@monthly 45 cron.monthly nice run-parts /etc/cron.monthly</strong></pre>
<p>This states that every script contained in the /etc/cron.daily directory will be executed once every day at 3:05 a.m. Given below is the /etc/cron.daily/tmpwatch script:</p>
<pre><strong>[root@linuxnix ~]# cat /etc/cron.daily/tmpwatch</strong>
<strong>#! /bin/sh</strong>
<strong>flags=-umc</strong>
<strong>/usr/sbin/tmpwatch "$flags" -x /tmp/.X11-unix -x /tmp/.XIM-unix \</strong>
<strong>-x /tmp/.font-unix -x /tmp/.ICE-unix -x /tmp/.Test-unix \</strong>
<strong>-X '/tmp/hsperfdata_*' -X '/tmp/.hdb*lock' -X '/tmp/.sapstartsrv*.log' \</strong>
<strong>-X '/tmp/pymp-*' 10d /tmp</strong>
<strong>/usr/sbin/tmpwatch "$flags" 30d /var/tmp</strong>
<strong>for d in /var/{cache/man,catman}/{cat?,X11R6/cat?,local/cat?}; do</strong>
<strong>if [ -d "$d" ]; then</strong>
<strong>/usr/sbin/tmpwatch "$flags" -f 30d "$d"</strong>
<strong>fi</strong>
<strong>done</strong></pre>
<p>Given below is a description of the options used in the above script</p>
<p><strong>-u, &#8211;atime</strong><br />
Make the decision about deleting a file based on the file&#8217;s atime (access time). This is the default.</p>
<p>Note that the periodic updatedb file system scans keep the atime of directories recent.</p>
<p><strong>-m, &#8211;mtime</strong><br />
Make the decision about deleting a file based on the file&#8217;s mtime (modification time) instead of the atime.</p>
<p><strong>-c, &#8211;ctime</strong><br />
Make the decision about deleting a file based on the file&#8217;s ctime (inode change time) instead of the atime; for directories, make the decision based on<br />
the mtime.</p>
<p><strong>-x, &#8211;exclude=path</strong><br />
Skip path; if path is a directory, all files contained in it are skipped too. If path does not exist, it must be an absolute path that contains no symbolic links.</p>
<p><strong>-X, &#8211;exclude-pattern=pattern</strong><br />
Skip paths matching pattern; if a directory matches pattern, all files contained in it are skipped too. pattern must match an absolute path that contains no symbolic links.</p>
<p>The time argument is a number with an optional single-character suffix specifying the units: m for minutes, h for hours, d for days. If no suffix is specified, time is in hours. 30d and 10d refer to the time interval after which tmpwatch will perform a clean up of the target directory.</p>
<p>&nbsp;</p>
<h4>Demonstration:</h4>
<p>We do not need to rely on the defaults that have been provided with the cron.daily script for tmpwatch. In case we require a different setup as compared to the default then we could implement our requirement with ease. Just to demonstrate how we could use this, I&#8217;ve created a couple of files in the /tmp file system</p>
<pre><strong>[root@linuxnix tmp]# ls -l</strong>
<strong>total 12</strong>
<strong>-rw-r--r--. 1 sahil sahil 4 Feb 20 16:02 file1</strong>
<strong>-rw-r--r--. 1 sahil sahil 4 Feb 20 16:02 file2</strong>
<strong>-rw-r--r--. 1 sahil sahil 0 Feb 20 16:02 file3</strong>
<strong>-rw-r--r--. 1 sahil sahil 0 Feb 20 16:02 file4</strong>
<strong>-rw-r--r--. 1 sahil sahil 0 Feb 20 16:02 file5</strong>
<strong>drwx------. 2 root root 4096 Feb 20 15:47 ssh-NjfmTj3097</strong></pre>
<p>After a couple of minutes I executed the following command:</p>
<pre><strong>[root@linuxnix tmp]# /usr/sbin/tmpwatch 2m /tmp</strong></pre>
<p>This resulted in the removal of files and directories in the /tmp file systems that had not been accessed in the last 2 minutes. The invocation of this command resulted in the removal of the five recently created files.</p>
<pre><strong>[root@linuxnix tmp]# ls -l</strong>
<strong>total 4</strong>
<strong>drwx------. 2 root root 4096 Feb 20 15:47 ssh-NjfmTj3097</strong>
<strong>[root@linuxnix tmp]#</strong></pre>
<h4>Conclusion</h4>
<p>In this article, we explained how the contents of the /tmp file system get removed over time and we also showed you a quick demonstration of using the tmpwatch command. We hope that you&#8217;ve found this article to be useful and we look forward towards your suggestions and feedback.</p>
<div class="post-views post-7876 entry-meta">
			<span class="post-views-icon dashicons dashicons-chart-bar"></span>
			<span class="post-views-label">Post Views: </span>
			<span class="post-views-count">377</span>
			</div><div id="ts-fab-below" class="ts-fab-wrapper"><span class="screen-reader-text">The following two tabs change content below.</span><ul class="ts-fab-list"><li class="ts-fab-bio-link"><a href="#ts-fab-bio-below">Bio</a></li><li class="ts-fab-latest-posts-link"><a href="#ts-fab-latest-posts-below">Latest Posts</a></li></ul><div class="ts-fab-tabs">
	<div class="ts-fab-tab" id="ts-fab-bio-below">
		<div class="ts-fab-avatar"><img alt='' src='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /><div class="ts-fab-social-links"></div>
		</div>
		
		<div class="ts-fab-text">
			<div class="ts-fab-header"><h4>Sahil Suri</h4></div><!-- /.ts-fab-header -->
			<div class="ts-fab-content">He started his career in IT in 2011 as a system administrator. He has since worked with HP-UX, Solaris and Linux operating systems along with exposure to high availability and virtualization solutions.
He has a keen interest in shell, Python and Perl scripting and is learning the ropes on AWS cloud, DevOps tools, and methodologies. He enjoys sharing the knowledge he's gained over the years with the rest of the community.</div>
		</div>
	</div>
	<div class="ts-fab-tab" id="ts-fab-latest-posts-below">
		<div class="ts-fab-avatar"><img alt='' src='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /><div class="ts-fab-social-links"></div>
		</div>
		<div class="ts-fab-text">
			<div class="ts-fab-header">
				<h4>Latest posts by Sahil Suri <span class="latest-see-all">(<a href="https://www.linuxnix.com/author/sohil_suri/" rel="nofollow">see all</a>)</span></h4>
			</div>
			<ul class="ts-fab-latest">
				<li>
					<a href="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">How does /tmp directory get emptied automatically over time ?</a><span> - January 22, 2019</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/oracle-virtualbox-installation-troubleshooting-in-linux-explained/">Oracle VirtualBox installation troubleshooting in Linux explained</a><span> - October 23, 2018</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/how-to-install-oracle-virtual-box-on-centos-7/">How to install Oracle virtual box on Centos 7?</a><span> - October 22, 2018</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/understanding-swapiness-parameter-in-linux/">Understanding swapiness parameter in Linux</a><span> - September 20, 2018</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/resolving-yum-repodata-is-over-2-weeks-old-install-yum-cron-or-run-yum-makecache-fast/">Resolving YUM: Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast</a><span> - September 19, 2018</span> 
				</li>
		</ul></div>
	</div>
		</div>
	</div>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;t=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Facebook" data-network-name="facebook" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/home?status=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F%20https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Twitter" data-network-name="twitter" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;t=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Google +" data-network-name="googleplus" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;t=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Tumblr" data-network-name="tumblr" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;description=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Pinterest" data-network-name="pinterest" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;title=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via LinkedIn" data-network-name="linkedin" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;title=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Buffer" data-network-name="buffer" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/&#038;title=How%20does%20%2Ftmp%20directory%20get%20emptied%20automatically%20over%20time%20%3F" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Email" data-network-name="basic_email" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;How does /tmp directory get emptied automatically over time ?&quot; via Print" data-network-name="basic_print" data-share-title="How does /tmp directory get emptied automatically over time ?" data-share-url="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="7876" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #8bd623;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://www.linuxnix.com/deep-dive-into-jenkins-what-are-all-jenkins-functionalities/" rel="prev"><span class="button">Previous</span><span class="title">Deep-Dive into Jenkins &#8211; What are all Jenkins functionalities ?</span></a>								</div>
								<div class="nav-link nav-link-next">
																	</div>
							</div>
						</nav>

												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/understanding-swapiness-parameter-in-linux/" title="Understanding swapiness parameter in Linux" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Understanding swapiness parameter in Linux" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/understanding-swapiness-parameter-in-linux/">Understanding swapiness parameter in Linux</a></h4>
									<p class="date"><span class="updated">September 20, 2018</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/9-bzip-bunzip-command-examples-linuxunix/" title="9 bzip and bunzip command examples in Linux/Unix" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="9 bzip and bunzip command examples in Linux/Unix" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/9-bzip-bunzip-command-examples-linuxunix/">9 bzip and bunzip command examples in Linux/Unix</a></h4>
									<p class="date"><span class="updated">September 22, 2017</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/generate-random-number-bash/" title="How to generate a random number in Bash" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="How to generate a random number in Bash" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/generate-random-number-bash/">How to generate a random number in Bash</a></h4>
									<p class="date"><span class="updated">November 19, 2016</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/lsblk-command-explained-with-examples/" title="5 lsblk command examples in Linux" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="5 lsblk command examples in Linux" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/lsblk-command-explained-with-examples/">5 lsblk command examples in Linux</a></h4>
									<p class="date"><span class="updated">October 31, 2017</span></p>
								</div>
																							</div>
						</div>
										
				
<div id="disqus_thread"></div>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="lsi_widget-2" class="et_pb_widget widget_lsi_widget"><h4 class="widgettitle">Over 16,000 readers, Get fresh content from &#8220;The Linux juggernaut&#8221;</h4><ul class="lsi-social-icons icon-set-lsi_widget-2" style="text-align: center"><li class="lsi-social-facebook"><a class="tooltip" rel="nofollow" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/Linux.Juggernaut" target="_blank"><i class="lsicon lsicon-facebook"></i></a></li><li class="lsi-social-twitter"><a class="tooltip" rel="nofollow" title="Twitter" aria-label="Twitter" href="https://twitter.com/linuxnix" target="_blank"><i class="lsicon lsicon-twitter"></i></a></li><li class="lsi-social-gplus"><a class="tooltip" rel="nofollow" title="Google+" aria-label="Google+" href="https://plus.google.com/+SurendraKumarAnne" target="_blank"><i class="lsicon lsicon-gplus"></i></a></li><li class="lsi-social-youtube"><a class="tooltip" rel="nofollow" title="YouTube" aria-label="YouTube" href="https://www.youtube.com/user/kumarat9pm/" target="_blank"><i class="lsicon lsicon-youtube"></i></a></li><li class="lsi-social-rss"><a class="tooltip" rel="nofollow" title="RSS" aria-label="RSS" href="https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut" target="_blank"><i class="lsicon lsicon-rss"></i></a></li></ul></div> <!-- end .et_pb_widget --><div id="cb_email_subscribes-2" class="et_pb_widget widget_cb_email_subscribes"><h4 class="widgettitle">Email Subscribe</h4><div class="sidebar-email-subscribe-area">									
								<form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
									<p>
										<input class="email-subscribe" placeholder="Enter your email address:" type="email" name="email"/>
										<input type="hidden" value="TheLinuxJuggernaut" name="uri"/><input type="hidden" name="loc" value="en_US"/><input class="email-subscribe-submit" type="submit" value="Subscribe" />
									</p>
								</form>
								<p class="sidebar-email-sub-total">
									<a href="http://feeds.feedburner.com/TheLinuxJuggernaut"><img src="https://feeds.feedburner.com/~fc/TheLinuxJuggernaut?bg=99CCFF&amp;fg=444444&amp;anim=1" height="26" width="88" style="border:0" alt="" /></a>
								</p>
							</div></div> <!-- end .et_pb_widget --><div id="custom_html-3" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Take this course</h4><div class="textwidget custom-html-widget"><a href="https://shareasale.com/r.cfm?b=1041299&u=1627062&m=59485&urllink=&afftrack=">Essentials of OpenStack Administration (LFS252)</a></div></div> <!-- end .et_pb_widget --><div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://www.linuxnix.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">ABOUT ME..!</h4>			<div class="textwidget"><p><a href="/wp-content/uploads/2010/05/My-photo.jpg"><img class="alignnone size-full wp-image-2382" src="/wp-content/uploads/2010/05/My-photo.jpg" alt="My photo"></a><br />
My name is Surendra Kumar Anne. I hail from Vijayawada which is cultural capital of south Indian state of Andhra Pradesh. I am a Linux evangelist who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. At present I work at Bank of America as Sr. Analyst Systems and Administration. You can contact me at surendra (@) linuxnix dot com.</p>
</div>
		</div> <!-- end .et_pb_widget --><div id="insticator-embed-4" class="et_pb_widget insticator-embed-class"></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->


	</div> <!-- .container -->

</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_2">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<!--<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>-->
<!-- OnScroll tag: linuxnix - 479839 - 728x90(SF) -->
<script src="//tags.us.onscroll.com/abb02468-6e24-445f-8578-cb3cee3d87ca/tag.min.js" async defer></script>
				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="https://www.linuxnix.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="https://www.linuxnix.com/testimonials/">Testimonials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6050"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="https://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="https://www.linuxnix.com/contribute/">Contribute</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="https://www.linuxnix.com/editorial-board/">Editorial team</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="https://www.linuxnix.com/support-us/">Support us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '1233092', 'h2f1i6t6q7', 'load');
</script>

	<script>
		var advanced_ads_ga_UID = false;
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();		
		</script><img id = "ba_banner" src = "https://www.linuxnix.com/wp-content/plugins/blockalyzer-adblock-counter/img/ads/banner.gif" alt = "banner" width = "1" height = "1" /><script type="text/javascript">//<![CDATA[
                jQuery(document).ready(function($) {
                    setTimeout(function(){ // timeout to run after loading the advertisement.js
                        // count for missing js file
                        var nonce = '104138a0db';
                        
                        ba_blocked=false;
                        if ($.adblockJsFile === undefined){
                            ba_blocked=true;
                        }

                        var banner = document.getElementById("ba_banner");

                        if (banner == null || banner.offsetHeight == 0){
                            ba_blocked=true;
                        }

                        if(ba_blocked==true){
                            BaSetCookie('BaAdBlock', 'enabled', 30);
                        }else{
                            BaSetCookie('BaAdBlock', 'disabled', 30);
                        }
                        var data = {
                    action: 'standard_count',
                    blocked: ba_blocked
                };
                data.ba_count_jsFile = false;
                if ($.adblockJsFile === undefined){
                    data.ba_count_jsFile = true;
                }

                data.ba_count_banner = false;
                if (banner == null || banner.offsetHeight == 0){
                    data.ba_count_banner = true;
                }

                $.post(BaAjax.ajaxurl, data, function(response) {
                                        if ( !BaGetCookie('BaUniqueVisitor') || BaGetCookie('BaUniqueVisitor') != nonce ) {
                        BaSetCookie('BaUniqueVisitor', nonce, 30);
                    }
            });                    },100);
                });
            //]]></script>
<script type='text/javascript'>
	//<![CDATA[
    jQuery(document).ready(function($) { 
    	$('html').MagicLiquidizerTable({ whichelement: 'table', breakpoint: '780', headerSelector: 'thead td, thead th, tr th', bodyRowSelector: 'tbody tr, tr', table: '1' })
    })
	//]]>
</script> 	
<link rel='stylesheet' id='lsi-style-css'  href='https://www.linuxnix.com/wp-content/plugins/lightweight-social-icons/css/style-min.css?ver=1.0.1' type='text/css' media='all' />
<style id='lsi-style-inline-css' type='text/css'>
.icon-set-lsi_widget-2 a,
			.icon-set-lsi_widget-2 a:visited,
			.icon-set-lsi_widget-2 a:focus {
				border-radius: 25px;
				background: #b11b3d !important;
				color: #FFFFFF !important;
				font-size: 20px !important;
			}

			.icon-set-lsi_widget-2 a:hover {
				background: #777777 !important;
				color: #FFFFFF !important;
			}
</style>
<link rel='stylesheet' id='rainmaker_form_style-css'  href='https://www.linuxnix.com/wp-content/plugins/icegram-rainmaker/classes/../assets/css/form.css?ver=0.33' type='text/css' media='all' />

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"linuxnix"};
/* ]]> */
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"7876 https:\/\/www.linuxnix.com\/?p=7876","disqusShortname":"linuxnix","disqusTitle":"How does \/tmp directory get emptied automatically over time ?","disqusUrl":"https:\/\/www.linuxnix.com\/how-does-tmp-directory-get-emptied-automatically-over-time\/","postId":"7876"};
/* ]]> */
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_page_notices = {"es_email_notice":"Please enter email address","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Kindly check your mailbox and confirm your subscription. If you don't see the email within a few minutes, check the spam\/junk folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_ajax_url":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>






<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","rating_nonce":"ea27fdee8a","timeline_nonce":"189c091855","blog_feed_nonce":"5b61c2586d","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address."};
/* ]]> */
</script>






<script type='text/javascript'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"8d89d9732d","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","is_divi_theme_used":"","widget_search_selector":".widget_search"};
/* ]]> */
</script>



<script type='text/javascript'>
/* <![CDATA[ */
var rm_pre_data = {"ajax_url":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","rm_nonce_field":"f2994200c8"};
/* ]]> */
</script>

<script type="text/javascript" defer src="https://www.linuxnix.com/wp-content/cache/autoptimize/js/autoptimize_616539f3bc7414a429e7234557824fb8.js"></script></body>
</html>
