<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" />
<script data-cfasync='false' data-pagespeed-no-defer>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</script><script data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var z=[],i="/porpoiseant/army.gif";function t(e,i,t,d,_,o,n){if(__ez.dot.isDefined(e,e.getSlotElementId)){var a=parseInt(e.getTargeting("ap")[0]),r=function(e){var i=0;try{var t=e.getTargetingMap(),d=e.getSlotElementId();if(-1===d.indexOf("div-gpt-ad"))return i;if(void 0!==t)for(var _ in t)if(-1!==_.indexOf("iid")&&void 0!==t[_][0]){i=t[_][0];break}}catch(e){}return i}(e),s=e.getSlotElementId(),p=parseInt(e.getTargeting("compid")[0]),g=0,v=0;if("object"==typeof _ezim_d){var m=e.getAdUnitPath().split("/").pop();void 0!==_ezim_d[m]&&(void 0!==_ezim_d[m].creative_id&&(v=_ezim_d[m].creative_id),void 0!==_ezim_d[m].line_item_id&&(g=_ezim_d[m].line_item_id))}__ez.dot.isDefined(r,s)&&__ez.dot.isValid(i)&&z.push({type:"impression",impression_id:r,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:d,ad_position:a,ad_size:"",bid_floor_filled:_,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:g,creative_id:v,data:__ez.dot.dataToStr(i)})}}function d(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(z)&&0<z.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(z));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}z=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),d()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var d=t[0],_=t[2];z.push({type:"impression",impression_id:_,domain_id:__ez.dot.getDID(),unit:d,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:d}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(i,e){this.name=i,this.val=e};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(i,e){this.AddImpPixel(i,e,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(i,e){this.AddPVPixel(i,e),this.FirePixels()},AddImpPixel:function(i,e,t,n,o,a,r){if(this.isDefined(i,i.getSlotElementId)){var d=parseInt(i.getTargeting("ap")[0]),s=i.getSizes()[0],p=s.l.toString()+"x"+s.j.toString(),l="0",h="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(l=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(h=_ezaq.country);var f=this.getSlotIID(i),c=i.getSlotElementId();this.isDefined(f,c)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:f,domain_id:l,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:d,ad_size:p,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:r,country_code:h,data:e}))}},AddImpPixelById:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=i.split("/");if(this.isDefined(i)&&3===n.length&&this.validateData(e)){var o=n[0],a=n[2];e=this.convertDataToStr(e),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:e})}},AddPVPixel:function(i,e){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),this.isDefined(i)&&this.validateData(e)&&(e=this.convertDataToStr(e),this.pixels.push({type:"pageview",pageview_id:i,domain_id:t,t_epoch:this.tEpoch,data:e}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(this.isDefined(this.pixels)&&this.pixels.length>0&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(i,e){return new EzoicPixelData(i,e)},convertDataToStr:function(i){if(void 0===i)return[];try{for(var e in i)i[e].val=i[e].val+""}catch(i){}return i},getSlotIID:function(i){var e=0;try{var t=i.getTargetingMap();if(-1===i.getSlotElementId().indexOf("div-gpt-ad"))return e;if(void 0!==t)for(var n in t)if(-1!==n.indexOf("iid")&&void 0!==t[n][0]){e=t[n][0];break}}catch(i){}return e},isDefined:function(){for(var i=0;i<arguments.length;i++)if(void 0===arguments[i]||null===arguments[i])return console.error("Argument not defined. ",arguments),!1;return!0},validateData:function(i){for(var e=0;e<i.length;e++)if(i[e]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",i[e]),!1;return!0}};</script>
	
			
	
	<link rel="pingback" href="https://www.linuxnix.com/xmlrpc.php" />
    <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" />
<style>
 .ABT_float_ads_main_Wrap { width: 100%; max-width: 550px; max-height: 400px; position: fixed; z-index: 98765; background: rgb(59, 89, 152); left: 50%; top: 50%; transform: translate(-50%, -100%); box-sizing: border-box; box-shadow: 0 0 3px rgba(0, 0, 0, 0.2); border-radius: 10px; text-align: center; box-shadow: 0px 0px 3px 1px black; display: none; } .ABT_float_ads_close { margin: 0 auto; text-align: center; padding: 30px 20px 30px; position: absolute; top: -45px; right: -30px; z-index: 9999999; } .ABT_float_ads_close #ABT_close_button { font-size: 25px; color: #fff; display: inline-block; box-shadow: 0 0 3px rgba(0, 0, 0, 1); background: rgb(59, 89, 152); padding: 5px; border-radius: 5px; } #ABT_close_button { cursor: pointer; } #ABT_credits { font-size: 25px; color: #fff; position: absolute; bottom: 2px; right: 5px; display: inline-block; text-shadow: 0 0 3px rgba(0, 0, 0, 0.2); text-decoration: none!important; } .ABT_formWrap { background: rgb(250, 155, 57); padding: 10px; margin: 0px; width: 100%; min-width: 350px; overflow: hidden; box-sizing: border-box; border-radius: 10px; } .ABT_Heading, .ABT_Heading2 { color: #fff; font-size: 28px; font-weight: bold; text-shadow: 0px 0px 3px black; font-family: 'oswald', sans-serif; text-align: center; display: block; padding: 5px 0px; margin: 10px 0px 0px 0px; } .ABT_Heading2 { color: #fff; font-size: 18px; margin-bottom: 20px; font-style: italic; font-weight: 400; margin-top: 5px; } .ABT_Heading2 .fa-rss { color: rgb(250, 155, 57); } .ABT_Heading .fa-heart { color: rgb(227, 27, 35); } .ABT_float_ads_main_Wrap .fa-long-arrow-down { font-size: 40px; z-index: 98567; position: absolute; display: inline-block; padding: 10px; top: 80px; left: 45%; color: white; text-shadow: 0px 0px 5px black; } .ABT_formWrap .ABT_input_group { width: 100%; box-sizing: border-box; position: relative; margin: 0 auto; margin-top: 20px; border: 1px solid rgb(59, 89, 152); border-radius: 4px; } .ABT_input_group:before { color: #fff; content: "\f003"; font-family: FontAwesome; position: absolute; text-align: center; padding: 10px 12px; width: 50px; height: 100%; box-sizing: border-box; background: rgb(59, 89, 152); border: 1px solid rgb(59, 89, 152); text-shadow: 0px 0px 3px black; } .ABT_formWrap .ABT_Email { box-sizing: border-box; width: 100%; padding: 10px 0px 10px 60px; height: 100%; margin: 0px; border: none; border-radius: 4px; border: 1px solid rgb(59, 89, 152); } .ABT_formWrap .button { width: 100%; display: block; padding: 10px; box-sizing: border-box; position: relative; margin: 10px auto; margin-bottom: 20px; border-radius: 4px; background: rgb(59, 89, 152); font-size: 18px; border: none!important; cursor: pointer; text-shadow: 0px 0px 3px black; color: #fff; } .ABT_formWrap, .ABT_innerForm, .ABT_Widget_Container { width: 100%; } .pulse { -webkit-animation: pulse .8s linear infinite; -moz-animation: pulse .8s linear infinite; -ms-animation: pulse .8s linear infinite; animation: pulse .8s linear infinite } @keyframes pulse { 0% { -webkit-transform: scale(1); -moz-transform: scale(1); -o-transform: scale(1); -ms-transform: scale(1); transform: scale(1) } 50% { -webkit-transform: scale(0.8); -moz-transform: scale(0.8); -o-transform: scale(0.8); -ms-transform: scale(0.8); transform: scale(0.8) } 100% { -webkit-transform: scale(1); -moz-transform: scale(1); -o-transform: scale(1); -ms-transform: scale(1); transform: scale(1) } } @-moz-keyframes pulse { 0% { -moz-transform: scale(1); transform: scale(1) } 50% { -moz-transform: scale(0.8); transform: scale(0.8) } 100% { -moz-transform: scale(1); transform: scale(1) } } @-webkit-keyframes &quot; pulse&quot; { 0% { -webkit-transform: scale(1); transform: scale(1) } 50% { -webkit-transform: scale(0.8); transform: scale(0.8) } 100% { -webkit-transform: scale(1); transform: scale(1) } } @-ms-keyframes &quot; pulse&quot; { 0% { -ms-transform: scale(1); transform: scale(1) } 50% { -ms-transform: scale(0.8); transform: scale(0.8) } 100% { -ms-transform: scale(1); transform: scale(1) }
    </style>
   

<script type="text/javascript">
    window.onload = function() {
        var ABT_closeButton = document.getElementById('ABT_close_button');
        var ABT_float_ads_main_Wrap = document.getElementById("ABT_float_ads_main_Wrap");
        myVar = setTimeout(function() {
            ABT_float_ads_main_Wrap.style.display = 'block'
        }, 3000);
        ABT_closeButton.onclick = function() {
            document.getElementById("ABT_float_ads_main_Wrap").style.display = 'none';
        }
    }
</script>

		<!--[if lt IE 9]>
	<script src="https://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
	<!-- Header Tag Code -->
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/a30dc085-55ae-4bb0-9e46-774d36a290eb.js');/*]]>*/</script>
<!-- End Header Tag Code -->
	
	
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>

	<title>3 ways to automate file transfers using ftp - The Linux Juggernaut</title>
<script type="text/javascript">//<![CDATA[
            function BaGetCookie(c_name) { var i,x,y,ARRcookies=document.cookie.split(";"); for (i=0;i<ARRcookies.length;i++) { x=ARRcookies[i].substr(0,ARRcookies[i].indexOf("=")); y=ARRcookies[i].substr(ARRcookies[i].indexOf("=")+1); x=x.replace(/^\s+|\s+$/g,""); if (x==c_name) { return unescape(y); } } }
            function BaSetCookie( name, value, exdays, path, domain, secure) { var exdate=new Date(); exdate.setDate(exdate.getDate() + exdays); document.cookie = name + "=" + escape(value) + ((exdate == null) ? "" : "; expires=" + exdate.toUTCString()) + ((path == null) ? "; path=/" : "; path=" + path) + ((domain == null) ? "" : "; domain=" + domain) +((secure == null) ? "" : "; secure");}
            //]]></script>
<!-- This site is optimized with the Yoast SEO plugin v11.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="3 ways to automate file transfers using ftp - The Linux Juggernaut" />
<meta property="og:description" content="Introduction In some of our earlier articles we&#8217;ve explained the setting up of chrooted sftp and chrooted ssh accounts along with the setup of an ftp server using vsftpd. In today&#8217;s automation driven enterprise infrastructure environments we may often find ourselves in situations where we need to automate the transfer of files using the ftp/sftp &hellip;" />
<meta property="og:url" content="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/" />
<meta property="og:site_name" content="The Linux Juggernaut" />
<meta property="article:tag" content="ftp" />
<meta property="article:section" content="Basics" />
<meta property="article:published_time" content="2019-07-03T04:27:38+00:00" />
<meta property="og:image" content="https://www.linuxnix.com/wp-content/uploads/2018/08/3-ways-to-automate-file-transfers-using-ftp.jpg" />
<meta property="og:image:secure_url" content="https://www.linuxnix.com/wp-content/uploads/2018/08/3-ways-to-automate-file-transfers-using-ftp.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Introduction In some of our earlier articles we&#8217;ve explained the setting up of chrooted sftp and chrooted ssh accounts along with the setup of an ftp server using vsftpd. In today&#8217;s automation driven enterprise infrastructure environments we may often find ourselves in situations where we need to automate the transfer of files using the ftp/sftp [&hellip;]" />
<meta name="twitter:title" content="3 ways to automate file transfers using ftp - The Linux Juggernaut" />
<meta name="twitter:image" content="https://www.linuxnix.com/wp-content/uploads/2018/08/3-ways-to-automate-file-transfers-using-ftp.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.linuxnix.com/#website","url":"https://www.linuxnix.com/","name":"The Linux Juggernaut","publisher":{"@id":"https://www.linuxnix.com/#person"},"potentialAction":{"@type":"SearchAction","target":"https://www.linuxnix.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#webpage","url":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/","inLanguage":"en-US","name":"3 ways to automate file transfers using ftp - The Linux Juggernaut","isPartOf":{"@id":"https://www.linuxnix.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#primaryimage","url":"https://www.linuxnix.com/wp-content/uploads/2018/08/3-ways-to-automate-file-transfers-using-ftp.jpg","width":586,"height":282},"primaryImageOfPage":{"@id":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#primaryimage"},"datePublished":"2019-07-03T04:27:38+00:00","dateModified":"2019-07-03T04:27:38+00:00"},{"@type":"Article","@id":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#article","isPartOf":{"@id":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#webpage"},"author":{"@id":"https://www.linuxnix.com/author/sohil_suri/#author"},"headline":"3 ways to automate file transfers using ftp","datePublished":"2019-07-03T04:27:38+00:00","dateModified":"2019-07-03T04:27:38+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#webpage"},"publisher":{"@id":"https://www.linuxnix.com/#person"},"keywords":"ftp","articleSection":"Basics"},{"@type":["Person"],"@id":"https://www.linuxnix.com/author/sohil_suri/#author","name":"Sahil Suri","image":{"@type":"ImageObject","@id":"https://www.linuxnix.com/#authorlogo","url":"https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=96&d=mm&r=g","caption":"Sahil Suri"},"description":"He started his career in IT in 2011 as a system administrator. He has since worked with HP-UX, Solaris and Linux operating systems along with exposure to high availability and virtualization solutions.\r\nHe has a keen interest in shell, Python and Perl scripting and is learning the ropes on AWS cloud, DevOps tools, and methodologies. He enjoys sharing the knowledge he's gained over the years with the rest of the community.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Feed" href="https://www.linuxnix.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Comments Feed" href="https://www.linuxnix.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; 3 ways to automate file transfers using ftp Comments Feed" href="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.7.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.7.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-752078-3';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-752078-3', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><!--noptimize--><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><!--/noptimize--><meta content="Extra v." name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='cupStyle-css'  href='https://www.linuxnix.com/wp-content/plugins/contact-us-page/css/cupStyle.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='email-subscribers-advanced-form-css'  href='https://www.linuxnix.com/wp-content/plugins/email-subscribers-advanced-form/assets/css/styles.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='email-subscribers-css'  href='https://www.linuxnix.com/wp-content/plugins/email-subscribers/public/css/email-subscribers-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='ts_fab_css-css'  href='https://www.linuxnix.com/wp-content/plugins/fancier-author-box/css/ts-fab.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='magic-liquidizer-table-style-css'  href='https://www.linuxnix.com/wp-content/plugins/magic-liquidizer-responsive-table/idcss/ml-responsive-table.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mailerlite_forms.css-css'  href='https://www.linuxnix.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.linuxnix.com/wp-includes/css/dashicons.min.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css'  href='https://www.linuxnix.com/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.2.14' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-sub-style-css'  href='https://www.linuxnix.com/wp-content/plugins/wp-feedburner-email-subscriber/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='extra-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://www.linuxnix.com/wp-content/themes/Extra/style.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.linuxnix.com/wp-content/themes/Extra/includes/builder/styles/magnific_popup.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://www.linuxnix.com/?sccss=1&#038;ver=4.9.10' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var BaAjax = {"ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxnix.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>

<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/www.linuxnix.com","hash_tracking":"false"};
/* ]]> */
</script>


<script type='text/javascript'>
/* <![CDATA[ */
var es_data = {"messages":{"es_empty_email_notice":"Please enter email address","es_rate_limit_notice":"You need to wait for sometime before subscribing again","es_single_optin_success_message":"Successfully Subscribed.","es_double_optin_success_message":"Your subscription was successful! Kindly check your mailbox and confirm your subscription. If you don't see the email within a few minutes, check the spam\/junk folder.","es_email_exists_notice":"Email Address already exists!","es_unexpected_error_notice":"Oops.. Unexpected error occurred.","es_invalid_email_notice":"Invalid email address","es_try_later_notice":"Please try after some time"},"es_ajax_url":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>



<link rel='https://api.w.org/' href='https://www.linuxnix.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxnix.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxnix.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.10" />
<link rel='shortlink' href='https://www.linuxnix.com/?p=7719' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxnix.com%2F3-ways-to-automate-file-transfers-using-ftp%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxnix.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxnix.com%2F3-ways-to-automate-file-transfers-using-ftp%2F&#038;format=xml" />
    <!-- MailerLite Universal -->
    <script>
        (function (m, a, i, l, e, r) {
            m['MailerLiteObject'] = e;

            function f() {
                var c = {a: arguments, q: []};
                var r = this.push(c);
                return "number" != typeof r ? r : f.bind(c.q);
            }

            f.q = f.q || [];
            m[e] = m[e] || f.bind(f.q);
            m[e].q = m[e].q || f.q;
            r = a.createElement(i);
            var _ = a.getElementsByTagName(i)[0];
            r.async = 1;
            r.src = l + '?' + (~~(new Date().getTime() / 10000000));
            _.parentNode.insertBefore(r, _);
        })(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

        var ml_account = ml('accounts', '1233092', 'h2f1i6t6q7', 'load');
    </script>
    <!-- End MailerLite Universal -->
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<style type="text/css" id="extra-dynamic-styles-primary_nav_text_color-color">
#et-menu > li a,
#et-menu > li.menu-item-has-children > a:after,
#et-menu > li.mega-menu-featured > a:after,
#et-extra-mobile-menu > li.mega-menu-featured > a:after {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-color">
#et-menu > li > a:hover,
#et-menu > li.menu-item-has-children > a:hover:after,
#et-menu > li.mega-menu-featured > a:hover:after,
#et-navigation > ul#et-menu > li.current-menu-item > a,
#et-navigation > ul#et-menu > li.current_page_item > a,
#et-extra-mobile-menu > li.mega-menu-featured > a:hover:after,
#et-extra-mobile-menu > li.current-menu-item > a,
#et-extra-mobile-menu > li.current_page_item > a,
#et-extra-mobile-menu > li > a:hover {
	color: #1e73be;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-background-color">
#et-navigation > ul > li > a:before {
	background-color: #1e73be;
}

</style>

<style type="text/css" id="extra-dynamic-styles-primary_nav_background_color-background-color">
#main-header {
	background-color: #ffffff;
}

</style>

<style type="text/css" id="extra-dynamic-styles-button_text_color-color">
#page-container .button,
#page-container button,
#page-container button[type="submit"],
#page-container input[type="submit"],
#page-container input[type="reset"],
#page-container input[type="button"],
.read-more-button,
.comment-body .comment_area .comment-content .reply-container .comment-reply-link,
.widget_tag_cloud a,
.widget_tag_cloud a:visited,
.post-nav .nav-links .button,
a.read-more-button,
a.read-more-button:visited,
#footer .widget_tag_cloud a,
#footer .widget_tag_cloud a:visited,
#footer a.read-more-button,
#footer a.read-more-button:visited,
#footer .button,
#footer button,
#footer button[type="submit"],
#footer input[type="submit"],
#footer input[type="reset"],
#footer input[type="button"] {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-button_hover_text_color-color">
#page-container .button:hover,
#page-container button:hover,
#page-container button[type="submit"]:hover,
#page-container input[type="submit"]:hover,
#page-container input[type="reset"]:hover,
#page-container input[type="button"]:hover,
.read-more-button:hover,
.comment-body .comment_area .comment-content .reply-container .comment-reply-link:hover,
.widget_tag_cloud a:hover,
.widget_tag_cloud a:visited:hover,
.post-nav .nav-links .button:hover,
a.read-more-button:hover,
a.read-more-button:visited:hover,
#footer .widget_tag_cloud a:hover,
#footer .widget_tag_cloud a:visited:hover,
#footer a.read-more-button:hover,
#footer a.read-more-button:visited:hover,
#footer .button:hover,
#footer button:hover,
#footer button[type="submit"]:hover,
#footer input[type="submit"]:hover,
#footer input[type="reset"]:hover,
#footer input[type="button"]:hover {
	color: rgba(0,0,0,0.6);
}

</style>

<style type="text/css" id="extra-dynamic-styles-extra_nav_height_value">

			@media only screen and (min-width: 768px) {
				#main-header .logo {
					height: 48.45px;
					margin: 23.275px 0;
				}
				.header.left-right #et-navigation > ul > li > a {
					padding-bottom: 39.5px;
				}
			}
			@media only screen and (min-width: 768px) {
				.et-fixed-header #main-header .logo {
					height: 48.45px;
					margin: 23.275px 0;
				}
				.et-fixed-header .header.left-right #et-navigation > ul > li > a {
					padding-bottom: 39.5px;
				}
			}</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-752078-3', 'auto');
  ga('send', 'pageview');

</script><link rel="icon" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-270x270.png" />
<style type="text/css" id="et-custom-css">
@media screen and (max-width: 900px)
{
#main-header .etad {
display: none;
}
}

#top-header {
    background-color: #B11B3D;
}

.et_pb_extra_module .main-post article .header img, .et_extra_other_module .main-post article .header img {
    display: block;
    width: auto;
    /* max-width: 100%; */
    object-fit: cover;
    height: 158px;
    width: 100%;
}
pre {
    border: 1px solid #DDD;
    overflow: auto;
    background: #EEE;
    font-size: .857em;
    line-height: 1.5em;
    margin-bottom: 1.833em;
    padding: .667em .917em;
    clear: both;
    color: #000;
}
.posts-blog-feed-module.masonry .post-content {
padding: 20px !important;
}

.author-box {
  display: none;
}

.post-thumbnail img {
  width: auto;
  margin: 0 auto;
}

#disqus_thread {
    background: #fff;
    padding: 20px;
    border-radius: 3px;
    box-shadow: 0 1px 3px rgba(0,0,0,0.1);
    box-sizing: border-box;
}
</style>
<script data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-135000609-4";</script>
<script data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-135000609-4']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'linuxnix.com']);
_gaq.push(['f._setDomainName', 'linuxnix.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod8-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','linuxnix.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script type='text/javascript'>
var soc_app_id = '0';
var did = 113700;
var ezdomain = 'linuxnix.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":113700,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"0b0545f7-8356-4fc6-631f-ec480151ef37","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":808,"serverid":"54.83.141.167:22378","state":"VA","t_epoch":1563329745,"template_id":126,"time_on_site_visit":0,"url":"https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/","user_id":0,"word_count":1274,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=186-0&v=8" async></script>
<script data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_113700=" + new Date().getTime() + "|0b0545f7-8356-4fc6-631f-ec480151ef37; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head>
<body data-ocssl='1' class="post-template-default single single-post postid-7719 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right unknown et_includes_sidebar">

	<div id="page-container">
				<!-- Header -->
		<header class="header left-right">
						<!-- #top-header -->
			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="et-trending">
						
							<!-- ET Trending -->
							<div id="et-trending">

								<!-- ET Trending Button -->
								<a id="et-trending-button" href="#" title="">
									<span></span>
									<span></span>
									<span></span>
								</a>

								<!-- ET Trending Label -->
								<h4 id="et-trending-label">
									TRENDING:								</h4>

								<!-- ET Trending Post Loop -->
								<div id='et-trending-container'>
																											<div id="et-trending-post-1297" class="et-trending-post et-trending-latest">
											<a href="https://www.linuxnix.com/sticky-bit-set-linux/">What is a sticky Bit and how to set it in Linux?</a>
										</div>
																			<div id="et-trending-post-1264" class="et-trending-post">
											<a href="https://www.linuxnix.com/suid-set-suid-linuxunix/">What is SUID and how to set SUID in Linux/Unix?</a>
										</div>
																			<div id="et-trending-post-1093" class="et-trending-post">
											<a href="https://www.linuxnix.com/linux-top-command-explained-2/">Linux TOP command explained</a>
										</div>
																									</div>
							</div>
							<ul id="et-secondary-menu" class="nav"><li id="menu-item-5405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="https://www.linuxnix.com/contact-us/">Contact Us</a></li>
<li id="menu-item-3350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="https://www.linuxnix.com/testimonials/">Testimonials</a></li>
<li id="menu-item-6050" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6050"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
<li id="menu-item-3347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="https://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li>
<li id="menu-item-3349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="https://www.linuxnix.com/contribute/">Contribute</a></li>
<li id="menu-item-5341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="https://www.linuxnix.com/editorial-board/">Editorial team</a></li>
<li id="menu-item-5342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="https://www.linuxnix.com/support-us/">Support us</a></li>
<li id="menu-item-5382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
</ul>
												</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-extra-social-icons -->
						<ul class="et-extra-social-icons" style="">
																																														<li class="et-extra-social-icon facebook">
									<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
								</li>
																																															<li class="et-extra-social-icon twitter">
									<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
								</li>
																																																																																																																																																																																																										<li class="et-extra-social-icon instagram">
									<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
								</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																								</ul>
						
						<!-- .et-top-search -->
												<div class="et-top-search" style="">
							<form role="search" class="et-search-form" method="get" action="https://www.linuxnix.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form>						</div>
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			
        

        
				<div id="main-header" data-fixed-height="95">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://www.linuxnix.com/" data-fixed-height="51">
							<img src="https://www.linuxnix.com/wp-content/uploads/2016/08/linux.png" alt="The Linux Juggernaut" id="logo" />
						</a>
<!-- Insticator API Fire Widget Ads Code -->

<script data-cfasync='false' type="text/javascript">
/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-3");/*]]>*/
</script>
<!-- End Insticator API Fire Widget Ads Code -->
						
			
					</div>
					<container>
						<div class="subHeader">
						<div class="container">
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5531"><a href="https://www.linuxnix.com/category/administration/">Administration</a>
<ul class="sub-menu">
	<li id="menu-item-5534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5534"><a href="https://www.linuxnix.com/category/administration/monitoring/">Monitoring</a></li>
	<li id="menu-item-5533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5533"><a href="https://www.linuxnix.com/category/administration/security/">Security</a></li>
	<li id="menu-item-5532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5532"><a href="https://www.linuxnix.com/category/administration/servers/">Servers</a></li>
</ul>
</li>
<li id="menu-item-5536" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5536"><a href="https://www.linuxnix.com/category/basics/">Basics</a></li>
<li id="menu-item-5544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5544"><a href="/category/cloudvirtulization/">Cloud</a>
<ul class="sub-menu">
	<li id="menu-item-5545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5545"><a href="/category/cloudvirtulization/aws/">AWS</a></li>
	<li id="menu-item-5540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5540"><a href="https://www.linuxnix.com/category/cloudvirtulization/kvm/">KVM</a></li>
</ul>
</li>
<li id="menu-item-5546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5546"><a href="/category/Devops/">Devops</a>
<ul class="sub-menu">
	<li id="menu-item-5547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5547"><a href="/category/Devops/Ansible/">Ansible</a></li>
	<li id="menu-item-5548" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5548"><a href="/category/Devops/Docker/">Docker</a></li>
	<li id="menu-item-5549" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5549"><a href="/category/Devops/Packer/">Packer</a></li>
	<li id="menu-item-5550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5550"><a href="/category/Devops/Puppet/">Puppet</a></li>
	<li id="menu-item-5551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5551"><a href="/category/Devops/Vagrant/">Vagrant</a></li>
</ul>
</li>
<li id="menu-item-5537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5537"><a href="https://www.linuxnix.com/category/interviews-2/">Interviews</a></li>
<li id="menu-item-5535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5535"><a href="https://www.linuxnix.com/category/news/">News</a></li>
<li id="menu-item-5552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5552"><a href="/category/offers/">Offers</a></li>
<li id="menu-item-5553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5553"><a href="/category/Programming/">Programming</a>
<ul class="sub-menu">
	<li id="menu-item-5554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5554"><a href="/category/Programming/awk/">Awk</a></li>
	<li id="menu-item-5538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5538"><a href="https://www.linuxnix.com/category/programming/bash/">Bash</a></li>
	<li id="menu-item-5555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5555"><a href="/category/Programming/Batch/">Batch</a></li>
	<li id="menu-item-5556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5556"><a href="/category/Programming/git/">Git</a></li>
	<li id="menu-item-5557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5557"><a href="/category/Programming/Perl/">Perl</a></li>
	<li id="menu-item-5558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5558"><a href="/category/Programming/PowerShell/">PowerShell</a></li>
	<li id="menu-item-5539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5539"><a href="https://www.linuxnix.com/category/programming/python/">python</a></li>
	<li id="menu-item-5559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5559"><a href="/category/Programming/Ruby/">Ruby</a></li>
	<li id="menu-item-5560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5560"><a href="/category/Programming/Sed/">Sed</a></li>
	<li id="menu-item-5561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5561"><a href="/category/Programming/SQL/">SQL</a></li>
</ul>
</li>
<li id="menu-item-5562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5562"><a href="/category/Reviews/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-5563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5563"><a href="/category/Reviews/Books/">Books</a></li>
	<li id="menu-item-5564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5564"><a href="/category/Reviews/Linuxunix/">Linux/Unix</a></li>
	<li id="menu-item-5565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5565"><a href="/category/reviews/open-source/">Open source</a></li>
</ul>
</li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
						</div>
						</div>
				</div><!-- /#main-header -->
			<!-- /#main-header-wrapper -->

		</header>
				<div id="main-content">
	<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-7719" class="module single-post-module post-7719 post type-post status-publish format-standard hentry category-basics tag-ftp et-doesnt-have-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">3 ways to automate file transfers using ftp</h1>
								<div class="post-meta">
									<p>Posted by <a href="https://www.linuxnix.com/author/sohil_suri/" class="url fn" title="Posts by Sahil Suri" rel="author">Sahil Suri</a> | <span class="updated">Jul 3, 2019</span> | <a href="https://www.linuxnix.com/category/basics/" rel="tag">Basics</a> | <a class="comments-link" href="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
								</div>
							</div>
							
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p><img class="size-full wp-image-7720 aligncenter" src="https://www.linuxnix.com/wp-content/uploads/2018/08/3-ways-to-automate-file-transfers-using-ftp.jpg" alt="" width="586" height="282" /></p>
<h4>Introduction</h4>
<p>In some of our earlier articles we&#8217;ve explained the setting up of chrooted sftp and chrooted ssh accounts along with the setup of an ftp server using vsftpd. In today&#8217;s automation driven enterprise infrastructure environments we may often find ourselves in situations where we need to automate the transfer of files using the ftp/sftp protocol. Setting up passwordless tranfer of files using sftp is farily stragithforward.  Since sftp is based on the ssh protocol we can generate and use ssh keys to setup passwordless authentication to allow for automated file tranfers. In this article we will demonstrate three techniques using which you can automate the transfer of files using FTP protocol as well.</p>
<p><strong>Method 1: Using wget</strong><br />
The wget command provides options to connect to the ftp server and download a file while specifying the credentials on the command line. In the below example, we connect to the ftp server with IP address 172.31.18.17 using the user name sahil and password as L#giN@123 and download the file download.txt.</p>
<pre><strong>[root@sahilsuri0081 ~]# wget --user=sahil --password='L#giN@123' ftp://172.31.18.17/download.txt</strong>
<strong>--2018-07-27 17:39:40-- ftp://172.31.18.17/download.txt</strong>
<strong>=&gt; ‘download.txt’</strong>
<strong>Connecting to 172.31.18.17:21... connected.</strong>
<strong>Logging in as sahil ... Logged in!</strong>
<strong>==&gt; SYST ... done. ==&gt; PWD ... done.</strong>
<strong>==&gt; TYPE I ... done. ==&gt; CWD not needed.</strong>
<strong>==&gt; SIZE download.txt ... done.</strong>
<strong>==&gt; PASV ... done. ==&gt; RETR download.txt ... done.</strong>

<strong>[ &lt;=&gt; ] 0 --.-K/s in 0s</strong>

<strong>2018-07-27 17:39:40 (0.00 B/s) - ‘download.txt’ saved [0]</strong>

<strong>[root@sahilsuri0081 ~]# ls -l download.txt</strong>
<strong>-rw-r--r--. 1 root root 0 Jul 27 17:39 download.txt</strong>
<strong>[root@sahilsuri0081 ~]#</strong></pre>
<p>The shortcoming of using this method is that we have to specify the credentials in the command itself so it&#8217;s not very secure. The wget command only allows us to download files from the ftp server. It does not allow us to upload files.<br />
Although there is a utility named wput which works like wget but instead of downloading files it&#8217;s purpose is to upload files.</p>
<p><strong>Method 2: Using curl</strong><br />
The curl command provides us options to download as well as upload files in an automated manner. While using the curl command we specify the username/password by using the -u option followed by the username and password delimited by a colon. We use the -O option specify the FTP server URL. Given below is an example.</p>
<pre><strong>[root@linuxnix ~]# curl -u sahil:L#giN@123 -O ftp://172.31.18.17/download.txt</strong>
<strong>% Total % Received % Xferd Average Speed Time Time Time Current</strong>
<strong>Dload Upload Total Spent Left Speed</strong>
<strong>100 20 100 20 0 0 430 0 --:--:-- --:--:-- --:--:-- 444</strong>
<strong>[root@linuxnix ~]# ls -l download.txt</strong>
<strong>-rw-r--r--. 1 root root 20 Jul 28 10:30 download.txt</strong>
<strong>[root@linuxnix ~]#</strong></pre>
<p>Note: Curl will not download the file if the file is empty.</p>
<p>To upload a file using the curl command we use the -T option to specify the file name to be uploaded and we do not use the -O option to indicate the URL in this case. Given below is an example:</p>
<pre><strong>[root@linuxnix ~]# curl -u sahil:123 ftp://172.31.18.17/ -T file.txt</strong>
<strong>% Total % Received % Xferd Average Speed Time Time Time Current</strong>
<strong>Dload Upload Total Spent Left Speed</strong>
<strong>100 69 0 0 100 69 0 1503 --:--:-- --:--:-- --:--:-- 1533</strong></pre>
<p><strong>Method 3: Using here documents</strong><br />
In the third and final technique we&#8217;ll rely on here documents. A here document is a special-purpose code block. It uses a form of I/O redirection to feed a command list to an interactive program or a command, such as ftp, cat, or the ex text editor. A limit string delineates (frames) the command list. The special symbol &lt;&lt; precedes the limit string. This has the effect of redirecting the output of a command block into the stdin of the program or command.  It is similar to interactive-program &lt; command-file, where command-file contains To demonstrate the automation of the FTP file transfer process using here documents I&#8217;ve written a small script shown below</p>
<pre><strong>[root@linuxnix ~]# cat ftp.bash</strong>
<strong>ftp -in 172.31.18.17 &lt;&lt; EOF &gt; ~/ftp-session-log.txt 2&gt;&amp;1</strong>
<strong>user sahil L#giN@123</strong>
<strong>get download.txt</strong>
<strong>bye</strong>
<strong>EOF</strong>
<strong>[root@linuxnix ~]#</strong></pre>
<p>In the above script we&#8217;ve used the -i and -n options with the FTP command wherein -i prevents interactive login prompts and -n option prevents auto-login attempts. Therefore we can specify all the FTP commands that we intend to execute during our FTP session within the body of the here document. In the above script we are logging in to our FTP server as the user sahil by providing the user name and password and then we download a file named download.txt. After this we disconnect the session. The sessions logs are being sent to a file named ftp-session-log.txt. Let&#8217;s execute this script and then we can review the contents of this file.</p>
<pre><strong>[root@linuxnix ~]# bash -x ftp.bash</strong>
<strong>+ ftp -in 172.31.18.17</strong>
<strong>[root@linuxnix ~]# cat ftp-session-log.txt</strong>
<strong>WARNING! 1 bare linefeeds received in ASCII mode</strong>
<strong>File may not have transferred correctly.</strong></pre>
<h4>Conclusion</h4>
<p>In this article we demonstrated three different techniques to automate our FTP file transfers. From among the methods listed we would recommend using here documents as we can implement the setup in shell scripts and it would provide more flexibility.</p>
<div class="post-views post-7719 entry-meta">
			<span class="post-views-icon dashicons dashicons-chart-bar"></span>
			<span class="post-views-label">Post Views: </span>
			<span class="post-views-count">461</span>
			</div><div id="ts-fab-below" class="ts-fab-wrapper"><span class="screen-reader-text">The following two tabs change content below.</span><ul class="ts-fab-list"><li class="ts-fab-bio-link"><a href="#ts-fab-bio-below">Bio</a></li><li class="ts-fab-latest-posts-link"><a href="#ts-fab-latest-posts-below">Latest Posts</a></li></ul><div class="ts-fab-tabs">
	<div class="ts-fab-tab" id="ts-fab-bio-below">
		<div class="ts-fab-avatar"><img alt='' src='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /><div class="ts-fab-social-links"></div>
		</div>
		
		<div class="ts-fab-text">
			<div class="ts-fab-header"><h4>Sahil Suri</h4></div><!-- /.ts-fab-header -->
			<div class="ts-fab-content">He started his career in IT in 2011 as a system administrator. He has since worked with HP-UX, Solaris and Linux operating systems along with exposure to high availability and virtualization solutions.
He has a keen interest in shell, Python and Perl scripting and is learning the ropes on AWS cloud, DevOps tools, and methodologies. He enjoys sharing the knowledge he's gained over the years with the rest of the community.</div>
		</div>
	</div>
	<div class="ts-fab-tab" id="ts-fab-latest-posts-below">
		<div class="ts-fab-avatar"><img alt='' src='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9cbd2f914376ceab894e9400a9cadaa4?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /><div class="ts-fab-social-links"></div>
		</div>
		<div class="ts-fab-text">
			<div class="ts-fab-header">
				<h4>Latest posts by Sahil Suri <span class="latest-see-all">(<a href="https://www.linuxnix.com/author/sohil_suri/" rel="nofollow">see all</a>)</span></h4>
			</div>
			<ul class="ts-fab-latest">
				<li>
					<a href="https://www.linuxnix.com/using-cpulimit-to-limit-cpu-utilization-of-a-process-in-linux/">Using CPULimit to limit CPU utilization of a process in Linux</a><span> - July 11, 2019</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/5-different-ways-to-display-ip-addresses-in-centos-7/">5 Different ways to display IP addresses in Centos 7</a><span> - July 8, 2019</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">3 ways to automate file transfers using ftp</a><span> - July 3, 2019</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/journalctl-command-in-linux-explained/">Journalctl command in Linux explained</a><span> - July 1, 2019</span> 
				</li>
				<li>
					<a href="https://www.linuxnix.com/how-does-tmp-directory-get-emptied-automatically-over-time/">How does /tmp directory get emptied automatically over time ?</a><span> - January 22, 2019</span> 
				</li>
		</ul></div>
	</div>
		</div>
	</div>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;t=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Facebook" data-network-name="facebook" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/home?status=3%20ways%20to%20automate%20file%20transfers%20using%20ftp%20https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Twitter" data-network-name="twitter" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;t=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Google +" data-network-name="googleplus" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;t=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Tumblr" data-network-name="tumblr" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;description=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Pinterest" data-network-name="pinterest" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;title=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via LinkedIn" data-network-name="linkedin" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;title=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Buffer" data-network-name="buffer" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/&#038;title=3%20ways%20to%20automate%20file%20transfers%20using%20ftp" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Email" data-network-name="basic_email" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;3 ways to automate file transfers using ftp&quot; via Print" data-network-name="basic_print" data-share-title="3 ways to automate file transfers using ftp" data-share-url="https://www.linuxnix.com/3-ways-to-automate-file-transfers-using-ftp/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="7719" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #8bd623;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://www.linuxnix.com/journalctl-command-in-linux-explained/" rel="prev"><span class="button">Previous</span><span class="title">Journalctl command in Linux explained</span></a>								</div>
								<div class="nav-link nav-link-next">
									<a href="https://www.linuxnix.com/5-different-ways-to-display-ip-addresses-in-centos-7/" rel="next"><span class="button">Next</span><span class="title">5 Different ways to display IP addresses in Centos 7</span></a>								</div>
							</div>
						</nav>

												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/ls-command-examples-in-linux/" title="16 ls command examples in Linux/Unix" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/uploads/2016/02/ls.jpg" alt="16 ls command examples in Linux/Unix" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/ls-command-examples-in-linux/">16 ls command examples in Linux/Unix</a></h4>
									<p class="date"><span class="updated">April 20, 2016</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/introducing-systemd/" title="Introducing systemd" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Introducing systemd" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/introducing-systemd/">Introducing systemd</a></h4>
									<p class="date"><span class="updated">January 18, 2018</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/hashicorp-and-its-devops-toolset/" title="What is HashiCorp DevOps tools all about?" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="What is HashiCorp DevOps tools all about?" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/hashicorp-and-its-devops-toolset/">What is HashiCorp DevOps tools all about?</a></h4>
									<p class="date"><span class="updated">August 21, 2018</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.linuxnix.com/how-to-install-terraform-and-how-to-create-your-first-infrastructure-in-aws/" title="How to install Terraform and create your first infrastructure in AWS?" class="post-thumbnail">
				<img src="https://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="How to install Terraform and create your first infrastructure in AWS?" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.linuxnix.com/how-to-install-terraform-and-how-to-create-your-first-infrastructure-in-aws/">How to install Terraform and create your first infrastructure in AWS?</a></h4>
									<p class="date"><span class="updated">November 14, 2018</span></p>
								</div>
																							</div>
						</div>
										
				
<div id="disqus_thread"></div>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="lsi_widget-2" class="et_pb_widget widget_lsi_widget"><h4 class="widgettitle">Over 16,000 readers, Get fresh content from &#8220;The Linux juggernaut&#8221;</h4><ul class="lsi-social-icons icon-set-lsi_widget-2" style="text-align: center"><li class="lsi-social-facebook"><a class="tooltip" rel="nofollow" title="Facebook" aria-label="Facebook" href="https://www.facebook.com/Linux.Juggernaut" target="_blank"><i class="lsicon lsicon-facebook"></i></a></li><li class="lsi-social-twitter"><a class="tooltip" rel="nofollow" title="Twitter" aria-label="Twitter" href="https://twitter.com/linuxnix" target="_blank"><i class="lsicon lsicon-twitter"></i></a></li><li class="lsi-social-gplus"><a class="tooltip" rel="nofollow" title="Google+" aria-label="Google+" href="https://plus.google.com/+SurendraKumarAnne" target="_blank"><i class="lsicon lsicon-gplus"></i></a></li><li class="lsi-social-youtube"><a class="tooltip" rel="nofollow" title="YouTube" aria-label="YouTube" href="https://www.youtube.com/user/kumarat9pm/" target="_blank"><i class="lsicon lsicon-youtube"></i></a></li><li class="lsi-social-rss"><a class="tooltip" rel="nofollow" title="RSS" aria-label="RSS" href="https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut" target="_blank"><i class="lsicon lsicon-rss"></i></a></li></ul></div> <!-- end .et_pb_widget --><div id="cb_email_subscribes-2" class="et_pb_widget widget_cb_email_subscribes"><h4 class="widgettitle">Email Subscribe</h4><div class="sidebar-email-subscribe-area">									
								<form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true">
									<p>
										<input class="email-subscribe" placeholder="Enter your email address:" type="email" name="email"/>
										<input type="hidden" value="TheLinuxJuggernaut" name="uri"/><input type="hidden" name="loc" value="en_US"/><input class="email-subscribe-submit" type="submit" value="Subscribe" />
									</p>
								</form>
								<p class="sidebar-email-sub-total">
									<a href="http://feeds.feedburner.com/TheLinuxJuggernaut"><img src="https://feeds.feedburner.com/~fc/TheLinuxJuggernaut?bg=99CCFF&amp;fg=444444&amp;anim=1" height="26" width="88" style="border:0" alt="" /></a>
								</p>
							</div></div> <!-- end .et_pb_widget --><div id="custom_html-3" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Take this course</h4><div class="textwidget custom-html-widget"><a href="https://shareasale.com/r.cfm?b=1041299&u=1627062&m=59485&urllink=&afftrack=">Essentials of OpenStack Administration (LFS252)</a></div></div> <!-- end .et_pb_widget --><div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="https://www.linuxnix.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div> <!-- end .et_pb_widget --><div id="insticator-embed-5" class="et_pb_widget insticator-embed-class"></div> <!-- end .et_pb_widget --><div id="custom_html-6" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><!-- Insticator API Fire Widget -->
<div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed" embed-id="68177583-1994-412a-be0d-ee99e36ca658"></div><div id="div-insticator-ad-2"></div><script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "68177583-1994-412a-be0d-ee99e36ca658"})/*]]>*/</script></div>
<!-- End Insticator API Fire Widget -->

<style>
#textwidget custom-html-widget {padding: 2px !important;}

</style></div></div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">ABOUT ME..!</h4>			<div class="textwidget"><p><a href="/wp-content/uploads/2010/05/My-photo.jpg"><img class="alignnone size-full wp-image-2382" src="/wp-content/uploads/2010/05/My-photo.jpg" alt="My photo"></a><br />
My name is Surendra Kumar Anne. I hail from Vijayawada which is cultural capital of south Indian state of Andhra Pradesh. I am a Linux evangelist who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. At present I work at Bank of America as Sr. Analyst Systems and Administration. You can contact me at surendra (@) linuxnix dot com.</p>
</div>
		</div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->


	</div> <!-- .container -->

</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_2">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<!--<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>-->
<!-- OnScroll tag: linuxnix - 479839 - 728x90(SF) -->
<script src="//tags.us.onscroll.com/abb02468-6e24-445f-8578-cb3cee3d87ca/tag.min.js" async defer></script>
				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="https://www.linuxnix.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="https://www.linuxnix.com/testimonials/">Testimonials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6050"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="https://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="https://www.linuxnix.com/contribute/">Contribute</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="https://www.linuxnix.com/editorial-board/">Editorial team</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="https://www.linuxnix.com/support-us/">Support us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="https://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	<script>
(function(m,a,i,l,e,r){ m['MailerLiteObject']=e;function f(){
var c={ a:arguments,q:[]};var r=this.push(c);return "number"!=typeof r?r:f.bind(c.q);}
f.q=f.q||[];m[e]=m[e]||f.bind(f.q);m[e].q=m[e].q||f.q;r=a.createElement(i);
var _=a.getElementsByTagName(i)[0];r.async=1;r.src=l+'?v'+(~~(new Date().getTime()/1000000));
_.parentNode.insertBefore(r,_);})(window, document, 'script', 'https://static.mailerlite.com/js/universal.js', 'ml');

var ml_account = ml('accounts', '1233092', 'h2f1i6t6q7', 'load');
</script>

	<img id = "ba_banner" src = "https://www.linuxnix.com/wp-content/plugins/blockalyzer-adblock-counter/img/ads/banner.gif" alt = "banner" width = "1" height = "1" /><script type="text/javascript">//<![CDATA[
                jQuery(document).ready(function($) {
                    setTimeout(function(){ // timeout to run after loading the advertisement.js
                        // count for missing js file
                        var nonce = '104138a0db';
                        
                        ba_blocked=false;
                        if ($.adblockJsFile === undefined){
                            ba_blocked=true;
                        }

                        var banner = document.getElementById("ba_banner");

                        if (banner == null || banner.offsetHeight == 0){
                            ba_blocked=true;
                        }

                        if(ba_blocked==true){
                            BaSetCookie('BaAdBlock', 'enabled', 30);
                        }else{
                            BaSetCookie('BaAdBlock', 'disabled', 30);
                        }
                        var data = {
                    action: 'standard_count',
                    blocked: ba_blocked
                };
                data.ba_count_jsFile = false;
                if ($.adblockJsFile === undefined){
                    data.ba_count_jsFile = true;
                }

                data.ba_count_banner = false;
                if (banner == null || banner.offsetHeight == 0){
                    data.ba_count_banner = true;
                }

                $.post(BaAjax.ajaxurl, data, function(response) {
                                        if ( !BaGetCookie('BaUniqueVisitor') || BaGetCookie('BaUniqueVisitor') != nonce ) {
                        BaSetCookie('BaUniqueVisitor', nonce, 30);
                    }
            });                    },100);
                });
            //]]></script>
<script type='text/javascript'>
	//<![CDATA[
    jQuery(document).ready(function($) { 
    	$('html').MagicLiquidizerTable({ whichelement: 'table', breakpoint: '780', headerSelector: 'thead td, thead th, tr th', bodyRowSelector: 'tbody tr, tr', table: '1' })
    })
	//]]>
</script> 	
<link rel='stylesheet' id='lsi-style-css'  href='https://www.linuxnix.com/wp-content/plugins/lightweight-social-icons/css/style-min.css?ver=1.0.1' type='text/css' media='all' />
<style id='lsi-style-inline-css' type='text/css'>
.icon-set-lsi_widget-2 a,
			.icon-set-lsi_widget-2 a:visited,
			.icon-set-lsi_widget-2 a:focus {
				border-radius: 25px;
				background: #b11b3d !important;
				color: #FFFFFF !important;
				font-size: 20px !important;
			}

			.icon-set-lsi_widget-2 a:hover {
				background: #777777 !important;
				color: #FFFFFF !important;
			}
</style>
<link rel='stylesheet' id='rainmaker_form_style-css'  href='https://www.linuxnix.com/wp-content/plugins/icegram-rainmaker/classes/../assets/css/form.css?ver=0.37' type='text/css' media='all' />

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"linuxnix"};
/* ]]> */
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"7719 https:\/\/www.linuxnix.com\/?p=7719","disqusShortname":"linuxnix","disqusTitle":"3 ways to automate file transfers using ftp","disqusUrl":"https:\/\/www.linuxnix.com\/3-ways-to-automate-file-transfers-using-ftp\/","postId":"7719"};
/* ]]> */
</script>






<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","rating_nonce":"f4307711a5","timeline_nonce":"d562a69f24","blog_feed_nonce":"df99175de0","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address."};
/* ]]> */
</script>







<script type='text/javascript'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"fc5e58a1b6","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","is_divi_theme_used":"","widget_search_selector":".widget_search"};
/* ]]> */
</script>



<script type='text/javascript'>
/* <![CDATA[ */
var rm_pre_data = {"ajax_url":"https:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","rm_nonce_field":"4f8abe81b0"};
/* ]]> */
</script>


<script>
(function(){
  if(typeof _bsa !== 'undefined' && _bsa) {
    _bsa.init('fancybar', 'CK7IVKQI', 'placement:wwwlinuxnixcom');
  }
})();
</script>

<script type="text/javascript" defer src="https://www.linuxnix.com/wp-content/cache/autoptimize/js/autoptimize_878da74591c382afe62e3c954966d839.js"></script><script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=31', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=31', false, [], true, false, false, false);
</script>

<!--Begin comScore Tag--><script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"20015427"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el)})();</script><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript><!--End comScore Tag-->
<!--Quantcast Tag--><script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt)})();_qevents.push({qacct:"p-31iz6hfFutd16",labels:"Domain.linuxnix_com,DomainId.113700"});</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxnix_com,DomainId.113700" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><!--End Quantcast tag--></body>
</html>
