<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head><link rel="stylesheet" type="text/css" href="http://www.linuxnix.com/wp-content/cache/minify/b7961.css" media="all"/>
<meta charset="UTF-8"/>
<link rel="pingback" href="http://www.linuxnix.com/xmlrpc.php"/>
<!--[if lt IE 9]>
	<script src="http://www.linuxnix.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<title>Basics of SELinux in Linux - The Linux Juggernaut</title>
 
<link rel="canonical" href="http://www.linuxnix.com/basics-of-selinux-in-linux/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Basics of SELinux in Linux - The Linux Juggernaut"/>
<meta property="og:description" content="Basics of SElinux What is SELinux? SELinux is a set of security policies/modules which are going to apply on the machine to improve the overall security of the machine. These are the Linux security modules(LSM) which are loaded in to kernel to improve security on accessing services/files which improve security. SELinux is short form of &hellip;"/>
<meta property="og:url" content="http://www.linuxnix.com/basics-of-selinux-in-linux/"/>
<meta property="og:site_name" content="The Linux Juggernaut"/>
<meta property="article:author" content="https://www.facebook.com/Linux.Juggernaut/"/>
<meta property="article:tag" content="app-armor"/>
<meta property="article:tag" content="Basic-Security"/>
<meta property="article:tag" content="Enter your zip code here"/>
<meta property="article:tag" content="getenforce"/>
<meta property="article:tag" content="Security"/>
<meta property="article:tag" content="SELinux"/>
<meta property="article:tag" content="setenforce"/>
<meta property="article:section" content="Security"/>
<meta property="article:published_time" content="2012-09-12T12:06:00+00:00"/>
<meta property="og:image" content="http://docs.google.com/drawings/image?id=af26a&#038;w=400&#038;h=400&#038;rev=43&#038;ac=1"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="Basics of SElinux What is SELinux? SELinux is a set of security policies/modules which are going to apply on the machine to improve the overall security of the machine. These are the Linux security modules(LSM) which are loaded in to kernel to improve security on accessing services/files which improve security. SELinux is short form of [&hellip;]"/>
<meta name="twitter:title" content="Basics of SELinux in Linux - The Linux Juggernaut"/>
<meta name="twitter:image" content="http://docs.google.com/drawings/image?id=af26a&#038;w=400&#038;h=400&#038;rev=43&#038;ac=1"/>
<meta name="twitter:creator" content="@linuxnix"/>
 
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Feed" href="http://www.linuxnix.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Comments Feed" href="http://www.linuxnix.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="The Linux Juggernaut &raquo; Basics of SELinux in Linux Comments Feed" href="http://www.linuxnix.com/basics-of-selinux-in-linux/feed/"/>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("http://www.linuxnix.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '348fde8d-723d-4dd8-b8ac-2d123ca69f0a';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['subdomainName'] = "linuxnix";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Get free Linux/Devops updates to you directly';
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.linuxnix.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.7"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Extra v.1.2.4.4" name="generator"/><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='et-gf-open-sans-css' href="https://fonts.googleapis.com/css?family=Open+Sans:400,700" type='text/css' media='all'/>
<link rel='stylesheet' id='extra-fonts-css' href="https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&#038;subset=latin,latin-ext" type='text/css' media='all'/>
<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/df983.js"></script>
<!--[if IE]><script type='text/javascript' src='http://www.linuxnix.com/wp-content/plugins/wordpress-popup/assets/js/vendor/fitie/fitie.js?ver=2.0.2'></script>
<![endif]--><link rel='https://api.w.org/' href='http://www.linuxnix.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.linuxnix.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.linuxnix.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.5.7"/>
<link rel='shortlink' href='http://www.linuxnix.com/?p=138'/>
<link rel="alternate" type="application/json+oembed" href="http://www.linuxnix.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.linuxnix.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;format=xml"/>
<style type="text/css" id="et-social-custom-css"></style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1"/>
<style type="text/css" id="extra-dynamic-styles-primary_nav_text_color-color">#et-menu>li a,#et-menu>li.menu-item-has-children>a:after,#et-menu>li.mega-menu-featured>a:after,#et-extra-mobile-menu>li.mega-menu-featured>a:after{color:rgba(0,0,0,0.6);}</style>
<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-color">#et-menu>li>a:hover,#et-menu>li.menu-item-has-children>a:hover:after,#et-menu>li.mega-menu-featured>a:hover:after,#et-navigation>ul#et-menu>li.current-menu-item>a,#et-navigation>ul#et-menu>li.current_page_item>a,#et-extra-mobile-menu>li.mega-menu-featured>a:hover:after,#et-extra-mobile-menu>li.current-menu-item>a,#et-extra-mobile-menu>li.current_page_item>a,#et-extra-mobile-menu>li>a:hover{color:#1e73be;}</style>
<style type="text/css" id="extra-dynamic-styles-primary_nav_active_link_color-background-color">#et-navigation>ul>li>a:before{background-color:#1e73be;}</style>
<style type="text/css" id="extra-dynamic-styles-primary_nav_background_color-background-color">#main-header{background-color:#ffffff;}</style>
<style type="text/css" id="extra-dynamic-styles-button_text_color-color">#page-container .button,#page-container button,#page-container button[type="submit"],#page-container input[type="submit"],#page-container input[type="reset"],#page-container input[type="button"],.read-more-button,.comment-body .comment_area .comment-content .reply-container .comment-reply-link,.widget_tag_cloud a,.widget_tag_cloud a:visited,.post-nav .nav-links .button,a.read-more-button,a.read-more-button:visited,#footer .widget_tag_cloud a,#footer .widget_tag_cloud a:visited,#footer a.read-more-button,#footer a.read-more-button:visited,#footer .button,#footer button,#footer button[type="submit"],#footer input[type="submit"],#footer input[type="reset"],#footer input[type="button"]{color:rgba(0,0,0,0.6);}</style>
<style type="text/css" id="extra-dynamic-styles-button_hover_text_color-color">#page-container .button:hover,#page-container button:hover,#page-container button[type="submit"]:hover,#page-container input[type="submit"]:hover,#page-container input[type="reset"]:hover,#page-container input[type="button"]:hover,.read-more-button:hover,.comment-body .comment_area .comment-content .reply-container .comment-reply-link:hover,.widget_tag_cloud a:hover,.widget_tag_cloud a:visited:hover,.post-nav .nav-links .button:hover,a.read-more-button:hover,a.read-more-button:visited:hover,#footer .widget_tag_cloud a:hover,#footer .widget_tag_cloud a:visited:hover,#footer a.read-more-button:hover,#footer a.read-more-button:visited:hover,#footer .button:hover,#footer button:hover,#footer button[type="submit"]:hover,#footer input[type="submit"]:hover,#footer input[type="reset"]:hover,#footer input[type="button"]:hover{color:rgba(0,0,0,0.6);}</style>
<style type="text/css" id="extra-dynamic-styles-extra_nav_height_value">@media only screen and (min-width: 768px) {#main-header .logo{height:48.45px;margin:23.275px 0;}.header.left-right #et-navigation>ul>li>a{padding-bottom:39.5px;}}@media only screen and (min-width: 768px) {.et-fixed-header #main-header .logo{height:48.45px;margin:23.275px 0;}.et-fixed-header .header.left-right #et-navigation>ul>li>a{padding-bottom:39.5px;}}</style>
 <script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "5.5", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/a30dc085-55ae-4bb0-9e46-774d36a290eb.js');/*]]>*/</script> <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-752078-3', 'auto');
  ga('send', 'pageview');

</script><link rel="icon" href="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-32x32.png" sizes="32x32"/>
<link rel="icon" href="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-180x180.png"/>
<meta name="msapplication-TileImage" content="http://www.linuxnix.com/wp-content/uploads/2011/05/cropped-Untitleddrawing3-270x270.png"/>
<style type="text/css" id="et-custom-css">@media screen and (max-width: 900px)
{#main-header .etad{display:none;}}#top-header{background-color:#B11B3D;}.et_pb_extra_module .main-post article .header img,.et_extra_other_module .main-post article .header img{display:block;width:auto;object-fit:cover;height:158px;width:100%;}pre{border:1px solid #DDD;overflow:auto;background:#EEE;font-size:.857em;line-height:1.5em;margin-bottom:1.833em;padding:.667em .917em;clear:both;color:#000;}.posts-blog-feed-module.masonry .post-content{padding:20px!important;}.author-box{display:none;}.post-thumbnail img{width:auto;margin:0 auto;}#disqus_thread{background:#fff;padding:20px;border-radius:3px;box-shadow:0 1px 3px rgba(0,0,0,0.1);box-sizing:border-box;}</style></head>
<body class="single single-post postid-138 single-format-standard et_monarch et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right unknown et_includes_sidebar">
<div id="page-container">
 
<header class="header left-right">
 
<div id="top-header" style="">
<div class="container">
 
<div id="et-secondary-nav" class="et-trending">
 
<div id="et-trending">
 
<a id="et-trending-button" href="#" title="">
<span></span>
<span></span>
<span></span>
</a>
 
<h4 id="et-trending-label">
TRENDING: </h4>
 
<div id='et-trending-container'>
<div id="et-trending-post-1297" class="et-trending-post et-trending-latest">
<a href="http://www.linuxnix.com/sticky-bit-set-linux/">What is a sticky Bit and how to set it in Linux?</a>
</div>
<div id="et-trending-post-1264" class="et-trending-post">
<a href="http://www.linuxnix.com/suid-set-suid-linuxunix/">What is SUID and how to set SUID in Linux/Unix?</a>
</div>
<div id="et-trending-post-1093" class="et-trending-post">
<a href="http://www.linuxnix.com/linux-top-command-explained-2/">Linux TOP command explained</a>
</div>
</div>
</div>
</div>
 
<div id="et-info">
 
<ul class="et-extra-social-icons" style="">
<li class="et-extra-social-icon facebook">
<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
</li>
<li class="et-extra-social-icon twitter">
<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
</li>
<li class="et-extra-social-icon instagram">
<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
</li>
</ul>
 
<div class="et-top-search" style="">
<form role="search" class="et-search-form" method="get" action="http://www.linuxnix.com/">
<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:"/>
<button class="et-search-submit"></button>
</form> </div>
 
</div>
</div> 
</div> 
 
<div id="main-header-wrapper">
<div id="main-header" data-fixed-height="95">
<div class="container">
 
 
<a class="logo" href="http://www.linuxnix.com/" data-fixed-height="51">
<img src="http://www.linuxnix.com/wp-content/uploads/2016/08/linux.png" alt="The Linux Juggernaut" id="logo"/>
</a>
<div style="margin:auto;padding-top: 5px;" class="js-gads">
<script type="text/javascript"><!--
						    google_ad_client = "ca-pub-7992389594799240";
						    if (window.innerWidth <= 350) {
						      // Small ad
						      google_ad_slot = "1617608518";
						      google_ad_width = 320;
						      google_ad_height = 50;
						    } else if (window.innerWidth >= 750) {
						      google_ad_slot = "1617608518";
						      google_ad_width = 728;
						      google_ad_height = 90;

						    } else {
						      // Medium (fallback) ad
						      google_ad_slot = "1617608518";
						      google_ad_width = 320;
						      google_ad_height = 50;
						    }
						  //--></script>
<script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
</div>
</div>
 
<div class="subHeader">
<div class="container">
 
<div id="et-navigation" class="">
<ul id="et-menu" class="nav"><li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-5531"><a href="http://www.linuxnix.com/category/administration/">Administration</a>
<ul class="sub-menu">
<li id="menu-item-5534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5534"><a href="http://www.linuxnix.com/category/administration/monitoring/">Monitoring</a></li>
<li id="menu-item-5533" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5533"><a href="http://www.linuxnix.com/category/administration/security/">Security</a></li>
<li id="menu-item-5532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5532"><a href="http://www.linuxnix.com/category/administration/servers/">Servers</a></li>
</ul>
</li>
<li id="menu-item-5536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5536"><a href="http://www.linuxnix.com/category/basics/">Basics</a></li>
<li id="menu-item-5544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5544"><a href="/category/cloudvirtulization/">Cloud</a>
<ul class="sub-menu">
<li id="menu-item-5545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5545"><a href="/category/cloudvirtulization/aws/">AWS</a></li>
<li id="menu-item-5540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5540"><a href="http://www.linuxnix.com/category/cloudvirtulization/kvm/">KVM</a></li>
</ul>
</li>
<li id="menu-item-5546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5546"><a href="/category/Devops/">Devops</a>
<ul class="sub-menu">
<li id="menu-item-5547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5547"><a href="/category/Devops/Ansible/">Ansible</a></li>
<li id="menu-item-5548" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5548"><a href="/category/Devops/Docker/">Docker</a></li>
<li id="menu-item-5549" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5549"><a href="/category/Devops/Packer/">Packer</a></li>
<li id="menu-item-5550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5550"><a href="/category/Devops/Puppet/">Puppet</a></li>
<li id="menu-item-5551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5551"><a href="/category/Devops/Vagrant/">Vagrant</a></li>
</ul>
</li>
<li id="menu-item-5537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5537"><a href="http://www.linuxnix.com/category/interviews-2/">Interviews</a></li>
<li id="menu-item-5535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5535"><a href="http://www.linuxnix.com/category/news/">News</a></li>
<li id="menu-item-5552" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5552"><a href="/category/offers/">Offers</a></li>
<li id="menu-item-5553" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5553"><a href="/category/Programming/">Programming</a>
<ul class="sub-menu">
<li id="menu-item-5554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5554"><a href="/category/Programming/awk/">Awk</a></li>
<li id="menu-item-5538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5538"><a href="http://www.linuxnix.com/category/programming/bash/">Bash</a></li>
<li id="menu-item-5555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5555"><a href="/category/Programming/Batch/">Batch</a></li>
<li id="menu-item-5556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5556"><a href="/category/Programming/git/">Git</a></li>
<li id="menu-item-5557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5557"><a href="/category/Programming/Perl/">Perl</a></li>
<li id="menu-item-5558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5558"><a href="/category/Programming/PowerShell/">PowerShell</a></li>
<li id="menu-item-5539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5539"><a href="http://www.linuxnix.com/category/programming/python/">python</a></li>
<li id="menu-item-5559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5559"><a href="/category/Programming/Ruby/">Ruby</a></li>
<li id="menu-item-5560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5560"><a href="/category/Programming/Sed/">Sed</a></li>
<li id="menu-item-5561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5561"><a href="/category/Programming/SQL/">SQL</a></li>
</ul>
</li>
<li id="menu-item-5562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5562"><a href="/category/Reviews/">Reviews</a>
<ul class="sub-menu">
<li id="menu-item-5563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5563"><a href="/category/Reviews/Books/">Books</a></li>
<li id="menu-item-5564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5564"><a href="/category/Reviews/Linuxunix/">Linux/Unix</a></li>
<li id="menu-item-5565" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5565"><a href="/category/reviews/open-source/">Open source</a></li>
</ul>
</li>
<li id="menu-item-5896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5896"><a href="http://corp.linuxnix.com">Mounix Systems</a></li>
</ul> <div id="et-mobile-navigation">
<span class="show-menu">
<div class="show-menu-button">
<span></span>
<span></span>
<span></span>
</div>
<p>Select Page</p>
</span>
<nav>
</nav>
</div>   </div> 
</div>
</div>
</div> 
</div> 
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-138" class="module single-post-module post-138 post type-post status-publish format-standard hentry category-security tag-app-armor tag-basic-security tag-enter-your-zip-code-here tag-getenforce tag-security tag-selinux tag-setenforce et-doesnt-have-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Basics of SELinux in Linux</h1>
<div class="post-meta">
<p>Posted by <a href="http://www.linuxnix.com/author/surendra/" class="url fn" title="Posts by Surendra Anne" rel="author">Surendra Anne</a> | <span class="updated">Sep 12, 2012</span> | <a href="http://www.linuxnix.com/category/administration/security/" rel="tag">Security</a> | <a class="comments-link" href="http://www.linuxnix.com/basics-of-selinux-in-linux/#comments">5 <span title="comment count" class="comment-bubble post-meta-icon"></span></a> | <span class="rating-stars" title="Rating: 3.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
</div>
</div>
<div class="post-wrap">
<div class="post-content entry-content">
<h1>Basics of SElinux</span></h1>
<p><strong>What is SELinux?</strong></p>
<p>SELinux is a set of security policies/modules which are going to apply on the machine to improve the overall security of the machine. These are the Linux security modules(LSM) which are loaded in to kernel to improve security on accessing services/files which improve security. <strong>SELinux</strong> is short form of Security Enhanced Linux. <strong>SElinux</strong> is a security feature which was shipped with RHEL5, it is much secure than any other security such as PAM and Initd. Apparmor is some times consider as eloquent to SELinux. Below is the security model in Linux.</p>
<p><img src="https://docs.google.com/drawings/image?id=af26a&amp;w=400&amp;h=400&amp;rev=43&amp;ac=1" alt=""/></p>
<h2><strong>Setting of SELinux</strong></span></h2>
<p><strong>SELinux is set in three modes.</strong></p>
<ul>
<li><span style="color: #800000;"><strong>Enforcing</strong> </span>&#8211; SELinux security policy is enforced. IF this is set SELinux is enabled and will try to enforce the SELinux policies strictly</li>
<li><span style="color: #800000;"><strong>Permissive</strong></span> &#8211; SELinux prints warnings instead of enforcing. This setting will just give warning when any SELinux policy setting is breached</li>
<li><strong><span style="color: #800000;">Disabled</span></strong> &#8211; No SELinux policy is loaded. This will totally disable SELinux policies.</li>
</ul>
<p>&nbsp;</p>
<p><strong>And SELinux is set in two levels</strong></p>
<ul>
<li><strong><span style="color: #800000;">Targeted</span></strong> &#8211; Targeted processes are protected,</li>
<li><strong><span style="color: #800000;">Mls</span> </strong>&#8211; Multi Level Security protection.</li>
</ul>
<h2>Get SELinux Status</span></h2>
<p><strong style="color: red;">Example1</strong>:Is SELinux enabled or not on your box? use below command to get the status.</p>
<p><span style="color: #3333ff;"><strong>#getenforce<br/>
</strong></span></p>
<p>The output will be either &#8220;Enabled&#8221; or &#8220;Disabled&#8221;<br/>
<strong style="color: red;">Example2</strong>: To see SELinux status in simplified way you can use sestatus<br/>
<strong></strong></p>
<p><span style="color: #800000;"><strong>#sestatus</strong></span></p>
<p><strong>Sample output:</strong><br/>
<em><span style="color: #ff0000;">SElinux status : enabled</span></em><br/>
<em><span style="color: #ff0000;">SELinux mount : /selinux</span></em><br/>
<em><span style="color: #ff0000;">Current mode : enforcing</span></em><br/>
<em><span style="color: #ff0000;">Mode from config file : enforcing</span></em><br/>
<em><span style="color: #ff0000;">Policy version : 21</span></em><br/>
<em><span style="color: #ff0000;">Policy from config file : targeted</span></em></p>
<p>From the above output we can see that SElinux is enabled and it is in enforced mode.<br/>
and to see detailed status you can use <strong>-b</strong> option, this will give on which services SElinux is enabled and which services are disabled.</p>
<p><span style="color: #800000;"><strong>Example3:</strong></span>To get elobrated info on difference status of SELinux on different services use -b option along sestatus</p>
<p><strong>#sestatus -b</strong></p>
<p><strong>Sample output:</strong></p>
<p><span style="color: #ff0000;"><em>[<a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="82f0ededf6c2e1e7ecf6edf1b3">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script> ~]# sestatus -b</em></span><br/>
<span style="color: #ff0000;"><em>SELinux status: enabled</em></span><br/>
<span style="color: #ff0000;"><em>SELinuxfs mount: /selinux</em></span><br/>
<span style="color: #ff0000;"><em>Current mode: permissive</em></span><br/>
<span style="color: #ff0000;"><em>Mode from config file: enforcing</em></span><br/>
<span style="color: #ff0000;"><em>Policy version: 24</em></span><br/>
<span style="color: #ff0000;"><em>Policy from config file: targeted</em></span></p>
<p><span style="color: #ff0000;"><em>Policy booleans:</em></span><br/>
<span style="color: #ff0000;"><em>abrt_anon_write off</em></span><br/>
<span style="color: #ff0000;"><em>allow_console_login on</em></span><br/>
<span style="color: #ff0000;"><em>allow_corosync_rw_tmpfs off</em></span><br/>
<span style="color: #ff0000;"><em>allow_cvs_read_shadow off</em></span><br/>
<span style="color: #ff0000;"><em>allow_daemons_dump_core on</em></span><br/>
<span style="color: #ff0000;"><em>allow_daemons_use_tty on</em></span><br/>
<span style="color: #ff0000;"><em>allow_domain_fd_use on</em></span><br/>
<span style="color: #ff0000;"><em>allow_execheap off</em></span><br/>
<span style="color: #ff0000;"><em>allow_execmem on</em></span><br/>
<span style="color: #ff0000;"><em>allow_execmod on</em></span><br/>
<span style="color: #ff0000;"><em>allow_execstack on</em></span><br/>
<span style="color: #ff0000;"><em>allow_ftpd_anon_write off</em></span></p>
<p><strong>==Cliped the output here==</strong></p>
<h2><strong>Disabling SELinux</strong></span></h2>
<p><strong style="color: red;">Example4</strong>:How to disable SElinux</p>
<p>We can do it in two ways<br/>
<strong>1)</strong>Permanent<strong> way : </strong><span style="color: #000000;"><strong>edit /etc/selinux/config</strong></span></p>
<p>change the <strong>status</strong> of SELINUX from<strong> enforcing</strong> to <strong>disabled</strong></p>
<p>SELINUX=enforcing</p>
<p>to</p>
<p>SELINUX=disabled</p>
<p>Save the file and exit.</p>
<p><strong>2)Temporary way : </strong>Execute below command</p>
<p><strong>echo 0 &gt; /selinux/enforce</strong></p>
<p>or</p>
<p>setenforce 0</p>
<h2 style="text-align: center;"><strong><span style="color: #ff0000;">Enabling SELinux</span></strong></h2>
<p><span style="color: #ff0000;"><strong>Example5:</strong></span>How about enabling SELinux</p>
<p><strong>1)</strong>Permanent<strong> way : </strong><strong>edit /etc/selinux/config</strong></p>
<p>change the <strong>status</strong> of SELINUX from<strong> </strong><strong>disabled to <strong>enforcing</strong></strong></p>
<p>SELINUX=disabled</p>
<p>to</p>
<p>SELINUX=<strong>enforcing</strong></p>
<p>Save the file and exit.</p>
<p><strong>2)Temporary way : </strong>Execute below command</p>
<p><strong>echo 1 &gt; /selinux/enforce</strong></p>
<p>or</p>
<p><strong>setenforce 1</strong></p>
<pre>Comment your thoughts on SELinux.</pre>
<span class="et_social_bottom_trigger"></span> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;t=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Facebook" data-network-name="facebook" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/home?status=Basics%20of%20SELinux%20in%20Linux%20http://www.linuxnix.com/basics-of-selinux-in-linux/" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Twitter" data-network-name="twitter" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;t=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Google +" data-network-name="googleplus" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.tumblr.com/share?v=3&#038;u=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;t=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Tumblr" data-network-name="tumblr" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover"></span>
</a><a href="https://www.pinterest.com/pin/create/button/?url=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;description=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Pinterest" data-network-name="pinterest" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;title=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="https://bufferapp.com/add?url=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;title=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Buffer" data-network-name="buffer" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover"></span>
</a><a href="http://www.stumbleupon.com/badge?url=http://www.linuxnix.com/basics-of-selinux-in-linux/&#038;title=Basics%20of%20SELinux%20in%20Linux" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Email" data-network-name="basic_email" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Basics of SELinux in Linux&quot; via Print" data-network-name="basic_print" data-share-title="Basics of SELinux in Linux" data-share-url="http://www.linuxnix.com/basics-of-selinux-in-linux/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<div class="rating-stars">
<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="138"/> </div>
<style type="text/css" id="rating-stars">.post-footer .rating-stars #rated-stars img.star-on,.post-footer .rating-stars #rating-stars img.star-on{background-color:#e8533b;}</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="http://www.linuxnix.com/linuxunix-bash-shell-script-to-find-out-machinesystem-ip-address/" rel="prev"><span class="button">Previous</span><span class="title">Linux/Unix Bash shell script to find out machine/system IP address</span></a> </div>
<div class="nav-link nav-link-next">
<a href="http://www.linuxnix.com/linux-directory-structure-explained-boot-folder/" rel="next"><span class="button">Next</span><span class="title">Linux Directory Structure explained: /boot folder</span></a> </div>
</div>
</nav>
<div class="et_extra_other_module author-box vcard">
<div class="author-box-header">
<h3>About The Author</h3>
</div>
<div class="author-box-content clearfix">
<div class="author-box-avatar photo">
<img alt='' src="https://2.gravatar.com/avatar/8f71515aab81c5a2f6b9a2f414e347eb?s=170&#038;d=mm&#038;r=g" srcset="http://2.gravatar.com/avatar/8f71515aab81c5a2f6b9a2f414e347eb?s=340&amp;d=mm&amp;r=g 2x" class='avatar avatar-170 photo' height='170' width='170'/> </div>
<div class="author-box-description">
<h4><a class="author-link url fn" href="http://www.linuxnix.com/author/surendra/" rel="author" title="">Surendra Anne</a></h4>
<p class="note">Mr Surendra Anne is from Vijayawada, Andhra Pradesh, India. He is a Linux/Open source supporter who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. He works as Devops Engineer with Taggle systems, an IOT automatic water metering company, Sydney . You can contact him at surendra (@) linuxnix dot com.</p>
<ul class="social-icons">
<li><a href="https://www.facebook.com/Linux.Juggernaut/" target="_blank"><span class="et-extra-icon et-extra-icon-facebook et-extra-icon-color-hover"></span></a></li>
<li><a href="http://linuxnix" target="_blank"><span class="et-extra-icon et-extra-icon-twitter et-extra-icon-color-hover"></span></a></li>
<li><a href="https://www.facebook.com/Linux.Juggernaut/" target="_blank"><span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-color-hover"></span></a></li>
</ul>
</div>
</div>
</div>
<div class="et_extra_other_module related-posts">
<div class="related-posts-header">
<h3>Related Posts</h3>
</div>
<div class="related-posts-content clearfix">
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/kernel-recompilation/" title="Kernel Recompilation" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Kernel Recompilation"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/kernel-recompilation/">Kernel Recompilation</a></h4>
<p class="date"><span class="updated">May 27, 2008</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/how-to-auto-logout/" title="How To set Auto Logout for Linux users" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="How To set Auto Logout for Linux users"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/how-to-auto-logout/">How To set Auto Logout for Linux users</a></h4>
<p class="date"><span class="updated">March 17, 2010</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/hardening-ssh-server-in-the-dmzde-militarised-zone/" title="Hardening SSH Server In The DMZ(De Militarised Zone)" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-thumb-text.svg" alt="Hardening SSH Server In The DMZ(De Militarised Zone)"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/hardening-ssh-server-in-the-dmzde-militarised-zone/">Hardening SSH Server In The DMZ(De Militarised Zone)</a></h4>
<p class="date"><span class="updated">March 17, 2010</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="http://www.linuxnix.com/heartbeat-clustering/" title="Heartbeat Clustering in Linux" class="post-thumbnail">
<img src="http://www.linuxnix.com/wp-content/uploads/2010/01/ha_nodes.png" alt="Heartbeat Clustering in Linux"/><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="http://www.linuxnix.com/heartbeat-clustering/">Heartbeat Clustering in Linux</a></h4>
<p class="date"><span class="updated">January 23, 2010</span></p>
</div>
</div>
</div>
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-1056">
<div id="dsq-comment-header-1056" class="dsq-comment-header">
<cite id="dsq-cite-1056">
<span id="dsq-author-user-1056">gouthamk10</span>
</cite>
</div>
<div id="dsq-comment-body-1056" class="dsq-comment-body">
<div id="dsq-comment-message-1056" class="dsq-comment-message"><p>good post.</p>
<p>thanks</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1057">
<div id="dsq-comment-header-1057" class="dsq-comment-header">
<cite id="dsq-cite-1057">
<span id="dsq-author-user-1057">Premnath</span>
</cite>
</div>
<div id="dsq-comment-body-1057" class="dsq-comment-body">
<div id="dsq-comment-message-1057" class="dsq-comment-message"><p>nice</p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1058">
<div id="dsq-comment-header-1058" class="dsq-comment-header">
<cite id="dsq-cite-1058">
<span id="dsq-author-user-1058">djangofan</span>
</cite>
</div>
<div id="dsq-comment-body-1058" class="dsq-comment-body">
<div id="dsq-comment-message-1058" class="dsq-comment-message"><p>What you don&#8217;t mention is that there is a nice GUI tool called &#8220;SELinux Management&#8221; that can be found in the standard software repository. For beginners, its much more educational since it shows all the possibilities right up front.</p>
</div>
</div>
</li> 
<li class="post pingback">
<p>Pingback: <a href='http://www.linuxnix.com/2011/02/howtos-related-linux-file-folder-permissions.html' rel='external nofollow' class='url'>Many howto&#8217;s related to Linux file and folder permissions | The Linux Juggernaut</a>()</p>
</li>
</li> 
<li class="post pingback">
<p>Pingback: <a href='http://www.thelinuxgeek.net/basics-of-selinux-in-linux-a-linux-user-should-know' rel='external nofollow' class='url'>Basics of SELinux in Linux a Linux user should know | Thelinuxgeek</a>()</p>
</li>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1061">
<div id="dsq-comment-header-1061" class="dsq-comment-header">
<cite id="dsq-cite-1061">
<span id="dsq-author-user-1061">john</span>
</cite>
</div>
<div id="dsq-comment-body-1061" class="dsq-comment-body">
<div id="dsq-comment-message-1061" class="dsq-comment-message"><p>after changing selinux = disabled , how to effect changes to system , if system is restart ? or any command is ther.</p>
</div>
</div>
<ul class="children">
<li class="comment byuser comment-author-surendra bypostauthor even depth-2" id="dsq-comment-1062">
<div id="dsq-comment-header-1062" class="dsq-comment-header">
<cite id="dsq-cite-1062">
<a id="dsq-author-user-1062" href="http://www.linuxnix.com" target="_blank" rel="nofollow">Surendra Anne</a>
</cite>
</div>
<div id="dsq-comment-body-1062" class="dsq-comment-body">
<div id="dsq-comment-message-1062" class="dsq-comment-message"><p>
you have to do above echo command as shown in post to update selinux status so that there is no reboot is required.</p>
</div>
</div>
</li> 
</ul> 
</li> 
</li> 
</li> 
</ul>
</div>
</div>
</div> 
<div class="et_pb_extra_column_sidebar">
<div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle"> </h4><form role="search" method="get" class="search-form" action="http://www.linuxnix.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s"/>
</label>
<input type="submit" class="search-submit" value="Search"/>
</form></div>  <div id="wp_subscribe-2" class="et_pb_widget wp_subscribe">
<div class="wp-subscribe no-name-field" id="wp-subscribe">
<h4 class="title">Get more stuff like this<br/> <span>in your inbox</span></h4>
<p class="text">Subscribe to our mailing list and get interesting stuff and updates to your email inbox.</p>
<form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('https://feedburner.google.com/fb/a/mailverify?uri=TheLinuxJuggernaut', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true" _lpchecked="1">
                        <input class="email-field" type="text" value="" placeholder="Enter your email here" name="email">
                        <input type="hidden" value="TheLinuxJuggernaut" name="uri"><input type="hidden" name="loc" value="en_US">
                        <input class="submit" name="submit" type="submit" value="Sign Up Now">
                    </form>
                
                                <div class="clear"></div>
                
                <p class="footer-text">we respect your privacy and take protecting it seriously</p>
                
            </div><!--subscribe_widget-->
        
        </div> <!-- end .et_pb_widget --><div id="et_social_followers-3" class="et_pb_widget widget_et_social_followers"><h4 class="widgettitle">Follow Us</h4>
		<div class="widget_content">
			<ul class="widget_list">
								<li>
						<a class="et-extra-icon et-extra-icon-facebook et-extra-icon-background social-icon" href="https://www.facebook.com/Linux.Juggernaut/"></a>
						<a href="https://www.facebook.com/Linux.Juggernaut/" class="widget_list_social">
							<h3 class="title">Facebook</h3>
													</a>
					</li>
										<li>
						<a class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background social-icon" href="https://plus.google.com/+Linuxnix"></a>
						<a href="https://plus.google.com/+Linuxnix" class="widget_list_social">
							<h3 class="title">Google+</h3>
													</a>
					</li>
										<li>
						<a class="et-extra-icon et-extra-icon-twitter et-extra-icon-background social-icon" href="https://twitter.com/LINUXNIX"></a>
						<a href="https://twitter.com/LINUXNIX" class="widget_list_social">
							<h3 class="title">Twitter</h3>
														<span class="post-meta">699 followers</span>
													</a>
					</li>
								</ul>
		</div>
		</div> <!-- end .et_pb_widget -->		<div id="et-recent-posts-3" class="et_pb_widget widget_et_recent_entries">		<h4 class="widgettitle">Recent Posts</h4>		<ul class="widget_list">
					<li>
									<a href="http://www.linuxnix.com/read-command-hide-password-linux/" title="Linux Shell scripting: Hide User input on terminal" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="Linux Shell scripting: Hide User input on terminal"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/read-command-hide-password-linux/" class="title">Linux Shell scripting: Hide User input on terminal</a>
										<div class="post-meta">
						<span class="updated">Mar 21, 2017</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/how-to-search-files-in-linux/" title="How to find a file in Linux?" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="How to find a file in Linux?"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/how-to-search-files-in-linux/" class="title">How to find a file in Linux?</a>
										<div class="post-meta">
						<span class="updated">Mar 19, 2017</span> | <a href="http://www.linuxnix.com/category/basics/" rel="tag">Basics</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/join-devops-whatsapp-groups/" title="Free: Join our Devops whatsApp group(s)" class="widget_list_thumbnail" style="background-color:#8bd623">
				<img src="http://www.linuxnix.com/wp-content/uploads/2017/03/DevOps-Gear-150x150.png" alt="Free: Join our Devops whatsApp group(s)"  style="background-color:#8bd623"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/join-devops-whatsapp-groups/" class="title">Free: Join our Devops whatsApp group(s)</a>
										<div class="post-meta">
						<span class="updated">Mar 17, 2017</span> | <a href="http://www.linuxnix.com/category/devops/ansible/" rel="tag">Ansible</a>, <a href="http://www.linuxnix.com/category/cloudvirtulization/aws/" rel="tag">AWS</a>, <a href="http://www.linuxnix.com/category/cloudvirtulization/" rel="tag">Cloud/Virtulization</a>, <a href="http://www.linuxnix.com/category/devops/" rel="tag">Devops</a>, <a href="http://www.linuxnix.com/category/devops/linux-containers/" rel="tag">Docker</a>, <a href="http://www.linuxnix.com/category/news/" rel="tag">News</a>, <a href="http://www.linuxnix.com/category/offers/" rel="tag">Offers</a>, <a href="http://www.linuxnix.com/category/devops/packer/" rel="tag">Packer</a>, <a href="http://www.linuxnix.com/category/devops/puppt-related-stuff/" rel="tag">Puppet</a>, <a href="http://www.linuxnix.com/category/devops/vagrant/" rel="tag">vagrant</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/pfotd-python-cmp-builtin-function-examples/" title="PFOTD: Python cmp() builtin function examples" class="widget_list_thumbnail" style="background-color:#7ac8cc">
				<img src="http://www.linuxnix.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="PFOTD: Python cmp() builtin function examples"  style="background-color:#7ac8cc"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/pfotd-python-cmp-builtin-function-examples/" class="title">PFOTD: Python cmp() builtin function examples</a>
										<div class="post-meta">
						<span class="updated">Feb 28, 2017</span> | <a href="http://www.linuxnix.com/category/programming/python/" rel="tag">python</a>					</div>
				</div>
			</li>
					<li>
									<a href="http://www.linuxnix.com/interview-questions-infrastructure-operational-manager/" title="7 Interview questions for Infrastructure operational manager" class="widget_list_thumbnail" style="background-color:#7ac8cc">
				<img src="http://www.linuxnix.com/wp-content/uploads/2010/03/interview-600x449.gif" alt="7 Interview questions for Infrastructure operational manager"  style="background-color:#7ac8cc"/>
			</a>								<div class="post_info">
					<a href="http://www.linuxnix.com/interview-questions-infrastructure-operational-manager/" class="title">7 Interview questions for Infrastructure operational manager</a>
										<div class="post-meta">
						<span class="updated">Feb 25, 2017</span> | <a href="http://www.linuxnix.com/category/interviews-2/" rel="tag">Interviews</a>					</div>
				</div>
			</li>
						</ul>
		</div> <!-- end .et_pb_widget --><div id="et-recent-comments-3" class="et_pb_widget widget_et_recent_comments"><h4 class="widgettitle">Recent Comments</h4><ul id="recentcomments" class="widget_list"><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/shell-script-to-convert-octal-to-decimal/#comment-2120">Shell script to convert Octal to Decimal</a></div></li><li class="recentcomments"><span class="author">brad tittle</span>  <div class="post-title">on <a href="http://www.linuxnix.com/shell-script-to-convert-octal-to-decimal/#comment-2119">Shell script to convert Octal to Decimal</a></div></li><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/how-to-search-files-in-linux/#comment-2113">How to find a file in Linux?</a></div></li><li class="recentcomments"><span class="author"><a href='http://www.linuxnix.com' rel='external nofollow' class='url'>Surendra</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/how-to-search-files-in-linux/#comment-2112">How to find a file in Linux?</a></div></li><li class="recentcomments"><span class="author"><a href='http://www.cuixiaochen.com' rel='external nofollow' class='url'>崔晓晨</a></span>  <div class="post-title">on <a href="http://www.linuxnix.com/how-to-search-files-in-linux/#comment-2111">How to find a file in Linux?</a></div></li></ul></div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">ABOUT ME..!</h4>			<div class="textwidget"><p><a href="/wp-content/uploads/2010/05/My-photo.jpg"><img class="alignnone size-full wp-image-2382" src="/wp-content/uploads/2010/05/My-photo.jpg" alt="My photo"></a><br />
My name is Surendra Kumar Anne. I hail from Vijayawada which is cultural capital of south Indian state of Andhra Pradesh. I am a Linux evangelist who believes in Hard work, A down to earth person, Likes to share knowledge with others, Loves dogs, Likes photography. At present I work at Bank of America as Sr. Analyst Systems and Administration. You can contact me at surendra (@) linuxnix dot com.</p>
</div>
		</div> <!-- end .et_pb_widget --><div id="insticator-embed-3" class="et_pb_widget insticator-embed-class"><!-- Insticator API Fire Widget --><div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div><script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "68177583-1994-412a-be0d-ee99e36ca658"})/*]]>*/</script></div><!-- End Insticator API Fire Widget --></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
</div> <!-- #main-content -->

	
	<footer id="footer" class="footer_columns_2">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<!--<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>-->

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-3347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3347"><a href="http://www.linuxnix.com/about-the-linux-juggernaut-blog/">About US</a></li>
<li id="menu-item-3349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3349"><a href="http://www.linuxnix.com/contribute/">Contribute</a></li>
<li id="menu-item-5341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5341"><a href="http://www.linuxnix.com/editorial-board/">Editorial team</a></li>
<li id="menu-item-5342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a href="http://www.linuxnix.com/support-us/">Support us</a></li>
<li id="menu-item-5382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5382"><a href="http://www.linuxnix.com/advertise-on-linuxnix-com/">Advertise</a></li>
<li id="menu-item-5405" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5405"><a href="http://www.linuxnix.com/contact-us/">Contact Us</a></li>
<li id="menu-item-3350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3350"><a href="http://www.linuxnix.com/testimonials/">Testimonials</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	
	<div class="et_social_pin_images_outer">
					<div class="et_social_pinterest_window">
						<div class="et_social_modal_header"><h3>Pin It on Pinterest</h3><span class="et_social_close"></span></div>
						<div class="et_social_pin_images" data-permalink="http://www.linuxnix.com/basics-of-selinux-in-linux/" data-title="Basics of SELinux in Linux" data-post_id="138"></div>
					</div>
				</div><div class="et_social_sidebar_networks et_social_visible_sidebar et_social_slideright et_social_animated et_social_rectangle et_social_sidebar_flip et_social_withtotalcount et_social_mobile_on et_social_sidebar_networks_right">
					<div class="et_social_totalcount et_social_dark">
							<span class="et_social_totalcount_count et_social_total_share" data-post_id="138"></span>
							<span class="et_social_totalcount_label">Shares</span>
						</div>
					<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;t=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_facebook"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="https://twitter.com/share?text=Basics%20of%20SELinux%20in%20Linux&#038;url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;via=" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_twitter"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_googleplus">
									<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;t=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_googleplus"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_buffer">
									<a href="https://bufferapp.com/add?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;title=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="buffer" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_buffer"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_digg">
									<a href="https://digg.com/submit?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;title=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="digg" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_digg"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_evernote">
									<a href="https://www.evernote.com/clip.action?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;title=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="evernote" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_evernote"></i>
										
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_all_button">
								<a href="#" rel="nofollow" data-location="sidebar" data-page_id="138" data-permalink="http://www.linuxnix.com/basics-of-selinux-in-linux/" data-title="Basics of SELinux in Linux" class="et_social_open_all">
									<i class="et_social_icon et_social_icon_all_button"></i>
									<span class="et_social_overlay"></span>
								</a>
							</li></ul>
					<span class="et_social_hide_sidebar et_social_icon"></span>
				</div><div class="et_social_mobile_button"></div>
					<div class="et_social_mobile et_social_fadein">
						<div class="et_social_heading">Share This</div>
						<span class="et_social_close"></span>
						<div class="et_social_networks et_social_simple et_social_rounded et_social_left">
							<ul class="et_social_icons_container"><li class="et_social_facebook">
									<a href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;t=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_facebook"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Facebook</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_twitter">
									<a href="https://twitter.com/share?text=Basics%20of%20SELinux%20in%20Linux&#038;url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;via=" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_twitter"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Twitter</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_googleplus">
									<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;t=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_googleplus"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Google+</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_buffer">
									<a href="https://bufferapp.com/add?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;title=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="buffer" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_buffer"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Buffer</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_digg">
									<a href="https://digg.com/submit?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;title=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="digg" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_digg"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Digg</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_evernote">
									<a href="https://www.evernote.com/clip.action?url=http%3A%2F%2Fwww.linuxnix.com%2Fbasics-of-selinux-in-linux%2F&#038;title=Basics%20of%20SELinux%20in%20Linux" class="et_social_share" rel="nofollow" data-social_name="evernote" data-post_id="138" data-social_type="share" data-location="sidebar">
										<i class="et_social_icon et_social_icon_evernote"></i>
										<div class="et_social_network_label"><div class="et_social_networkname">Evernote</div></div>
										
										<span class="et_social_overlay"></span>
									</a>
								</li><li class="et_social_all_button">
								<a href="#" rel="nofollow" data-location="sidebar" data-page_id="138" data-permalink="http://www.linuxnix.com/basics-of-selinux-in-linux/" data-title="Basics of SELinux in Linux" class="et_social_open_all">
									<i class="et_social_icon et_social_icon_all_button"></i>
									<span class="et_social_overlay"></span>
								</a>
							</li></ul>
						</div>
					</div>
					<div class="et_social_mobile_overlay"></div>        <style type="text/css" id="inc-opt-styles"> .inc_optin_1 .wpoi-hustle .wpoi-optin{ background: #38454E;}  .inc_optin_1 .wpoi-hustle h2.wpoi-title{ color: #FDFDFD;}  .inc_optin_1 .wpoi-hustle .wpoi-message p a{ color: #38C5B5;}  .inc_optin_1 .wpoi-hustle .wpoi-message, .inc_optin_1.wpoi-hustle .wpoi-message p{ color: #ADB5B7;}  .inc_optin_1 .wpoi-hustle .wpoi-message p a:hover{ color: #49E2D1;}  .inc_optin_1 .wpoi-hustle .wpoi-form{ background: #5D7380;}  .inc_optin_1 .wpoi-hustle form .wpoi-element{ background: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form .wpoi-element:hover{ background: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form .wpoi-element:active, .inc_optin_1.wpoi-hustle form .wpoi-element:focus{ background: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form .wpoi-element label, .inc_optin_1.wpoi-hustle form .wpoi-element label span, .inc_optin_1.wpoi-hustle form .wpoi-element label span, .inc_optin_1.wpoi-hustle form .wphi-font{ color: #ADB5B7;}  .inc_optin_1 .wpoi-hustle form button{ background: #38C5B5;}  .inc_optin_1 .wpoi-hustle form button{ color: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form > .wpoi-element input{ color: #363B3F;}  .inc_optin_1 .wpoi-hustle form > .wpoi-element input:hover{ color: #363B3F;}  .inc_optin_1 .wpoi-hustle form > .wpoi-element input:active, .inc_optin_1.wpoi-hustle form > .wpoi-element input:focus{ color: #363B3F;}  .inc_optin_1 .wpoi-hustle form .i-error, .inc_optin_1.wpoi-hustle form .i-error + span{ color: #C63D2B;}  .inc_optin_1 .wpoi-hustle form button:hover{ background: #49E2D1;}  .inc_optin_1 .wpoi-hustle form button:active, .inc_optin_1.wpoi-hustle form button:focus{ background: #49E2D1;}  .inc_optin_1 .wpoi-hustle form button:hover{ color: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form button:active, .inc_optin_1.wpoi-hustle form button:focus{ color: #FDFDFD;}  .inc_optin_1 .wpoi-hustle .wpoi-success-message .wphi-font{ color: #38C5B5;}  .inc_optin_1 .wpoi-hustle .wpoi-success-message .wpoi-content, .inc_optin_1.wpoi-hustle .wpoi-success-message .wpoi-content p{ color: #FDFDFD;}  .inc_optin_1 a.inc-opt-close-btn, .inc_optin_1a.inc-opt-close-btn:visited{ color: #38C5B5;}  .inc_optin_1 .wpoi-nsa > a, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again{ color: #38C5B5;}  .inc_optin_1 .wpoi-popup-overlay{ background: rgba(54,59,63,0.8);}  .inc_optin_1 a.inc-opt-close-btn:hover{ color: #38C5B5;}  .inc_optin_1 a.inc-opt-close-btn:active, .inc_optin_1a.inc-opt-close-btn:focus{ color: #38C5B5;}  .inc_optin_1 .wpoi-nsa > a:hover, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again:hover{ color: #38C5B5;}  .inc_optin_1 .wpoi-nsa > a:active, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again:active, .inc_optin_1.wpoi-nsa > a:focus, .inc_optin_1.wpoi-nsa > a.inc_opt_never_see_again:focus{ color: #38C5B5;}  .inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="radio"] + label:before{ background: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="radio"] + label:after{ background: #38C5B5;}  .inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="checkbox"] + label:before{ background: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="checkbox"]:checked + label:before{ color: #38C5B5;}  .inc_optin_1 .wpoi-hustle form .wpoi-mcg-list-name, .inc_optin_1.wpoi-hustle .wpoi-submit-failure{ color: #FDFDFD;}  .inc_optin_1 .wpoi-hustle form .wpoi-mcg-option input[type="checkbox"] + label, .inc_optin_1.wpoi-hustle form .wpoi-mcg-option input[type="radio"] + label{ color: #ADB5B7;}  .inc_optin_1 .wpoi-success-icon path { fill: #1FC5B6 } .inc_optin_1 .wpoi-hustle .wpoi-optin{box-shadow:0px 0px 0px #000000} .inc_optin_1 .wpoi-hustle .wpoi-optin{border-radius:0px;} .inc_optin_1 .wpoi-hustle form button{border-radius: 0px !important;} .inc_optin_1 .wpoi-hustle form .wpoi-element{border-radius: 0px;} .wpmui-popup.inc_optin_1{border-radius:0px;}</style>
        <script id="optin-layout-two" type="text/template">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</script>
        <style type="text/css" id="hustle-cc-styles"></style>
        



<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/d1f15.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","pageurl":"http:\/\/www.linuxnix.com\/basics-of-selinux-in-linux\/","stats_nonce":"87819ff76e","share_counts":"48ee04ef3e","follow_counts":"8a86e273d5","total_counts":"3001d56b97","media_single":"85a21f2f32","media_total":"8818a45451","generate_all_window_nonce":"5c1cdf508f","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>

<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/39b3b.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var Optins = {"IncOpt58e0f84c024ac":{"settings":{"shortcode_id":"newsletter","popup":{"enabled":"1","animation_in":"fadein","animation_out":"fadein","appear_after":"scrolled","appear_after_scroll":"scrolled","appear_after_time_val":"5","appear_after_time_unit":"seconds","appear_after_page_portion_val":"90","appear_after_page_portion_unit":"%","appear_after_element_val":"","add_never_see_this_message":"false","close_button_acts_as_never_see_again":"false","never_see_expiry":"0","show_on_all_posts":"true","excluded_posts":[],"selected_posts":[],"show_on_all_pages":"true","excluded_pages":[],"selected_pages":[],"show_on_all_cats":"true","show_on_these_cats":[],"show_on_all_tags":"true","show_on_these_tags":[],"conditions":{"pages":{"filter_type":"only"},"tags":{"filter_type":"only"},"posts":{"filter_type":"except"},"categories":{"filter_type":"except"}},"trigger_on_time":"immediately","trigger_on_element_click:":"","trigger_on_exit":"false","trigger_on_adblock":"false","trigger_on_adblock_timed":"false","trigger_on_adblock_timed_val":"180","trigger_on_adblock_timed_unit":"seconds","on_exit_trigger_once_per_session":"true","trigger_on_element_click":"","display":true,"is_test":false},"shortcode":{"enabled":"true","display":true,"is_test":false},"widget":{"enabled":"true","display":true,"is_test":false}},"design":{"success_message":"<p>Congratulations! You have been subscribed to {name}<\/p>","form_location":"1","elements":["image"],"image_location":"left","image_style":"cover","image_src":"","colors":{"customize":"false","palette":"gray_slate","main_background":"#38454E","form_background":"#5D7380","button_background":"#38C5B5","button_label":"#FDFDFD","title_color":"#FDFDFD","content_color":"#ADB5B7","fields_background":"#FDFDFD","fields_color":"#363B3F","link_color":"#38C5B5","link_hover_color":"#49E2D1","fields_hover_background":"#FDFDFD","fields_active_background":"#FDFDFD","label_color":"#ADB5B7","fields_hover_color":"#363B3F","fields_active_color":"#363B3F","error_color":"#C63D2B","button_hover_background":"#49E2D1","button_active_background":"#49E2D1","button_hover_label":"#FDFDFD","button_active_label":"#FDFDFD","checkmark_color":"#38C5B5","success_color":"#FDFDFD","close_color":"#38C5B5","nsa_color":"#38C5B5","overlay_background":"rgba(54,59,63,0.8)","close_hover_color":"#38C5B5","close_active_color":"#38C5B5","radio_background":"#FDFDFD","radio_checked_background":"#38C5B5","checkbox_background":"#FDFDFD","checkbox_checked_color":"#38C5B5","mcg_title_color":"#FDFDFD","mcg_label_color":"#ADB5B7","nsa_hover_color":"#38C5B5","nsa_active_color":"#38C5B5","_id":"gray_slate","label":"Gray Slate","button_label_color":""},"borders":{"rounded_corners":"true","corners_radius":"0","fields_corners_radius":"0","button_corners_radius":"0","drop_shadow":"false","dropshadow_value":"0","shadow_color":"#000000","fields_style":"joined","rounded_form_fields":"true","rounded_form_button":"true"},"opening_animation":"","closing_animation":"","css":"","input_icons":"animated_icon","on_submit":"success_message","on_submit_page_id":"","on_success":"remain","on_success_time":"0","on_success_unit":"s","customize_css":"false","page_redirect_url":""},"data":{"optin_id":"1","blog_id":"1","optin_name":"Newsletter","optin_title":"eg. Get 50% Early-bird Special","optin_message":"<p>Please fill in the form and submit to subscribe<\/p>","optin_mail_list":"","optin_provider":"","active":"1","test_mode":"0","api_key":"TheLinuxJuggernaut","test_types":null,"save_to_local":1},"shortcode":{"enabled":"true"},"widget":{"enabled":"true"},"provider_args":null}};
var inc_opt = {"ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","page_id":"138","page_type":"post","is_upfront":"","adblock_detector_js":"http:\/\/www.linuxnix.com\/wp-content\/plugins\/wordpress-popup\/assets\/js\/front\/ads.js","l10n":{"never_see_again":"Never see this message again","success":"Congratulations! You have been subscribed to {name}","submit_failure":"Something went wrong, please try again.","test_cant_submit":"Form can't be submitted in test mode."}};
var hustle_vars = {"ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","page_id":"138","page_type":"post","is_upfront":"","adblock_detector_js":"http:\/\/www.linuxnix.com\/wp-content\/plugins\/wordpress-popup\/assets\/js\/front\/ads.js","l10n":{"never_see_again":"Never see this message again","success":"Congratulations! You have been subscribed to {name}","submit_failure":"Something went wrong, please try again.","test_cant_submit":"Form can't be submitted in test mode."}};
var Hustle_Custom_Contents = [];
/* ]]> */
</script>
<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/ea02e.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var viewsCacheL10n = {"admin_ajax_url":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","post_id":"138"};
/* ]]> */
</script>





<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/fc934.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"http:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","rating_nonce":"0e277dbc3b","timeline_nonce":"fe8c0dc9d2","blog_feed_nonce":"1b64d1beb5","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address."};
/* ]]> */
</script>





<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/4abc4.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var et_pb_custom = {"ajaxurl":"http:\/\/www.linuxnix.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"http:\/\/www.linuxnix.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"6f1febab8a","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","is_divi_theme_used":"","widget_search_selector":".widget_search"};
/* ]]> */
</script>

<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/6edf5.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.5.7","language":""},"disqusIdentifier":"138 http:\/\/www.linuxnix.com\/2009\/05\/disabling-selinux\/","disqusShortname":"linuxnix","disqusTitle":"Basics of SELinux in Linux","disqusUrl":"http:\/\/www.linuxnix.com\/basics-of-selinux-in-linux\/","options":{"manualSync":false},"postId":"138"};
/* ]]> */
</script>
<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/f089b.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"linuxnix"};
/* ]]> */
</script>
<script type="text/javascript" src="http://www.linuxnix.com/wp-content/cache/minify/6ce07.js"></script>

</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 2978/3143 objects using apc
Page Caching using apc
Content Delivery Network via N/A
Minified using disk
Database Caching 38/66 queries in 0.042 seconds using apc

 Served from: www.linuxnix.com @ 2017-04-02 13:10:36 by W3 Total Cache -->